# Failed to complete action: delete\_indices

**URL:** <https://discuss.elastic.co/t/failed-to-complete-action-delete-indices/128446>\
**Category:** Elasticsearch\
**Created:** [April 18, 2018, 3:26am UTC](https://discuss.elastic.co/t/failed-to-complete-action-delete-indices/128446 "2018-04-18T03:26:40Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![ardel](https://avatars.discourse-cdn.com/v4/letter/a/a9a28c/32.png) [@ardel](https://discuss.elastic.co/u/ardel)\
**Post date:** [April 18, 2018, 3:26am UTC](https://discuss.elastic.co/t/failed-to-complete-action-delete-indices/128446/1 "2018-04-18T03:26:41Z")

</div>

Hello All,

I was receiving this error upon executing a delete\_indices action.

Failed to complete action: delete\_indices. \<class 'curator.exceptions.FailedExecution'\>: Exception encountered. Rerun with loglevel DEBUG and/or check Elasticsearch logs for more information. Exception: TransportError(400, u'illegal\_argument\_exception', u'[-U9WmRx][x.x.x.x:9300][indices:admin/delete]')

Is there anyone who can help me to find the reason why this is being encountered. Thank you in Advance.

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [April 18, 2018, 4:05am UTC](https://discuss.elastic.co/t/failed-to-complete-action-delete-indices/128446/2 "2018-04-18T04:05:29Z")

</div>

A `400` error indicates that the client made an illegal request (hence the `illegal_argument_exception`).

The bigger concern to me is that it is a `TransportError` and the port listed after the IP is `9300`, which is the Transport Protocol, and not the normal HTTP/REST protocol which Curator uses to interact with Elasticsearch. This suggests to me that Curator successfully made a request to a node (using HTTP), but the node-to-node traffic replied with that error. `indices:admin/delete` suggests that the user Curator is connecting as does not have the proper credentials to perform the delete.

These are my off-the-top-of-my-head speculations. Without more debug logging, I won't be able to do more. You may even need to set `blacklist: []` (in addition to `loglevel: DEBUG`) to not hide the elasticsearch request log lines.

---

<div class="post-metadata">

**Author:** ![ardel](https://avatars.discourse-cdn.com/v4/letter/a/a9a28c/32.png) [@ardel](https://discuss.elastic.co/u/ardel)\
**Post date:** [April 18, 2018, 4:10am UTC](https://discuss.elastic.co/t/failed-to-complete-action-delete-indices/128446/3 "2018-04-18T04:10:21Z")

</div>

Hello Aaron,

We encountered another error which is almost the same but with new kind of error:

Failed to complete action: delete\_indices. \<class 'curator.exceptions.FailedExecution'\>: Exception encountered. Rerun with loglevel DEBUG and/or check Elasticsearch logs for more information. Exception: ConnectionTimeout caused by - ReadTimeoutError(HTTPSConnectionPool(I\_REMOVED\_THIS\_PART', port=443): Read timed out. (read timeout=30))

---

<div class="post-metadata">

**Author:** ![ardel](https://avatars.discourse-cdn.com/v4/letter/a/a9a28c/32.png) [@ardel](https://discuss.elastic.co/u/ardel)\
**Post date:** [April 18, 2018, 4:40am UTC](https://discuss.elastic.co/t/failed-to-complete-action-delete-indices/128446/4 "2018-04-18T04:40:38Z")

</div>

By the way, we are using AWS managed services so we cannot create a user in AWS elasticsearch

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 18, 2018, 6:32am UTC](https://discuss.elastic.co/t/failed-to-complete-action-delete-indices/128446/5 "2018-04-18T06:32:01Z")

</div>

(not directly related):

Did you look at [cloud.elastic.co](http://cloud.elastic.co) and [https://aws.amazon.com/marketplace/pp/B01N6YCISK](https://aws.amazon.com/marketplace/pp/B01N6YCISK) ?

---

<div class="post-metadata">

**Author:** ![ardel](https://avatars.discourse-cdn.com/v4/letter/a/a9a28c/32.png) [@ardel](https://discuss.elastic.co/u/ardel)\
**Post date:** [April 18, 2018, 8:24am UTC](https://discuss.elastic.co/t/failed-to-complete-action-delete-indices/128446/6 "2018-04-18T08:24:38Z")

</div>

HI David,

Our instances are purely in AWS now so I'm afraid this will not be approved.

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [April 18, 2018, 1:12pm UTC](https://discuss.elastic.co/t/failed-to-complete-action-delete-indices/128446/7 "2018-04-18T13:12:27Z")

</div>

The long story short version is that the HTTP pool you are connecting to has a `timeout` value. If you set the `timeout` higher than `30` in your client definition (I understand you're using a lambda), and that still happens, then there's nothing I can do for you.

The `timeout` value goes into where you setup the client, e.g. `client = elasticsearch.Elasticsearch(host=xxx, port=xxx, timeout=30)`.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 18, 2018, 1:46pm UTC](https://discuss.elastic.co/t/failed-to-complete-action-delete-indices/128446/8 "2018-04-18T13:46:05Z")

</div>

Cloud by elastic is running on AWS as well. What do you mean?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 16, 2018, 1:46pm UTC](https://discuss.elastic.co/t/failed-to-complete-action-delete-indices/128446/9 "2018-05-16T13:46:37Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
