# Failed to connect to backoff(elasticsearch(http://localhost:9200))

**URL:** https://discuss.elastic.co/t/failed-to-connect-to-backoff-elasticsearch-http-localhost-9200/181995
**Category:** Elasticsearch
**Created:** [May 21, 2019, 12:19pm UTC](https://discuss.elastic.co/t/failed-to-connect-to-backoff-elasticsearch-http-localhost-9200/181995 "2019-05-21T12:19:56Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![faad021](https://avatars.discourse-cdn.com/v4/letter/f/9fc348/32.png) [@faad021](https://discuss.elastic.co/u/faad021)
#### Post date: [May 21, 2019, 12:19pm UTC](https://discuss.elastic.co/t/failed-to-connect-to-backoff-elasticsearch-http-localhost-9200/181995/1 "2019-05-21T12:19:56Z")

</div>

Hello everyone,  
I have been facing a problem here configuring Filebeat. I keep on having failures. below is my configuration and log.

```
#=========================== Filebeat inputs =============================
filebeat.inputs:
- type: log
  enabled: true
  paths: C:\ProgramData\Elastic\Elasticsearch\logs\*.log
    
#============================= Filebeat modules ===============================

filebeat.config.modules:
  path: ${path.config}/modules.d/*.yml
  reload.enabled: false

#==================== Elasticsearch template setting ==========================

setup.template.settings:
  index.number_of_shards: 1
  #index.codec: best_compression
  #_source.enabled: false

#============================== Kibana =====================================

setup.kibana:

#================================ Outputs =====================================

# Configure what output to use when sending the data collected by the beat.

#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["localhost:9200"]

processors:
  - add_host_metadata: ~
  - add_cloud_metadata: ~

```

and here is my log:

> 2019-05-21T14:18:26.285+0200 INFO [monitoring] log/log.go:144 Non-zero metrics in the last 30s {"monitoring": {"metrics": {"beat":{"cpu":{"system":{"ticks":453,"time":{"ms":16}},"total":{"ticks":953,"time":{"ms":16},"value":953},"user":{"ticks":500}},"handles":{"open":303},"info":{"ephemeral\_id":"527c9c1f-392f-40c8-8aa5-67aa1a4e8029","uptime":{"ms":720316}},"memstats":{"gc\_next":4241168,"memory\_alloc":2902392,"memory\_total":12133216,"rss":12288}},"filebeat":{"harvester":{"open\_files":0,"running":0}},"libbeat":{"config":{"module":{"running":0}},"output":{"read":{"bytes":673},"write":{"bytes":260}},"pipeline":{"clients":1,"events":{"active":28,"retry":28}}},"registrar":{"states":{"current":5}}}}}  
> 2019-05-21T14:18:47.570+0200 ERROR pipeline/output.go:100 Failed to connect to backoff(elasticsearch([http://localhost:9200](http://localhost:9200))): Connection marked as failed because the onConnect callback failed: This Beat requires the default distribution of Elasticsearch. Please upgrade to the default distribution of Elasticsearch from [elastic.co](http://elastic.co), or downgrade to the oss-only distribution of beats  
> 2019-05-21T14:18:47.570+0200 INFO pipeline/output.go:93 Attempting to reconnect to backoff(elasticsearch([http://localhost:9200](http://localhost:9200))) with 21 reconnect attempt(s)  
> 2019-05-21T14:18:47.572+0200 INFO elasticsearch/client.go:734 Attempting to connect to Elasticsearch version 5.5.0  
> 2019-05-21T14:18:56.281+0200 INFO [monitoring] log/log.go:144 Non-zero metrics in the last 30s {"monitoring": {"metrics": {"beat":{"cpu":{"system":{"ticks":468,"time":{"ms":31}},"total":{"ticks":968,"time":{"ms":31},"value":968},"user":{"ticks":500}},"handles":{"open":303},"info":{"ephemeral\_id":"527c9c1f-392f-40c8-8aa5-67aa1a4e8029","uptime":{"ms":750315}},"memstats":{"gc\_next":4238992,"memory\_alloc":2310384,"memory\_total":12384576,"rss":49152}},"filebeat":{"harvester":{"open\_files":0,"running":0}},"libbeat":{"config":{"module":{"running":0}},"output":{"read":{"bytes":673},"write":{"bytes":260}},"pipeline":{"clients":1,"events":{"active":28,"retry":28}}},"registrar":{"states":{"current":5}}}}}  
> 2019-05-21T14:19:23.079+0200 ERROR pipeline/output.go:100 Failed to connect to backoff(elasticsearch([http://localhost:9200](http://localhost:9200))): Connection marked as failed because the onConnect callback failed: This Beat requires the default distribution of Elasticsearch. Please upgrade to the default distribution of Elasticsearch from [elastic.co](http://elastic.co), or downgrade to the oss-only distribution of beats  
> 2019-05-21T14:19:23.079+0200 INFO pipeline/output.go:93 Attempting to reconnect to backoff(elasticsearch([http://localhost:9200](http://localhost:9200))) with 22 reconnect attempt(s)  
> 2019-05-21T14:19:23.081+0200 INFO elasticsearch/client.go:734 Attempting to connect to Elasticsearch version 5.5.0

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 18, 2019, 12:26pm UTC](https://discuss.elastic.co/t/failed-to-connect-to-backoff-elasticsearch-http-localhost-9200/181995/2 "2019-06-18T12:26:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
