# Failed to connect to backoff, Filebeat on Server B and ELK on local machine

**URL:** <https://discuss.elastic.co/t/failed-to-connect-to-backoff-filebeat-on-server-b-and-elk-on-local-machine/215970>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [January 22, 2020, 1:28am UTC](https://discuss.elastic.co/t/failed-to-connect-to-backoff-filebeat-on-server-b-and-elk-on-local-machine/215970 "2020-01-22T01:28:09Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mehak\_Bhargava](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mehak_bhargava/32/54750_2.png) [@Mehak\_Bhargava](https://discuss.elastic.co/u/Mehak_Bhargava)\
**Post date:** [January 22, 2020, 1:28am UTC](https://discuss.elastic.co/t/failed-to-connect-to-backoff-filebeat-on-server-b-and-elk-on-local-machine/215970/1 "2020-01-22T01:28:09Z")

</div>

Filebeat is running on server B which read logs and pushes to ELK logstash on local Machine A.

I want to use filebeat to send real time log files from the server, and point it to my local machine where Elasticsearch, logstahs, kibana is running. But When I run Filebeat on the Server B, I get this error.

In services, I tried to see if FIlebeat started but it doesnt show up there too.

```auto
2020-01-21T16:59:59.149-0800	ERROR	pipeline/output.go:100	Failed to connect to backoff(async(tcp://192.168.40.53:5044)): dial tcp 192.168.40.53:5044: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
2020-01-21T16:59:59.149-0800	INFO	pipeline/output.go:93	Attempting to reconnect to backoff(async(tcp://192.168.40.53:5044)) with 1 reconnect attempt(s)
2020-01-21T17:00:04.005-0800	INFO	[monitoring]	log/log.go:145	Non-zero metrics in the last 30s	{"monitoring": {"metrics": {"beat":{"cpu":{"system":{"ticks":78,"time":{"ms":78}},"total":{"ticks":406,"time":{"ms":406},"value":406},"user":{"ticks":328,"time":{"ms":328}}},"handles":{"open":206},"info":{"ephemeral_id":"0a360c35-31e5-4e4a-9a67-1e6cca6c02fa","uptime":{"ms":30186}},"memstats":{"gc_next":29718816,"memory_alloc":21262304,"memory_total":42124048,"rss":49532928},"runtime":{"goroutines":30}},"filebeat":{"events":{"active":5504,"added":5506,"done":2},"harvester":{"open_files":1,"running":1,"started":1}},"libbeat":{"config":{"module":{"running":0},"reloads":1},"output":{"type":"logstash"},"pipeline":{"clients":1,"events":{"active":4117,"filtered":1389,"published":4116,"retry":2048,"total":5506}}},"registrar":{"states":{"current":1,"update":2},"writes":{"success":2,"total":2}},"system":{"cpu":{"cores":8}}}}}
2020-01-21T17:00:22.194-0800	ERROR	pipeline/output.go:100	Failed to connect to backoff(async(tcp://192.168.40.53:5044)): dial tcp 192.168.40.53:5044: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

```

---

<div class="post-metadata">

**Author:** ![chandra2037](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chandra2037/32/72142_2.png) [@chandra2037](https://discuss.elastic.co/u/chandra2037)\
**Post date:** [January 22, 2020, 3:20am UTC](https://discuss.elastic.co/t/failed-to-connect-to-backoff-filebeat-on-server-b-and-elk-on-local-machine/215970/2 "2020-01-22T03:20:16Z")

</div>

Hi @Mehak_Bhargava,

maybe try this  
[https://www.elastic.co/guide/en/beats/filebeat/current/connection-problem.html#connection-problem](https://www.elastic.co/guide/en/beats/filebeat/current/connection-problem.html#connection-problem)

---

<div class="post-metadata">

**Author:** ![Mehak\_Bhargava](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mehak_bhargava/32/54750_2.png) [@Mehak\_Bhargava](https://discuss.elastic.co/u/Mehak_Bhargava)\
**Post date:** [January 25, 2020, 1:35am UTC](https://discuss.elastic.co/t/failed-to-connect-to-backoff-filebeat-on-server-b-and-elk-on-local-machine/215970/3 "2020-01-25T01:35:50Z")

</div>

Fixed it. harvester wasnt reading any file because of YAML file formatting. This is working now.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 22, 2020, 1:35am UTC](https://discuss.elastic.co/t/failed-to-connect-to-backoff-filebeat-on-server-b-and-elk-on-local-machine/215970/4 "2020-02-22T01:35:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
