# Failed to connect to backoff

**URL:** <https://discuss.elastic.co/t/failed-to-connect-to-backoff/179398>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [May 2, 2019, 3:04pm UTC](https://discuss.elastic.co/t/failed-to-connect-to-backoff/179398 "2019-05-02T15:04:07Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![sblancocr](https://avatars.discourse-cdn.com/v4/letter/s/ee59a6/32.png) [@sblancocr](https://discuss.elastic.co/u/sblancocr)\
**Post date:** [May 2, 2019, 3:04pm UTC](https://discuss.elastic.co/t/failed-to-connect-to-backoff/179398/1 "2019-05-02T15:04:08Z")

</div>

Hi

I installed a metricbeat in the server... and it have next configuration.

_metricbeat.config.modules:_  
_path: ${path.config}/modules.d/_.yml\*  
_reload.enabled: false_

_setup.template.settings:_  
_index.number\_of\_shards: 1_  
_index.codec: best\_compression_

_processors:_  
_- add\_host\_metadata: ~_  
_- add\_cloud\_metadata: ~_  
_setup.kibana:_  
_host: "ci-elk-kibana.ucr.ac.cr:5601"_

_output.logstash:_  
_hosts: ["ci-elk-logstash-01.ucr.ac.cr:5044"]_  
_ssl.certificate\_authorities: ["/etc/pki/tls/certs/logstash-01-forwarder.crt"]_  
_ssl.certificate: "/etc/pki/tls/certs/logstash-01-forwarder.crt"_  
_ssl.key: "/etc/pki/tls/private/logstash-01-forwarder.key"_

But in the metricbeat log show this error:

**2019-05-02T08:30:35.308-0600 ERROR pipeline/output.go:100 Failed to connect to backoff(async(tcp://ci-elk-logstash-01.ucr.ac.cr:5044)): dial tcp 172.16.48.93:5044: connect: no route to host**

The logstash config is next:

input {  
beats {  
port =\> 5044  
ssl =\> true  
ssl\_certificate =\> "/etc/pki/tls/certs/logstash-01-forwarder.crt"  
ssl\_key =\> "/etc/pki/tls/private/logstash-01-forwarder.key"  
client\_inactivity\_timeout =\> 0  
}  
}

filter {  
if [type] == "syslog" {  
grok {  
match =\> { "message" =\> "%{SYSLOGTIMESTAMP:syslog\_timestamp} %{SYSLOGHOST:syslog\_hostname} %{DATA:syslog\_program}(?:[%{POSINT:syslog\_pid}])?: %{GREEDYDATA:syslog\_message}" }  
}  
date {  
match =\> ["syslog\_timestamp", "MMM d HH:mm:ss", "MMM dd HH:mm:ss"]  
}  
}  
}

output {  
elasticsearch {  
hosts =\> ["ci-elk-client-01.ucr.ac.cr:9200"]  
index =\> "%{[@metadata][beat]}-%{+YYYY.MM.dd}"  
}  
}

Can any help me?

Thanks a lot...

---

<div class="post-metadata">

**Author:** ![sblancocr](https://avatars.discourse-cdn.com/v4/letter/s/ee59a6/32.png) [@sblancocr](https://discuss.elastic.co/u/sblancocr)\
**Post date:** [May 2, 2019, 3:37pm UTC](https://discuss.elastic.co/t/failed-to-connect-to-backoff/179398/2 "2019-05-02T15:37:48Z")

</div>

I reslolve this case...

Do not add port permissions in the iptables

Thaks.

---

<div class="post-metadata">

**Author:** ![Mario\_Castro](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mario_castro/32/35107_2.png) [@Mario\_Castro](https://discuss.elastic.co/u/Mario_Castro)\
**Post date:** [May 3, 2019, 10:14am UTC](https://discuss.elastic.co/t/failed-to-connect-to-backoff/179398/3 "2019-05-03T10:14:23Z")

</div>

🙂 Nice that you found a solution!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 31, 2019, 10:14am UTC](https://discuss.elastic.co/t/failed-to-connect-to-backoff/179398/4 "2019-05-31T10:14:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
