# Failed to connect to localhost port 9200

**URL:** https://discuss.elastic.co/t/failed-to-connect-to-localhost-port-9200/53216
**Category:** Elasticsearch
**Created:** [June 18, 2016, 6:56pm UTC](https://discuss.elastic.co/t/failed-to-connect-to-localhost-port-9200/53216 "2016-06-18T18:56:08Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Madhu\_CM](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/madhu_cm/32/10398_2.png) [@Madhu\_CM](https://discuss.elastic.co/u/Madhu_CM)
#### Post date: [June 18, 2016, 6:56pm UTC](https://discuss.elastic.co/t/failed-to-connect-to-localhost-port-9200/53216/1 "2016-06-18T18:56:08Z")

</div>

Hi,  
I have installed elasticsearch 2.3.3 on ubuntu 14.04.  
During elasticsearch restart/start I see OK message as below. But when i execute service elasticsearch status it says "\> elasticsearch is not running"

```
root@madhu:/var/log/elasticsearch# sudo service elasticsearch restart
 * Stopping Elasticsearch Server [OK]

 * Starting Elasticsearch Server [OK]

root@madhu:/var/log/elasticsearch# service elasticsearch status
 * elasticsearch is not running

```

I am not seeing any error message log in /var/log/elasticsearch

```
er increasing to at least [65536]
[2016-06-18 15:28:07,887][INFO][node] [Flying Tiger] version[2.3.3], pid[7807], build[218bdf1/2016-05-17T15:40:04Z]
[2016-06-18 15:28:07,892][INFO][node] [Flying Tiger] initializing ...
[2016-06-18 15:28:09,343][INFO][plugins] [Flying Tiger] modules [reindex, lang-expression, lang-groovy], plugins [], sites []
[2016-06-18 15:28:09,404][INFO][env] [Flying Tiger] using [1] data paths, mounts [[/ (/dev/sda1)]], net usable_space [2.2gb], net total_space [7.2gb], spins? [possibly], types [ext4]
[2016-06-18 15:28:09,404][INFO][env] [Flying Tiger] heap size [1015.6mb], compressed ordinary object pointers [true]
[2016-06-18 15:28:09,405][WARN][env] [Flying Tiger] max file descriptors [65535] for elasticsearch process likely too low, consider increasing to at least [65536]
[2016-06-18 15:38:43,167][INFO][node] [Madame Hydra] version[2.3.3], pid[7895], build[218bdf1/2016-05-17T15:40:04Z]
[2016-06-18 15:38:43,168][INFO][node] [Madame Hydra] initializing ...
[2016-06-18 15:38:46,206][INFO][plugins] [Madame Hydra] modules [reindex, lang-expression, lang-groovy], plugins [], sites []
[2016-06-18 15:38:46,387][INFO][env] [Madame Hydra] using [1] data paths, mounts [[/ (/dev/sda1)]], net usable_space [2.2gb], net total_space [7.2gb], spins? [possibly], types [ext4]
[2016-06-18 15:38:46,387][INFO][env] [Madame Hydra] heap size [1015.6mb], compressed ordinary object pointers [true]
[2016-06-18 15:38:46,387][WARN][env] [Madame Hydra] max file descriptors [65535] for elasticsearch process likely too low, consider increasing to at least [65536]
[2016-06-18 15:41:58,817][INFO][node] [Mercury] version[2.3.3], pid[7989], build[218bdf1/2016-05-17T15:40:04Z]
[2016-06-18 15:41:58,818][INFO][node] [Mercury] initializing ...
[2016-06-18 15:42:00,152][INFO][plugins] [Mercury] modules [reindex, lang-expression, lang-groovy], plugins [], sites []
[2016-06-18 15:42:00,223][INFO][env] [Mercury] using [1] data paths, mounts [[/ (/dev/sda1)]], net usable_space [2.2gb], net total_space [7.2gb], spins? [possibly], types [ext4]
[2016-06-18 15:42:00,224][INFO][env] [Mercury] heap size [1015.6mb], compressed ordinary object pointers [true]
[2016-06-18 15:42:00,224][WARN][env] [Mercury] max file descriptors [65535] for elasticsearch process likely too low, consider increasing to at least [65536]

```

My elasticsearch.yml is as below

```
# Set the bind address to a specific IP (IPv4 or IPv6):
#
network.host: localhost
#
# Set a custom port for HTTP:
#
http.port: 9200

```

Could you please let me what could be the reason for elasticsearch to fail to start ?

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [July 9, 2016, 12:18pm UTC](https://discuss.elastic.co/t/failed-to-connect-to-localhost-port-9200/53216/2 "2016-07-09T12:18:00Z")

</div>

Never mind what the `service` command thinks—have you confirmed that ES really isn't running (check with e.g. `ps aux`)?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 10:36pm UTC](https://discuss.elastic.co/t/failed-to-connect-to-localhost-port-9200/53216/3 "2017-07-05T22:36:50Z")

</div>


