# Failed to connect to postgreslq via logsatash

**URL:** <https://discuss.elastic.co/t/failed-to-connect-to-postgreslq-via-logsatash/298772>\
**Category:** Logstash\
**Created:** [March 3, 2022, 5:47pm UTC](https://discuss.elastic.co/t/failed-to-connect-to-postgreslq-via-logsatash/298772 "2022-03-03T17:47:44Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![francieliton\_araujo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/francieliton_araujo/32/47771_2.png) [@francieliton\_araujo](https://discuss.elastic.co/u/francieliton_araujo)\
**Post date:** [March 3, 2022, 5:47pm UTC](https://discuss.elastic.co/t/failed-to-connect-to-postgreslq-via-logsatash/298772/1 "2022-03-03T17:47:44Z")

</div>

it's the first time I'm trying to access a postgresql database through logstash. however there are dnado errors, can you help me. Below is conf and error.

```auto
input{
jdbc{
        jdbc_driver_library => "/usr/share/java/postgresql-jdbc.jar"
        jdbc_driver_class => "org.postgresql.Driver"
        jdbc_connection_string => "jdbc:postgresql://x.x.x.x:5432/banco"
        jdbc_user => " x"
        jdbc_password => "y"    
        statement => "
############ QUERY MYSQL
select

*

FROM
 events e
WHERE
  LIMIT
 1

"

 }
}
filter{
}
output{

stdout {
    codec => rubydebug
  }
}

```

error:  
`´`  
[ERROR] 2022-03-03 14:25:06.697 [[main]\<jdbc] jdbc - Unable to connect to database. Tried 1 times {:error\_message=\>"Java::OrgPostgresqlUtil::PSQLException: FATAL: no pg\_hba.conf entry for host "X", user " X", database "X", SSL off"}  
[ERROR] 2022-03-03 14:25:06.699 [[main]\<jdbc] javapipeline - A plugin had an unrecoverable error. Will restart this plugin.  
Pipeline\_id:main  
Plugin: \<LogStash::Inputs::Jdbc jdbc\_user=\>" lanlink", jdbc\_password=\>, statement=\>"\n############ QUERY MYSQL\nselect DISTINCT\n-- prodllkzabixauto ZXCVB\n\*\n\nFROM\n events e \nWHERE\n LIMIT\n 1 \n\n", jdbc\_driver\_library=\>"/usr/share/java/postgresql-jdbc.jar", jdbc\_connection\_string=\>"jdbc:postgresql://X:5432/zabbix", id=\>"f408664b97db17798e1c8aaac60a281e0afb717bd864fa1127a1c071ae1efd23", jdbc\_driver\_class=\>"org.postgresql.Driver", type=\>"X", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_c2a8d638-fb93-4309-b447-54a86b75d3eb", enable\_metric=\>true, charset=\>"UTF-8"\>, jdbc\_paging\_enabled=\>false, jdbc\_page\_size=\>100000, jdbc\_validate\_connection=\>false, jdbc\_validation\_timeout=\>3600, jdbc\_pool\_timeout=\>5, sql\_log\_level=\>"info", connection\_retry\_attempts=\>1, connection\_retry\_attempts\_wait\_time=\>0.5, plugin\_timezone=\>"utc", last\_run\_metadata\_path=\>"/root/.logstash\_jdbc\_last\_run", use\_column\_value=\>false, tracking\_column\_type=\>"numeric", clean\_run=\>false, record\_last\_run=\>true, lowercase\_column\_names=\>true, use\_prepared\_statements=\>false\>  
Error: Java::OrgPostgresqlUtil::PSQLException: FATAL: no pg\_hba.conf entry for host "X", user " lanlink", database "zabbix", SSL off  
Exception: Sequel::DatabaseConnectionError  
Stack: org.postgresql.core.v3.ConnectionFactoryImpl.doAuthentication(org/postgresql/core/v3/ConnectionFactoryImpl.java:398)  
org.postgresql.core.v3.ConnectionFactoryImpl.openConnectionImpl(org/postgresql/core/v3/ConnectionFactoryImpl.java:173)  
org.postgresql.core.ConnectionFactory.openConnection(org/postgresql/core/ConnectionFactory.java:64)  
org.postgresql.jdbc2.AbstractJdbc2Connection.(org/postgresql/jdbc2/AbstractJdbc2Connection.java:136)  
org.postgresql.jdbc3.AbstractJdbc3Connection.(org/postgresql/jdbc3/AbstractJdbc3Connection.java:29)  
org.postgresql.jdbc3g.AbstractJdbc3gConnection.(org/postgresql/jdbc3g/AbstractJdbc3gConnection.java:21)  
org.postgresql.jdbc4.AbstractJdbc4Connection.(org/postgresql/jdbc4/AbstractJdbc4Connection.java:31)  
org.postgresql.jdbc4.Jdbc4Connection.(org/postgresql/jdbc4/Jdbc4Connection.java:34)  
org.postgresql.Driver.makeConnection(org/postgresql/Driver.java:393)  
org.postgresql.Driver.connect(org/postgresql/Driver.java:267)  
jdk.internal.reflect.GeneratedMethodAccessor22.invoke(jdk/internal/reflect/GeneratedMethodAccessor22)  
jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(jdk/internal/reflect/DelegatingMethodAccessorImpl.java:43)  
java.lang.reflect.Method.invoke(java/lang/reflect/Method.java:566)  
org.jruby.javasupport.JavaMethod.invokeDirectWithExceptionHandling(org/jruby/javasupport/JavaMethod.java:471)  
org.jruby.javasupport.JavaMethod.invokeDirect(org/jruby/javasupport/JavaMethod.java:329)  
usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_39\_dot\_0.lib.sequel.adapters.jdbc.connect(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.39.0/lib/sequel/adapters/jdbc.rb:239)  
usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_39\_dot\_0.lib.sequel.connection\_pool.make\_new(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.39.0/lib/sequel/connection\_pool.rb:122)  
usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_39\_dot\_0.lib.sequel.connection\_pool.threaded.assign\_connection(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.39.0/lib/sequel/connection\_pool/threaded.rb:209)  
usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_39\_dot\_0.lib.sequel.connection\_pool.threaded.acquire(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.39.0/lib/sequel/connection\_pool/threaded.rb:139)  
usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_39\_dot\_0.lib.sequel.connection\_pool.threaded.hold(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.39.0/lib/sequel/connection\_pool/threaded.rb:91)  
usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_39\_dot\_0.lib.sequel.database.connecting.synchronize(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.39.0/lib/sequel/database/connecting.rb:269)  
usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_39\_dot\_0.lib.sequel.database.connecting.test\_connection(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.39.0/lib/sequel/database/connecting.rb:278)  
usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_39\_dot\_0.lib.sequel.database.misc.initialize(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.39.0/lib/sequel/database/misc.rb:169)  
usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_39\_dot\_0.lib.sequel.database.connecting.connect(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.39.0/lib/sequel/database/connecting.rb:57)  
usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_39\_dot\_0.lib.sequel.core.connect(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.39.0/lib/sequel/core.rb:124)  
usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_integration\_minus\_jdbc\_minus\_5\_dot\_0\_dot\_6.lib.logstash.plugin\_mixins.jdbc.jdbc.jdbc\_connect(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/plugin\_mixins/jdbc/jdbc.rb:114)  
org.jruby.RubyKernel.loop(org/jruby/RubyKernel.java:1442)  
usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_integration\_minus\_jdbc\_minus\_5\_dot\_0\_dot\_6.lib.logstash.plugin\_mixins.jdbc.jdbc.jdbc\_connect(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/plugin\_mixins/jdbc/jdbc.rb:111)  
usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_integration\_minus\_jdbc\_minus\_5\_dot\_0\_dot\_6.lib.logstash.plugin\_mixins.jdbc.jdbc.open\_jdbc\_connection(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/plugin\_mixins/jdbc/jdbc.rb:139)  
usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_integration\_minus\_jdbc\_minus\_5\_dot\_0\_dot\_6.lib.logstash.plugin\_mixins.jdbc.jdbc.execute\_statement(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/plugin\_mixins/jdbc/jdbc.rb:197)  
usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_integration\_minus\_jdbc\_minus\_5\_dot\_0\_dot\_6.lib.logstash.inputs.jdbc.execute\_query(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/inputs/jdbc.rb:316)  
usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_integration\_minus\_jdbc\_minus\_5\_dot\_0\_dot\_6.lib.logstash.inputs.jdbc.run(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/inputs/jdbc.rb:284)  
usr.share.logstash.logstash\_minus\_core.lib.logstash.java\_pipeline.inputworker(/usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb:405)  
usr.share.logstash.logstash\_minus\_core.lib.logstash.java\_pipeline.RUBY$method$inputworker$0$ **VARARGS** (usr/share/logstash/logstash\_minus\_core/lib/logstash//usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb)  
usr.share.logstash.logstash\_minus\_core.lib.logstash.java\_pipeline.start\_input(/usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb:396)  
org.jruby.RubyProc.call(org/jruby/RubyProc.java:318)  
java.lang.Thread.run(java/lang/Thread.java:834)

```auto

```

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [March 7, 2022, 4:37pm UTC](https://discuss.elastic.co/t/failed-to-connect-to-postgreslq-via-logsatash/298772/2 "2022-03-07T16:37:33Z")

</div>

> [@francieliton\_araujo](#):
>
> OrgPostgresqlUtil::PSQLException: FATAL: no pg\_hba.conf entry

It seems your Postgres database is using host based authentication and there is no entry in the [HBA configuration](https://www.postgresql.org/docs/9.2/auth-pg-hba-conf.html) for the IP/hostname of your logstash server.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 4, 2022, 4:37pm UTC](https://discuss.elastic.co/t/failed-to-connect-to-postgreslq-via-logsatash/298772/3 "2022-04-04T16:37:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
