# Failed to construct kafka producer

**URL:** <https://discuss.elastic.co/t/failed-to-construct-kafka-producer/76195>\
**Category:** Logstash\
**Created:** [February 23, 2017, 10:44am UTC](https://discuss.elastic.co/t/failed-to-construct-kafka-producer/76195 "2017-02-23T10:44:27Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![zpp](https://avatars.discourse-cdn.com/v4/letter/z/54ee81/32.png) [@zpp](https://discuss.elastic.co/u/zpp)\
**Post date:** [February 23, 2017, 10:44am UTC](https://discuss.elastic.co/t/failed-to-construct-kafka-producer/76195/1 "2017-02-23T10:44:27Z")

</div>

with Logstash 5.2, I'm testing sending data to kafka (using Kerberos). Below is the kakfa confiugration:

kafka {  
bootstrap\_servers =\> "xxx"  
jaas\_path =\> "/usr/hdp/current/kafka-broker/config/kafka\_client\_jaas.conf"  
kerberos\_config =\> "/etc/krb5.conf"  
security\_protocol =\> "SASL\_PLAINTEXT"  
sasl\_kerberos\_service\_name =\> "kafka"  
topic\_id =\> "test"  
}  
I'm sure that the bootstrap\_servers and jass\_path configurations are correct, as I use the same setting for KafkaConsoleProducer to send data successfully. Logstash failed to startup, giving below exception.

[2017-02-23T10:24:41,255][ERROR][logstash.outputs.kafka] Unable to create Kafka producer from given configuration {:kafka\_error\_message=\>org.apache.kafka.common.KafkaException: Failed to construct kafka producer}  
[2017-02-23T10:24:41,263][ERROR][logstash.agent] Pipeline aborted due to error {:exception=\>org.apache.kafka.common.KafkaException: Failed to construct kafka producer, :backtrace=\>["org.apache.kafka.clients.producer.KafkaProducer.(org/apache/kafka/clients/producer/Ka  
fkaProducer.java:335)", "org.apache.kafka.clients.producer.KafkaProducer.(org/apache/kafka/clients/producer/KafkaProducer.java:188)", "java.lang.reflect.Constructor.newInstance(java/lang/reflect/Constructor.java:423)", "RUBY.create\_producer(/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-kafka-5.1.3/lib/logstash/outputs/kafka.rb:235)", "RUBY.register(/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-kafka-5.1.3/lib/logstash/outputs/kafka.rb:171)", "RUBY.register(/usr/share/logstash/logstash-core/lib/logstash/output\_delegator\_strategies/shared.rb:8)", "RUBY.register(/usr/share/logstash/logstash-core/lib/logstash/output\_delegator.rb:37)", "RUBY.start\_workers(/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:234)", "org.jruby.RubyArray.each(org/jruby/RubyArray.java:1613)", "RUBY.start\_workers(/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:234)", "RUBY.run(/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:188)", "RUBY.start\_pipeline(/usr/share/logstash/logstash-core/lib/logstash/agent.rb:302)", "java.lang.Thread.run(java/lang/Thread.java:745)"]}

I use command line to start the logstash  
/usr/share/logstash/bin/logstash --path.settings /etc/logstash --log.level trace -f /etc/logstash/conf.d/shipper\_kafka\_elk.conf

I'm not sure what goes wrong, please help!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 23, 2017, 10:44am UTC](https://discuss.elastic.co/t/failed-to-construct-kafka-producer/76195/2 "2017-03-23T10:44:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
