# Failed to create index from local gateway

**URL:** <https://discuss.elastic.co/t/failed-to-create-index-from-local-gateway/3565>\
**Category:** Elasticsearch\
**Created:** [November 13, 2010, 9:54am UTC](https://discuss.elastic.co/t/failed-to-create-index-from-local-gateway/3565 "2010-11-13T09:54:43Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Lukas\_Vlcek1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lukas_vlcek1/32/819_2.png) [@Lukas\_Vlcek1](https://discuss.elastic.co/u/Lukas_Vlcek1)\
**Post date:** [November 13, 2010, 9:54am UTC](https://discuss.elastic.co/t/failed-to-create-index-from-local-gateway/3565/1 "2010-11-13T09:54:43Z")

</div>

Hi,

I noticed interesting issue today. Not sure if I have the latest master but  
it is not older then one day.

I created few indices in cluster, then I shut down the cluster and started  
again. During startup I got the following ERROR message in log:

[ERROR][gateway.local] [Drake, Frank] failed to create index  
[testindex]

I shutdown the cluster and started again, this time I did not get this error  
but the index was not recognized and created at all. It is simply missing in  
cluster status. The index data is still present in /data folder but if I  
check the \_state folder there are two files: metadata-xx and shards-yy. The  
[testindex] is still referenced in shards-yy but not in metadata-xx.

Not sure what went wrong (did not have a DEBUG logging level turned on) but  
one of the other indices have alias [testindex]. So there is an index A and  
index B having alias A, can this be a problem?

Regards,  
Lukas

---

<div class="post-metadata">

**Author:** ![Lukas\_Vlcek1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lukas_vlcek1/32/819_2.png) [@Lukas\_Vlcek1](https://discuss.elastic.co/u/Lukas_Vlcek1)\
**Post date:** [November 13, 2010, 11:11am UTC](https://discuss.elastic.co/t/failed-to-create-index-from-local-gateway/3565/2 "2010-11-13T11:11:36Z")

</div>

I created issue for this (tested with master):

> <https://github.com/elastic/elasticsearch/issues/513>
>
> Starting with clean ES installation:
> 
> \<pre\>
> curl -XPOST http://localhost:9200/a…bc/x -d '{ "name" : "a" }'
> curl -XPOST http://localhost:9200/xyz/x -d '{ "name" : "b" }'
> curl -XPOST http://localhost:9200/\_aliases -d '{ "actions" : \[{"add":{"index":"abc", "alias":"xyz"}} \] }'
> curl -XPOST http://localhost:9200/\_shutdown
> \</pre\>
> 
> 
> then when starting ES again
> 
> \<pre\>
> ./bin/elasticsearch -f
> \</pre\>
> 
> 
> I get the following log messages:
> 
> \<pre\>
> \[2010-11-13 12:03:24,159\]\[INFO \]\[node \] \[Foster, Bill\] {elasticsearch/0.13.0-SNAPSHOT/2010-11-13T10:04:15}\[8348\]: initializing ...
> \[2010-11-13 12:03:24,162\]\[INFO \]\[plugins \] \[Foster, Bill\] loaded \[\]
> \[2010-11-13 12:03:25,533\]\[INFO \]\[node \] \[Foster, Bill\] {elasticsearch/0.13.0-SNAPSHOT/2010-11-13T10:04:15}\[8348\]: initialized
> \[2010-11-13 12:03:25,533\]\[INFO \]\[node \] \[Foster, Bill\] {elasticsearch/0.13.0-SNAPSHOT/2010-11-13T10:04:15}\[8348\]: starting ...
> \[2010-11-13 12:03:25,685\]\[INFO \]\[transport \] \[Foster, Bill\] bound\_address {inet\[/0:0:0:0:0:0:0:0:9300\]}, publish\_address {inet\[/192.168.2.3:9300\]}
> \[2010-11-13 12:03:28,716\]\[INFO \]\[cluster.service \] \[Foster, Bill\] new\_master \[Foster, Bill\]\[R\_kJChj2TtC1vyrqUK74QA\]\[inet\[/192.168.2.3:9300\]\], reason: zen-disco-join (elected\_as\_master)
> \[2010-11-13 12:03:28,750\]\[INFO \]\[discovery \] \[Foster, Bill\] elasticsearch/R\_kJChj2TtC1vyrqUK74QA
> \[2010-11-13 12:03:28,828\]\[INFO \]\[http \] \[Foster, Bill\] bound\_address {inet\[/0:0:0:0:0:0:0:0:9200\]}, publish\_address {inet\[/192.168.2.3:9200\]}
> \[2010-11-13 12:03:28,829\]\[INFO \]\[node \] \[Foster, Bill\] {elasticsearch/0.13.0-SNAPSHOT/2010-11-13T10:04:15}\[8348\]: started
> \[2010-11-13 12:03:29,444\]\[INFO \]\[cluster.metadata \] \[Foster, Bill\] \[abc\] creating index, cause \[gateway\], shards \[5\]/\[1\], mappings \[x\]
> \[2010-11-13 12:03:29,447\]\[ERROR\]\[gateway.local \] \[Foster, Bill\] failed to create index \[xyz\]
> \[2010-11-13 12:03:29,914\]\[INFO \]\[cluster.metadata \] \[Foster, Bill\] \[abc\] created and added to cluster\_state
> \</pre\> 
> 
> 
> Note the ERROR ^^
> 
> What is even more strange is that if I use index names \[a\] instead \[abc\] and \[b\] instead \[xyx\] then it works fine.

On Sat, Nov 13, 2010 at 10:54 AM, Lukáš Vlček [lukas.vlcek@gmail.com](mailto:lukas.vlcek@gmail.com) wrote:

> Hi,
> 
> I noticed interesting issue today. Not sure if I have the latest master but  
> it is not older then one day.
> 
> I created few indices in cluster, then I shut down the cluster and started  
> again. During startup I got the following ERROR message in log:
> 
> [ERROR][gateway.local] [Drake, Frank] failed to create index  
> [testindex]
> 
> I shutdown the cluster and started again, this time I did not get this  
> error but the index was not recognized and created at all. It is simply  
> missing in cluster status. The index data is still present in /data folder  
> but if I check the \_state folder there are two files: metadata-xx and  
> shards-yy. The [testindex] is still referenced in shards-yy but not in  
> metadata-xx.
> 
> Not sure what went wrong (did not have a DEBUG logging level turned on) but  
> one of the other indices have alias [testindex]. So there is an index A and  
> index B having alias A, can this be a problem?
> 
> Regards,  
> Lukas

---

<div class="post-metadata">

**Author:** ![Lukas\_Vlcek1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lukas_vlcek1/32/819_2.png) [@Lukas\_Vlcek1](https://discuss.elastic.co/u/Lukas_Vlcek1)\
**Post date:** [November 13, 2010, 11:15am UTC](https://discuss.elastic.co/t/failed-to-create-index-from-local-gateway/3565/3 "2010-11-13T11:15:09Z")

</div>

Sorry for creating the ticket twice:

> <https://github.com/elastic/elasticsearch/issues/512>
>
> Starting with clean ES installation:
> 
> \<pre\>
> curl -XPOST http://localhost:9200/a…bc/x -d '{ "name" : "a" }'
> curl -XPOST http://localhost:9200/xyz/x -d '{ "name" : "b" }'
> curl -XPOST http://localhost:9200/\_aliases -d '{ "actions" : \[{"add":{"index":"abc", "alias":"xyz"}} \] }'
> curl -XPOST http://localhost:9200/\_shutdown
> \</pre\>
> 
> 
> then when starting ES again
> 
> \<pre\>
> ./bin/elasticsearch -f
> \</pre\>
> 
> 
> I get the following log messages:
> 
> \<pre\>
> \[2010-11-13 12:03:24,159\]\[INFO \]\[node \] \[Foster, Bill\] {elasticsearch/0.13.0-SNAPSHOT/2010-11-13T10:04:15}\[8348\]: initializing ...
> \[2010-11-13 12:03:24,162\]\[INFO \]\[plugins \] \[Foster, Bill\] loaded \[\]
> \[2010-11-13 12:03:25,533\]\[INFO \]\[node \] \[Foster, Bill\] {elasticsearch/0.13.0-SNAPSHOT/2010-11-13T10:04:15}\[8348\]: initialized
> \[2010-11-13 12:03:25,533\]\[INFO \]\[node \] \[Foster, Bill\] {elasticsearch/0.13.0-SNAPSHOT/2010-11-13T10:04:15}\[8348\]: starting ...
> \[2010-11-13 12:03:25,685\]\[INFO \]\[transport \] \[Foster, Bill\] bound\_address {inet\[/0:0:0:0:0:0:0:0:9300\]}, publish\_address {inet\[/192.168.2.3:9300\]}
> \[2010-11-13 12:03:28,716\]\[INFO \]\[cluster.service \] \[Foster, Bill\] new\_master \[Foster, Bill\]\[R\_kJChj2TtC1vyrqUK74QA\]\[inet\[/192.168.2.3:9300\]\], reason: zen-disco-join (elected\_as\_master)
> \[2010-11-13 12:03:28,750\]\[INFO \]\[discovery \] \[Foster, Bill\] elasticsearch/R\_kJChj2TtC1vyrqUK74QA
> \[2010-11-13 12:03:28,828\]\[INFO \]\[http \] \[Foster, Bill\] bound\_address {inet\[/0:0:0:0:0:0:0:0:9200\]}, publish\_address {inet\[/192.168.2.3:9200\]}
> \[2010-11-13 12:03:28,829\]\[INFO \]\[node \] \[Foster, Bill\] {elasticsearch/0.13.0-SNAPSHOT/2010-11-13T10:04:15}\[8348\]: started
> \[2010-11-13 12:03:29,444\]\[INFO \]\[cluster.metadata \] \[Foster, Bill\] \[abc\] creating index, cause \[gateway\], shards \[5\]/\[1\], mappings \[x\]
> \[2010-11-13 12:03:29,447\]\[ERROR\]\[gateway.local \] \[Foster, Bill\] failed to create index \[xyz\]
> \[2010-11-13 12:03:29,914\]\[INFO \]\[cluster.metadata \] \[Foster, Bill\] \[abc\] created and added to cluster\_state
> \</pre\> 
> 
> 
> Note the ERROR ^^
> 
> What is even more strange is that if I use index names \[a\] instead \[abc\] and \[b\] instead \[xyx\] then it works fine.

[https://github.com/elasticsearch/elasticsearch/issues/issue/512](https://github.com/elasticsearch/elasticsearch/issues/issue/512)The  
network is really weak here this morning. Feel free to kill one of these  
tickets.

On Sat, Nov 13, 2010 at 12:11 PM, Lukáš Vlček [lukas.vlcek@gmail.com](mailto:lukas.vlcek@gmail.com) wrote:

> I created issue for this (tested with master):  
> [Fail to create index when alias on other index · Issue #513 · elastic/elasticsearch · GitHub](https://github.com/elasticsearch/elasticsearch/issues/issue/513)
> 
> On Sat, Nov 13, 2010 at 10:54 AM, Lukáš Vlček [lukas.vlcek@gmail.com](mailto:lukas.vlcek@gmail.com)wrote:
> 
> > Hi,
> > 
> > I noticed interesting issue today. Not sure if I have the latest master  
> > but it is not older then one day.
> > 
> > I created few indices in cluster, then I shut down the cluster and started  
> > again. During startup I got the following ERROR message in log:
> > 
> > [ERROR][gateway.local] [Drake, Frank] failed to create index  
> > [testindex]
> > 
> > I shutdown the cluster and started again, this time I did not get this  
> > error but the index was not recognized and created at all. It is simply  
> > missing in cluster status. The index data is still present in /data folder  
> > but if I check the \_state folder there are two files: metadata-xx and  
> > shards-yy. The [testindex] is still referenced in shards-yy but not in  
> > metadata-xx.
> > 
> > Not sure what went wrong (did not have a DEBUG logging level turned on)  
> > but one of the other indices have alias [testindex]. So there is an index A  
> > and index B having alias A, can this be a problem?
> > 
> > Regards,  
> > Lukas

---

<div class="post-metadata">

**Author:** ![Lukas\_Vlcek1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lukas_vlcek1/32/819_2.png) [@Lukas\_Vlcek1](https://discuss.elastic.co/u/Lukas_Vlcek1)\
**Post date:** [November 13, 2010, 11:16am UTC](https://discuss.elastic.co/t/failed-to-create-index-from-local-gateway/3565/4 "2010-11-13T11:16:50Z")

</div>

I closed #513. Sorry for the confusion.

On Sat, Nov 13, 2010 at 12:15 PM, Lukáš Vlček [lukas.vlcek@gmail.com](mailto:lukas.vlcek@gmail.com) wrote:

> Sorry for creating the ticket twice:  
> [Fail to create index when alias on other index · Issue #512 · elastic/elasticsearch · GitHub](https://github.com/elasticsearch/elasticsearch/issues/issue/512)  
> [https://github.com/elasticsearch/elasticsearch/issues/issue/512](https://github.com/elasticsearch/elasticsearch/issues/issue/512)The  
> network is really weak here this morning. Feel free to kill one of these  
> tickets.
> 
> On Sat, Nov 13, 2010 at 12:11 PM, Lukáš Vlček [lukas.vlcek@gmail.com](mailto:lukas.vlcek@gmail.com)wrote:
> 
> > I created issue for this (tested with master):  
> > [Fail to create index when alias on other index · Issue #513 · elastic/elasticsearch · GitHub](https://github.com/elasticsearch/elasticsearch/issues/issue/513)
> > 
> > On Sat, Nov 13, 2010 at 10:54 AM, Lukáš Vlček [lukas.vlcek@gmail.com](mailto:lukas.vlcek@gmail.com)wrote:
> > 
> > > Hi,
> > > 
> > > I noticed interesting issue today. Not sure if I have the latest master  
> > > but it is not older then one day.
> > > 
> > > I created few indices in cluster, then I shut down the cluster and  
> > > started again. During startup I got the following ERROR message in log:
> > > 
> > > [ERROR][gateway.local] [Drake, Frank] failed to create index  
> > > [testindex]
> > > 
> > > I shutdown the cluster and started again, this time I did not get this  
> > > error but the index was not recognized and created at all. It is simply  
> > > missing in cluster status. The index data is still present in /data folder  
> > > but if I check the \_state folder there are two files: metadata-xx and  
> > > shards-yy. The [testindex] is still referenced in shards-yy but not in  
> > > metadata-xx.
> > > 
> > > Not sure what went wrong (did not have a DEBUG logging level turned on)  
> > > but one of the other indices have alias [testindex]. So there is an index A  
> > > and index B having alias A, can this be a problem?
> > > 
> > > Regards,  
> > > Lukas

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:16am UTC](https://discuss.elastic.co/t/failed-to-create-index-from-local-gateway/3565/5 "2017-07-06T04:16:35Z")

</div>


