# Failed to create mapping\["date"\], following steps in getting started doc

**URL:** <https://discuss.elastic.co/t/failed-to-create-mapping-date-following-steps-in-getting-started-doc/655>\
**Category:** Logstash\
**Created:** [May 14, 2015, 12:15am UTC](https://discuss.elastic.co/t/failed-to-create-mapping-date-following-steps-in-getting-started-doc/655 "2015-05-14T00:15:17Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Stan\_Linderstein](https://avatars.discourse-cdn.com/v4/letter/s/958977/32.png) [@Stan\_Linderstein](https://discuss.elastic.co/u/Stan_Linderstein)\
**Post date:** [May 14, 2015, 12:15am UTC](https://discuss.elastic.co/t/failed-to-create-mapping-date-following-steps-in-getting-started-doc/655/1 "2015-05-14T00:15:17Z")

</div>

[I posted this question (and others) on Google Groups with no response so I'm trying this newbie question here.]

I've played a bit with Elasticsearch and now I'm wanting to get going with logstash. I found this document:

[http://www.elastic.co/guide/en/logstash/current/getting-started-with-logstash.html](http://www.elastic.co/guide/en/logstash/current/getting-started-with-logstash.html)

The steps work fine until I want to add a record to my existing Elasticsearch and then I get this:

[2015-05-13 12:09:13,999][DEBUG][action.admin.indices.create] [Captain Germany] [logstash-2015.05.13] failed to create org.elasticsearch.index.mapper.MapperParsingException: mapping [“date”]at org.elasticsearch.cluster.metadata.MetaDataCreateIndexService$2.execute(MetaDataCreateIndexService.java:395)at org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:365)

...

I assume the problem is caused by the fact that logstash is trying to write into some database that either doesn't have a date field or else its mapping is wrong.

In any case, how do I get this to not throw an error?

bin/logstash -e 'input { stdin { } } output { elasticsearch { host =\> localhost }

Thanks.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 5:39am UTC](https://discuss.elastic.co/t/failed-to-create-mapping-date-following-steps-in-getting-started-doc/655/2 "2017-07-06T05:39:54Z")

</div>


