# Failed to create tempfile (/.filebeat.new) for writing: open /.filebeat.new: permission denied

**URL:** <https://discuss.elastic.co/t/failed-to-create-tempfile-filebeat-new-for-writing-open-filebeat-new-permission-denied/261132>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [January 14, 2021, 2:08pm UTC](https://discuss.elastic.co/t/failed-to-create-tempfile-filebeat-new-for-writing-open-filebeat-new-permission-denied/261132 "2021-01-14T14:08:33Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![prashant\_Rajenderan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/prashant_rajenderan/32/82035_2.png) [@prashant\_Rajenderan](https://discuss.elastic.co/u/prashant_Rajenderan)\
**Post date:** [January 14, 2021, 2:08pm UTC](https://discuss.elastic.co/t/failed-to-create-tempfile-filebeat-new-for-writing-open-filebeat-new-permission-denied/261132/1 "2021-01-14T14:08:34Z")

</div>

I noticed that filebeat agent is not shipping the logs, when I tried restarting the service I found the following error. Also, when I run sudo ./filebeat -e output returns nothing. By looking at the logs "permission denied", I re-checked the file permission for the source route but I still see the issue even after modifying the user permissions and group permissions. Can somebody suggest what could be the root cause for the following?

```auto
registrar.go:152: Failed to create tempfile (/.filebeat.new) for writing: open /.filebeat.new: permission denied
registrar.go:110: Writing of registry returned error: open /.filebeat.new: permission denied. Continuing..
registrar.go:152: Failed to create tempfile (/.filebeat.new) for writing: open /.filebeat.new: permission denied
registrar.go:110: Writing of registry returned error: open /.filebeat.new: permission denied. Continuing..
registrar.go:152: Failed to create tempfile (/.filebeat.new) for writing: open /.filebeat.new: permission denied
registrar.go:110: Writing of registry returned error: open /.filebeat.new: permission denied. Continuing..
registrar.go:152: Failed to create tempfile (/.filebeat.new) for writing: open /.filebeat.new: permission denied
registrar.go:110: Writing of registry returned error: open /.filebeat.new: permission denied. Continuing..
registrar.go:152: Failed to create tempfile (/.filebeat.new) for writing: open /.filebeat.new: permission denied
registrar.go:110: Writing of registry returned error: open /.filebeat.new: permission denied. Continuing..

```

Filebeat and filebeat.yml is installed in the same location

```auto
-rw-r--r-- 1 xyz xyz 814 Jan 7 10:08 filebeat.template.json
-rwxr-xr-x 1 xyz xyz 12386344 Jan 7 10:08 filebeat
-rw-r--r-- 1 xyz xyz 8992 Jan 7 10:08 filebeat.yml

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 11, 2021, 4:08pm UTC](https://discuss.elastic.co/t/failed-to-create-tempfile-filebeat-new-for-writing-open-filebeat-new-permission-denied/261132/2 "2021-02-11T16:08:47Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
