# Failed to determine the health of the cluster running

**URL:** <https://discuss.elastic.co/t/failed-to-determine-the-health-of-the-cluster-running/304748>\
**Category:** Elasticsearch\
**Created:** [May 15, 2022, 12:07pm UTC](https://discuss.elastic.co/t/failed-to-determine-the-health-of-the-cluster-running/304748 "2022-05-15T12:07:56Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![111273](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/111273/32/60289_2.png) [@111273](https://discuss.elastic.co/u/111273)\
**Post date:** [May 15, 2022, 12:07pm UTC](https://discuss.elastic.co/t/failed-to-determine-the-health-of-the-cluster-running/304748/1 "2022-05-15T12:07:56Z")

</div>

Hi

I have error master\_discovery\_exception and change password bundle user.  
Please have solution this case.

Elasticsearch.yml  
cluster.name: rpa-Elasticsearch-test  
http.port: 9200  
node.data: true  
node.master: true  
node.name: RPA-AP2-T1.xxx  
path.data: C:\ProgramData\Elastic\Elasticsearch\data  
path.logs: C:\ProgramData\Elastic\Elasticsearch\logs  
xpack.license.self\_generated.type: basic  
xpack.security.enabled: true  
xpack.security.transport.ssl.enabled: true  
xpack.security.transport.ssl.verification\_mode: certificate  
xpack.security.transport.ssl.keystore.path: rpa-Elasticsearch-t.xxx.p12  
xpack.security.transport.ssl.truststore.path: rpa-Elasticsearch-t.xxx.p12  
network.publish\_host: RPA-AP2-T1.xxx  
discovery.zen.ping.unicast.hosts: ["RPA-AP2-T1.xxx","RPA-AP2-T2.xxx","RPA-AP2-T3.xxx"]  
cluster.initial\_master\_nodes: ["RPA-AP2-T1.xxx","RPA-AP2-T2.xxxx","RPA-AP2-T3.xxx"]  
path.repo: ["C:\Program Files\Elastic\Elasticsearch\7.16.2\snapshot", "C:\Program Files\Elastic\Elasticsearch\7.16.2\backup"]  
xpack.ml.enabled: false

Error  
Failed to determine the health of the cluster running at [http://xxx.xxx.xx.xxx:9200](http://xxx.xxx.xx.xxx:9200)  
it is recommented that you resolve the issues with your cluster before running Elasticsearch-setup-password.  
it is very likely that the password changes will fail when run against an unhealthy cluster.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/e/0/e00083191854582be71d67c69297bad1d4aec867.png)

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 16, 2022, 12:19am UTC](https://discuss.elastic.co/t/failed-to-determine-the-health-of-the-cluster-running/304748/2 "2022-05-16T00:19:27Z")

</div>

Please don't post pictures of text, logs or code. They are difficult to read, impossible to search and replicate (if it's code), and some people may not be even able to see them 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 13, 2022, 12:20am UTC](https://discuss.elastic.co/t/failed-to-determine-the-health-of-the-cluster-running/304748/3 "2022-06-13T00:20:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
