# Failed to enable unit: Unit file logstash.service does not exist

**URL:** <https://discuss.elastic.co/t/failed-to-enable-unit-unit-file-logstash-service-does-not-exist/212995>\
**Category:** Elasticsearch\
**Created:** [December 25, 2019, 6:40am UTC](https://discuss.elastic.co/t/failed-to-enable-unit-unit-file-logstash-service-does-not-exist/212995 "2019-12-25T06:40:55Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![WhatsElastic](https://avatars.discourse-cdn.com/v4/letter/w/c6cbf5/32.png) [@WhatsElastic](https://discuss.elastic.co/u/WhatsElastic)\
**Post date:** [December 25, 2019, 6:40am UTC](https://discuss.elastic.co/t/failed-to-enable-unit-unit-file-logstash-service-does-not-exist/212995/1 "2019-12-25T06:40:55Z")

</div>

I am trying to instal ELK stack on raspberry pi using [easyELK](https://github.com/josh-thurston/easyELK) method. While installing I am getting below error

```auto
 Enabling Services for Start on Boot
 Starting Elastic, Logstash, Kibana Services
Failed to enable unit: Unit file logstash.service does not exist.
Failed to enable unit: Unit file kibana.service does not exist.
Failed to start logstash.service: Unit logstash.service not found.
Failed to start kibana.service: Unit kibana.service not found.
 Service Status:
grep: elasticsearch(?!-)\b: No such file or directory
elasticsearch Not Running
grep: logstash(?!-)\b: No such file or directory
logstash Not Running
grep: kibana(?!-)\b: No such file or directory
kibana Not Running
 Wed Dec 25 11:54:52 IST 2019
 Finished easyELK Installer
 Your Turn: Finish Configuration

```

I have added all other technical details and issues in [this thread](https://discuss.elastic.co/t/failed-to-connect-to-localhost-port-9200-connection-refused-fresh-install/212788)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 22, 2020, 6:40am UTC](https://discuss.elastic.co/t/failed-to-enable-unit-unit-file-logstash-service-does-not-exist/212995/2 "2020-01-22T06:40:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
