# Failed to execute action error on windows

**URL:** <https://discuss.elastic.co/t/failed-to-execute-action-error-on-windows/171320>\
**Category:** Logstash\
**Created:** [March 7, 2019, 2:12pm UTC](https://discuss.elastic.co/t/failed-to-execute-action-error-on-windows/171320 "2019-03-07T14:12:22Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![spolat](https://avatars.discourse-cdn.com/v4/letter/s/dec6dc/32.png) [@spolat](https://discuss.elastic.co/u/spolat)\
**Post date:** [March 7, 2019, 2:12pm UTC](https://discuss.elastic.co/t/failed-to-execute-action-error-on-windows/171320/1 "2019-03-07T14:12:22Z")

</div>

Logstash version 6.6.1  
Operating system : windows 10  
conf file : input { generator {} } filter { sleep { time =\> 1 } } output { stdout { codec =\> json } }  
pipelines.yml : pipeline.id: main

ERROR Message  
] Executing action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main}  
[2019-03-07T16:59:34,080][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"LogStash::ConfigurationError", :message=\>"Expected one of #, input, filter, output at line 3, column 1 (byte 76) after ", :backtrace=\>["E:/logstash-6.6.1/logstash-core/lib/logstash/compiler.rb:41:in `compile_imperative'", "E:/logstash-6.6.1/logstash-core/lib/logstash/compiler.rb:49:in`compile\_graph'", "E:/logstash-6.6.1/logstash-core/lib/logstash/compiler.rb:11:in `block in compile_sources'", "org/jruby/RubyArray.java:2486:in`map'", "E:/logstash-6.6.1/logstash-core/lib/logstash/compiler.rb:10:in `compile_sources'", "org/logstash/execution/AbstractPipelineExt.java:149:in`initialize'", "E:/logstash-6.6.1/logstash-core/lib/logstash/pipeline.rb:22:in `initialize'", "E:/logstash-6.6.1/logstash-core/lib/logstash/pipeline.rb:90:in`initialize'", "E:/logstash-6.6.1/logstash-core/lib/logstash/pipeline\_action/create.rb:43:in `block in execute'", "E:/logstash-6.6.1/logstash-core/lib/logstash/agent.rb:94:in`block in exclusive'", "org/jruby/ext/thread/Mutex.java:148:in `synchronize'", "E:/logstash-6.6.1/logstash-core/lib/logstash/agent.rb:94:in`exclusive'", "E:/logstash-6.6.1/logstash-core/lib/logstash/pipeline\_action/create.rb:39:in `execute'", "E:/logstash-6.6.1/logstash-core/lib/logstash/agent.rb:327:in`block in converge\_state'"]}

When I run conf file with "-f " parameter it runs without problem. But without parameter when I add it on pipeline, I got the error shown above.

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [March 7, 2019, 3:50pm UTC](https://discuss.elastic.co/t/failed-to-execute-action-error-on-windows/171320/2 "2019-03-07T15:50:57Z")

</div>

> [@spolat](#):
>
> When I run conf file with "-f " parameter it runs without problem. But without parameter when I add it on pipeline, I got the error shown above.

What is path.config set to? I would guess that logstash is concatenating all the files in path.config and at least one of those files (probably pipelines.yml) is not a logstash configuration file.

---

<div class="post-metadata">

**Author:** ![spolat](https://avatars.discourse-cdn.com/v4/letter/s/dec6dc/32.png) [@spolat](https://discuss.elastic.co/u/spolat)\
**Post date:** [March 7, 2019, 6:03pm UTC](https://discuss.elastic.co/t/failed-to-execute-action-error-on-windows/171320/3 "2019-03-07T18:03:11Z")

</div>

I solved the problem by editing pipeline.yml file. The problem was configuration error. Thank you for all.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 4, 2019, 6:03pm UTC](https://discuss.elastic.co/t/failed-to-execute-action-error-on-windows/171320/4 "2019-04-04T18:03:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
