# Failed to execute action error

**URL:** <https://discuss.elastic.co/t/failed-to-execute-action-error/230467>\
**Category:** Logstash\
**Created:** [April 30, 2020, 5:53am UTC](https://discuss.elastic.co/t/failed-to-execute-action-error/230467 "2020-04-30T05:53:37Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![vinayavvaru](https://avatars.discourse-cdn.com/v4/letter/v/2bfe46/32.png) [@vinayavvaru](https://discuss.elastic.co/u/vinayavvaru)\
**Post date:** [April 30, 2020, 5:53am UTC](https://discuss.elastic.co/t/failed-to-execute-action-error/230467/1 "2020-04-30T05:53:38Z")

</div>

Hi,

After running conf file from command prompt we are getting below error, please help us

Error Details :

C:\Users\VAVVARU\Desktop\ELK\_Softwares\logstash-7.6.2\bin\>logstash -f pipeline.conf  
Sending Logstash logs to C:/Users/VAVVARU/Desktop/ELK\_Softwares/logstash-7.6.2/logs which is now configured via log4j2.properties  
[2020-04-30T13:30:26,414][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2020-04-30T13:30:26,621][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.6.2"}  
[2020-04-30T13:30:28,583][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"LogStash::ConfigurationError", :message=\>"Expected one of [\t\r\n], "#", "{", [A-Za-z0-9\_-], '"', "'", "}" at line 9, column 2 (byte 141) after input {\r\n\tfile {\r\n\r\n\r\n\tpath =\> "C:\PegaPersonalEdition\PRPCPersonalEdition\tomcat\work\Catalina\localhost\prweb\PegaRULES.json.log"\r\n\r\n\r\n\r\n\t", :backtrace=\>["C:/Users/VAVVARU/Desktop/ELK\_Softwares/logstash-7.6.2/logstash-core/lib/logstash/compiler.rb:41:in `compile_imperative'", "C:/Users/VAVVARU/Desktop/ELK_Softwares/logstash-7.6.2/logstash-core/lib/logstash/compiler.rb:49:in `compile\_graph'", "C:/Users/VAVVARU/Desktop/ELK\_Softwares/logstash-7.6.2/logstash-core/lib/logstash/compiler.rb:11:in `block in compile_sources'", "org/jruby/RubyArray.java:2580:in `map'", "C:/Users/VAVVARU/Desktop/ELK\_Softwares/logstash-7.6.2/logstash-core/lib/logstash/compiler.rb:10:in `compile_sources'", "org/logstash/execution/AbstractPipelineExt.java:161:in `initialize'", "org/logstash/execution/JavaBasePipelineExt.java:47:in `initialize'", "C:/Users/VAVVARU/Desktop/ELK_Softwares/logstash-7.6.2/logstash-core/lib/logstash/java_pipeline.rb:27:in `initialize'", "C:/Users/VAVVARU/Desktop/ELK\_Softwares/logstash-7.6.2/logstash-core/lib/logstash/pipeline\_action/create.rb:36:in `execute'", "C:/Users/VAVVARU/Desktop/ELK_Softwares/logstash-7.6.2/logstash-core/lib/logstash/agent.rb:326:in `block in converge\_state'"]}  
[2020-04-30T13:30:29,511][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2020-04-30T13:30:34,147][INFO][logstash.runner] Logstash shut down.

Logstash conf file configuration:

input {  
file {  
path =\> "C:\PegaPersonalEdition\PRPCPersonalEdition\tomcat\work\Catalina\localhost\prweb\PegaRULES.json.log"  
​ }  
}

output {  
elasticsearch {  
hosts =\> ["localhost:9200"]  
index =\> "blocks"  
}  
}

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [April 30, 2020, 3:00pm UTC](https://discuss.elastic.co/t/failed-to-execute-action-error/230467/2 "2020-04-30T15:00:49Z")

</div>

Do not use backslash in the path option of a file input, use forward slash (or, if you really insist, double backslash, so that the first escapes the second). That said, I am uncertain why you are getting that error.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 28, 2020, 3:01pm UTC](https://discuss.elastic.co/t/failed-to-execute-action-error/230467/3 "2020-05-28T15:01:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
