# Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not execute action: PipelineAction::Create\<main\>, action\_result: false", :backtrace=\>nil}

**URL:** https://discuss.elastic.co/t/failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineaction-create-main-action-result-false-backtrace-nil/245372
**Category:** Logstash
**Created:** [August 18, 2020, 8:19am UTC](https://discuss.elastic.co/t/failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineaction-create-main-action-result-false-backtrace-nil/245372 "2020-08-18T08:19:52Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![joel.ng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joel.ng/32/74069_2.png) [@joel.ng](https://discuss.elastic.co/u/joel.ng)
#### Post date: [August 18, 2020, 8:19am UTC](https://discuss.elastic.co/t/failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineaction-create-main-action-result-false-backtrace-nil/245372/1 "2020-08-18T08:19:52Z")

</div>

Trying out logstash for the first time, but I'm getting this error on a very basic localhost:5044 to S3 configuration:

```auto
[2020-08-18T08:15:53,638][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"7.8.1", "jruby.version"=>"jruby 9.2.11.1 (2.5.7) 2020-03-25 b1f55b1a40 OpenJDK 64-Bit Server VM 11.0.8+10-post-Ubuntu-0ubuntu118.04.1 on 11.0.8+10-post-Ubuntu-0ubuntu118.04.1 +indy +jit [linux-x86_64]"}
[2020-08-18T08:15:56,147][INFO][org.reflections.Reflections] Reflections took 51 ms to scan 1 urls, producing 21 keys and 41 values
[2020-08-18T08:16:27,428][ERROR][logstash.agent] Failed to execute action {:id=>:main, :action_type=>LogStash::ConvergeResult::FailedAction, :message=>"Could not execute action: PipelineAction::Create<main>, action_result: false", :backtrace=>nil}
[2020-08-18T08:16:27,802][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600}
[2020-08-18T08:16:32,740][INFO][logstash.runner] Logstash shut down.

```

My logstash config:

```auto
# /etc/logstash/conf.d$ cat vf-settings.conf

input {
  beats {
    port => 5044
  }
}

output {
  s3 {
    region => "ap-southeast-1"
    bucket => "vf-logstash"
    size_file => 20000
  }
}

```

All my other configs are untouched.

Logstash worked when I tried the following command. My logs appeared in my S3 bucket.

```auto
sudo /usr/share/logstash/bin/logstash -f '/etc/logstash/conf.d/vf-settings.conf'

```

Any ideas why running logstash through the service + config file doesn't work?

---

<div class="post-metadata">

### Author: ![aaron-nimocks](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aaron-nimocks/32/73965_2.png) [@aaron-nimocks](https://discuss.elastic.co/u/aaron-nimocks)
#### Post date: [August 19, 2020, 1:36am UTC](https://discuss.elastic.co/t/failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineaction-create-main-action-result-false-backtrace-nil/245372/2 "2020-08-19T01:36:41Z")

</div>

```auto
input {
  beats {
    port => 5044
  }
}

output {
  stdout { }
}

```

Does the above work as a service? If not then it might be permissions based. What user:group owns vf-settings.conf?

---

<div class="post-metadata">

### Author: ![joel.ng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joel.ng/32/74069_2.png) [@joel.ng](https://discuss.elastic.co/u/joel.ng)
#### Post date: [August 19, 2020, 2:44am UTC](https://discuss.elastic.co/t/failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineaction-create-main-action-result-false-backtrace-nil/245372/3 "2020-08-19T02:44:25Z")

</div>

Hi, that config works. Switching back to my original config after trying that fails again.

root owns it:

`-rw-r--r-- 1 root root 254 Aug 19 02:37 vf-settings.conf`

---

<div class="post-metadata">

### Author: ![aaron-nimocks](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aaron-nimocks/32/73965_2.png) [@aaron-nimocks](https://discuss.elastic.co/u/aaron-nimocks)
#### Post date: [August 19, 2020, 12:03pm UTC](https://discuss.elastic.co/t/failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineaction-create-main-action-result-false-backtrace-nil/245372/4 "2020-08-19T12:03:04Z")

</div>

Can you explain what you mean when you say you run it as a service?

---

<div class="post-metadata">

### Author: ![joel.ng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joel.ng/32/74069_2.png) [@joel.ng](https://discuss.elastic.co/u/joel.ng)
#### Post date: [August 20, 2020, 4:51am UTC](https://discuss.elastic.co/t/failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineaction-create-main-action-result-false-backtrace-nil/245372/5 "2020-08-20T04:51:19Z")

</div>

Just running logstash with systemctl: `sudo systemctl start logstash.service`, instead of running the executable in the `bin` folder

---

<div class="post-metadata">

### Author: ![joel.ng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joel.ng/32/74069_2.png) [@joel.ng](https://discuss.elastic.co/u/joel.ng)
#### Post date: [August 24, 2020, 3:29am UTC](https://discuss.elastic.co/t/failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineaction-create-main-action-result-false-backtrace-nil/245372/6 "2020-08-24T03:29:12Z")

</div>

Decided to boot up a new EC2 to try set up everything all over again. It worked.

Not sure what might be the difference. I suspect the error might be because I installed Logstash before installing Java. I did see some strange messages when I did that.

Either way, it works now.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 21, 2020, 3:29am UTC](https://discuss.elastic.co/t/failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineaction-create-main-action-result-false-backtrace-nil/245372/7 "2020-09-21T03:29:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
