# Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not execute action: PipelineAction::Create\<main\>, action\_result: false", :backtrace=\>nil}

**URL:** <https://discuss.elastic.co/t/failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineaction-create-main-action-result-false-backtrace-nil/258909>\
**Category:** Logstash\
**Tags:** docker\
**Created:** [December 16, 2020, 7:42pm UTC](https://discuss.elastic.co/t/failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineaction-create-main-action-result-false-backtrace-nil/258909 "2020-12-16T19:42:14Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![velu](https://avatars.discourse-cdn.com/v4/letter/v/6a8cbe/32.png) [@velu](https://discuss.elastic.co/u/velu)\
**Post date:** [December 16, 2020, 7:42pm UTC](https://discuss.elastic.co/t/failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineaction-create-main-action-result-false-backtrace-nil/258909/1 "2020-12-16T19:42:14Z")

</div>

Hi ,

Please help me how to resolve the below issue.

2020-12-16 18:47:47 ERROR agent:123 - Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not execute action: PipelineAction::Create, action\_result: false", :backtrace=\>nil}  
2020-12-16 18:47:47 INFO agent:113 - Successfully started Logstash API endpoint {:port=\>9600}  
2020-12-16 18:47:52 INFO runner:115 - Logstash shut down.  
2020-12-16 18:47:52 ERROR Logstash:96 - java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit  
Sending Logstash logs to /usr/share/logstash/logs which is now configured via log4j2.properties  
2020-12-16 18:48:04 INFO runner:113 - Starting Logstash {"logstash.version"=\>"7.9.1", "jruby.version"=\>"jruby 9.2.13.0 (2.5.7) 2020-08-03 9a89c94bcc OpenJDK 64-Bit Server VM 23.181-b14 on 1.8.0\_181-b14 +jit [linux-x86\_64]"}  
2020-12-16 18:48:04 WARN multilocal:105 - Ignoring the 'pipelines.yml' file because modules or command line options are specified

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [December 16, 2020, 10:01pm UTC](https://discuss.elastic.co/t/failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineaction-create-main-action-result-false-backtrace-nil/258909/2 "2020-12-16T22:01:49Z")

</div>

If you enable log.level debug do you get a more informative message?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 13, 2021, 10:01pm UTC](https://discuss.elastic.co/t/failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineaction-create-main-action-result-false-backtrace-nil/258909/3 "2021-01-13T22:01:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
