# Failed to execute bulk item max length:2kb

**URL:** <https://discuss.elastic.co/t/failed-to-execute-bulk-item-max-length-2kb/108287>\
**Category:** Elasticsearch\
**Created:** [November 19, 2017, 2:01pm UTC](https://discuss.elastic.co/t/failed-to-execute-bulk-item-max-length-2kb/108287 "2017-11-19T14:01:44Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![lintungwei](https://avatars.discourse-cdn.com/v4/letter/l/3da27b/32.png) [@lintungwei](https://discuss.elastic.co/u/lintungwei)\
**Post date:** [November 19, 2017, 2:01pm UTC](https://discuss.elastic.co/t/failed-to-execute-bulk-item-max-length-2kb/108287/1 "2017-11-19T14:01:44Z")

</div>

I'm using logstash + elasticsearch. both are 6.0.0  
Elasticsearch output plugin is used for logstash to output a 147 fields document directly to Elasticsearch.

Below is the error message :

[2017-11-19T21:56:44,196][DEBUG][o.e.a.b.TransportShardBulkAction] [b777][4] failed to execute bulk item (index) BulkSha  
rdRequest [[b777][4]] containing [index {[b777][doc][CAL012-17-11-09 21:54:44], source[n/a, actual length: [2.7kb], max  
length: 2kb]}]

---

<div class="post-metadata">

**Author:** ![lintungwei](https://avatars.discourse-cdn.com/v4/letter/l/3da27b/32.png) [@lintungwei](https://discuss.elastic.co/u/lintungwei)\
**Post date:** [November 19, 2017, 3:01pm UTC](https://discuss.elastic.co/t/failed-to-execute-bulk-item-max-length-2kb/108287/2 "2017-11-19T15:01:48Z")

</div>

I found the problem by looking carefully on the error message. It all because something wrong with the data type and has nothing to do with length limitation.  
Suggest to revise the error message, it will lead to wrong debugging direction.  
🙂

---

<div class="post-metadata">

**Author:** ![lintungwei](https://avatars.discourse-cdn.com/v4/letter/l/3da27b/32.png) [@lintungwei](https://discuss.elastic.co/u/lintungwei)\
**Post date:** [November 19, 2017, 3:13pm UTC](https://discuss.elastic.co/t/failed-to-execute-bulk-item-max-length-2kb/108287/3 "2017-11-19T15:13:43Z")

</div>

Oh, forgot to mention, Elasticsearch output still has the length problem. I solved the problem by using http output plug-in.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 17, 2017, 3:14pm UTC](https://discuss.elastic.co/t/failed-to-execute-bulk-item-max-length-2kb/108287/4 "2017-12-17T15:14:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
