# Failed to execute bulk item

**URL:** <https://discuss.elastic.co/t/failed-to-execute-bulk-item/43740>\
**Category:** Elasticsearch\
**Created:** [March 8, 2016, 9:06am UTC](https://discuss.elastic.co/t/failed-to-execute-bulk-item/43740 "2016-03-08T09:06:19Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ashvin\_Meetoo](https://avatars.discourse-cdn.com/v4/letter/a/ebca7d/32.png) [@Ashvin\_Meetoo](https://discuss.elastic.co/u/Ashvin_Meetoo)\
**Post date:** [March 8, 2016, 9:06am UTC](https://discuss.elastic.co/t/failed-to-execute-bulk-item/43740/1 "2016-03-08T09:06:19Z")

</div>

Hello people,

I am getting a strange error while parsing some data to elasticsearch.

My template is properly defined, and when i add a sample data manually it works:  
POST /netflow-2016-03-08/socket  
{  
"tcp\_flags": "16",  
"peer\_ip\_src": "62.193.32.252",  
"ip\_dst": "62.193.34.125",  
"@timestamp": "2016-03-08T08:33:01Z",  
"peer\_as\_dst": 0,  
"port\_dst": 19209,  
"tag": 100,  
"iface\_out": 68,  
"peer\_as\_src": 6453,  
"ip\_src": "104.85.76.24",  
"sampling\_rate": 1,  
"peer\_ip\_dst": "62.193.37.9",  
"flows": 1,  
"as\_path": "",  
"bytes": 14200000,  
"class": "unknown",  
"as\_dst": 0,  
"packets": 10000,  
"iface\_in": 66,  
"port\_src": 443,  
"ip\_proto": "tcp",  
"as\_src": 20940  
}

When trying to parse the whole data, the index is properly created but no docs are fed and i'm getting the error below, as you can see it's same as above:

```
[2016-03-08 08:33:01,795][DEBUG][action.bulk] [node-2] [netflow-2016-03-08][2] failed to execute bulk item (index) index {[netflow-2016-03-08][Netflowa][AVNVW6CeBNvVuTM7ABR2], source[{"tcp_flags": "16", "peer_ip_src": "62.193.32.252", "ip_dst": "62.193.34.125", "@timestamp": "2016-03-08T08:33:01Z", "peer_as_dst": 0, "port_dst": 19209, "tag": 100, "iface_out": 68, "peer_as_src": 6453, "ip_src": "104.85.76.24", "sampling_rate": 1, "peer_ip_dst": "62.193.37.9", "flows": 1, "as_path": "", "bytes": 14200000, "class": "unknown", "as_dst": 0, "packets": 10000, "iface_in": 66, "port_src": 443, "ip_proto": "tcp", "as_src": 20940}]}
MapperParsingException[failed to parse [peer_ip_src]]; nested: NumberFormatException[For input string: "62.193.32.252"];
	at org.elasticsearch.index.mapper.FieldMapper.parse(FieldMapper.java:343)
	at org.elasticsearch.index.mapper.DocumentParser.parseObjectOrField(DocumentParser.java:318)
	at org.elasticsearch.index.mapper.DocumentParser.parseAndMergeUpdate(DocumentParser.java:765)
	at org.elasticsearch.index.mapper.DocumentParser.parseDynamicValue(DocumentParser.java:652)
	at org.elasticsearch.index.mapper.DocumentParser.parseValue(DocumentParser.java:451)
	at org.elasticsearch.index.mapper.DocumentParser.parseObject(DocumentParser.java:271)
	at org.elasticsearch.index.mapper.DocumentParser.innerParseDocument(DocumentParser.java:131)
	at org.elasticsearch.index.mapper.DocumentParser.parseDocument(DocumentParser.java:79)
	at org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:304)
	at org.elasticsearch.index.shard.IndexShard.prepareCreate(IndexShard.java:500)
	at org.elasticsearch.index.shard.IndexShard.prepareCreateOnPrimary(IndexShard.java:481)
	at org.elasticsearch.action.index.TransportIndexAction.prepareIndexOperationOnPrimary(TransportIndexAction.java:214)
	at org.elasticsearch.action.index.TransportIndexAction.executeIndexRequestOnPrimary(TransportIndexAction.java:223)
	at org.elasticsearch.action.bulk.TransportShardBulkAction.shardIndexOperation(TransportShardBulkAction.java:326)
	at org.elasticsearch.action.bulk.TransportShardBulkAction.shardOperationOnPrimary(TransportShardBulkAction.java:119)
	at org.elasticsearch.action.bulk.TransportShardBulkAction.shardOperationOnPrimary(TransportShardBulkAction.java:68)
	at org.elasticsearch.action.support.replication.TransportReplicationAction$PrimaryPhase.doRun(TransportReplicationAction.java:595)
	at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37)
	at org.elasticsearch.action.support.replication.TransportReplicationAction$PrimaryOperationTransportHandler.messageReceived(TransportReplicationAction.java:263)
	at org.elasticsearch.action.support.replication.TransportReplicationAction$PrimaryOperationTransportHandler.messageReceived(TransportReplicationAction.java:260)
	at org.elasticsearch.transport.TransportService$4.doRun(TransportService.java:350)
	at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NumberFormatException: For input string: "62.193.32.252"
	at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
	at java.lang.Long.parseLong(Long.java:589)
	at java.lang.Long.parseLong(Long.java:631)
	at org.elasticsearch.index.mapper.core.NumberFieldMapper.parseCreateField(NumberFieldMapper.java:241)
	at org.elasticsearch.index.mapper.FieldMapper.parse(FieldMapper.java:335)
	... 24 more

```

Help please 🙂

---

<div class="post-metadata">

**Author:** ![jpountz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jpountz/32/45836_2.png) [@jpountz](https://discuss.elastic.co/u/jpountz)\
**Post date:** [March 8, 2016, 9:49am UTC](https://discuss.elastic.co/t/failed-to-execute-bulk-item/43740/2 "2016-03-08T09:49:00Z")

</div>

It looks like the `peer_ip_src` field is mapped as a number in your mappings, so then it fails to index the document since it expects a number but gets a string that represents an ip address.

---

<div class="post-metadata">

**Author:** ![yp\_wang](https://avatars.discourse-cdn.com/v4/letter/y/74df32/32.png) [@yp\_wang](https://discuss.elastic.co/u/yp_wang)\
**Post date:** [May 10, 2017, 4:42am UTC](https://discuss.elastic.co/t/failed-to-execute-bulk-item/43740/3 "2017-05-10T04:42:12Z")

</div>

Bingo!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:00pm UTC](https://discuss.elastic.co/t/failed-to-execute-bulk-item/43740/4 "2017-07-05T22:00:28Z")

</div>


