# Failed to execute fetch phase - Field does not support custom formats

**URL:** <https://discuss.elastic.co/t/failed-to-execute-fetch-phase-field-does-not-support-custom-formats/170201>\
**Category:** Elasticsearch\
**Created:** [February 27, 2019, 4:05pm UTC](https://discuss.elastic.co/t/failed-to-execute-fetch-phase-field-does-not-support-custom-formats/170201 "2019-02-27T16:05:05Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![opoplawski](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/opoplawski/32/40442_2.png) [@opoplawski](https://discuss.elastic.co/u/opoplawski)\
**Post date:** [February 27, 2019, 4:05pm UTC](https://discuss.elastic.co/t/failed-to-execute-fetch-phase-field-does-not-support-custom-formats/170201/1 "2019-02-27T16:05:06Z")

</div>

We just added winlogbeat data to our elasticsearch setup. But now kibana will not show any results for the winlogbeat-\* index pattern. Dury the query elasticsearch reports:  
[2019-02-27T07:56:51,417][DEBUG][o.e.a.s.TransportSearchAction] [riXPT11] [24219] Failed to execute fetch phase  
org.elasticsearch.transport.RemoteTransportException: [riXPT11][127.0.0.1:9300][indices:data/read/search[phase/fetch/id]]  
Caused by: java.lang.IllegalArgumentException: Field [event\_data.DeviceTime] of type [keyword] does not support custom formats  
at org.elasticsearch.index.mapper.MappedFieldType.docValueFormat(MappedFieldType.java:471) ~[elasticsearch-6.6.1.jar:6.6.1]

I checked the index template for winlogbeat-6.6.1-\* and there is no entry for event\_data.DeviceTime. Is that an oversight?

---

<div class="post-metadata">

**Author:** ![opoplawski](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/opoplawski/32/40442_2.png) [@opoplawski](https://discuss.elastic.co/u/opoplawski)\
**Post date:** [February 27, 2019, 4:46pm UTC](https://discuss.elastic.co/t/failed-to-execute-fetch-phase-field-does-not-support-custom-formats/170201/2 "2019-02-27T16:46:11Z")

</div>

I also see "3 out of 812 shards failed". Is there some way to see what shards are failing?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 27, 2019, 4:46pm UTC](https://discuss.elastic.co/t/failed-to-execute-fetch-phase-field-does-not-support-custom-formats/170201/3 "2019-03-27T16:46:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
