# Failed to execute fetch phase org.elasticsearch.transport.RemoteTransportException

**URL:** <https://discuss.elastic.co/t/failed-to-execute-fetch-phase-org-elasticsearch-transport-remotetransportexception/101829>\
**Category:** Elasticsearch\
**Created:** [September 26, 2017, 10:40am UTC](https://discuss.elastic.co/t/failed-to-execute-fetch-phase-org-elasticsearch-transport-remotetransportexception/101829 "2017-09-26T10:40:08Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![dedosan](https://avatars.discourse-cdn.com/v4/letter/d/e9c0ed/32.png) [@dedosan](https://discuss.elastic.co/u/dedosan)\
**Post date:** [September 26, 2017, 10:40am UTC](https://discuss.elastic.co/t/failed-to-execute-fetch-phase-org-elasticsearch-transport-remotetransportexception/101829/1 "2017-09-26T10:40:09Z")

</div>

Hi

I am new to ELK Stack.  
Server details - 4 Vcpu , 16GB RAM  
here i am quering application log files (java applications)

Im getting following error on elasticsearch log file  
It comes when i access Dashboard (It has more queries)

**This is the Error**

```
  [2017-09-26T10:23:14,939][DEBUG][o.e.a.s.TransportSearchAction] [r7ldgie] [120571] Failed to execute fetch phase
org.elasticsearch.transport.RemoteTransportException: [r7ldgie][172.17.0.2:9300][indices:data/read/search[phase/fetch/id]]
Caused by: org.elasticsearch.transport.ResponseHandlerFailureTransportException: java.lang.UnsupportedOperationException
Caused by: java.lang.UnsupportedOperationException
	at org.elasticsearch.search.DocValueFormat$3.format(DocValueFormat.java:249) ~[elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.search.SearchSortValues.<init>(SearchSortValues.java:51) ~[elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.search.SearchHit.sortValues(SearchHit.java:417) ~[elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.action.search.SearchPhaseController.getHits(SearchPhaseController.java:391) ~[elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.action.search.SearchPhaseController.merge(SearchPhaseController.java:314) ~[elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.action.search.FetchSearchPhase.moveToNextPhase(FetchSearchPhase.java:206) ~[elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.action.search.FetchSearchPhase.lambda$innerRun$2(FetchSearchPhase.java:105) ~[elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.action.search.CountedCollector.countDown(CountedCollector.java:53) ~[elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.action.search.CountedCollector.onResult(CountedCollector.java:64) ~[elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.action.search.FetchSearchPhase$2.innerOnResponse(FetchSearchPhase.java:165) ~[elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.action.search.FetchSearchPhase$2.innerOnResponse(FetchSearchPhase.java:162) ~[elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.action.search.SearchActionListener.onResponse(SearchActionListener.java:44) ~[elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.action.search.SearchActionListener.onResponse(SearchActionListener.java:29) ~[elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.action.ActionListenerResponseHandler.handleResponse(ActionListenerResponseHandler.java:46) ~[elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.transport.TransportService$ContextRestoreResponseHandler.handleResponse(TransportService.java:1060) ~[elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.transport.TransportService$DirectResponseChannel.processResponse(TransportService.java:1134) [elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.transport.TransportService$DirectResponseChannel.sendResponse(TransportService.java:1124) [elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.transport.TransportService$DirectResponseChannel.sendResponse(TransportService.java:1113) [elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.transport.DelegatingTransportChannel.sendResponse(DelegatingTransportChannel.java:60) [elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.transport.RequestHandlerRegistry$TransportChannelWrapper.sendResponse(RequestHandlerRegistry.java:111) [elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.action.search.SearchTransportService$12.messageReceived(SearchTransportService.java:394) [elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.action.search.SearchTransportService$12.messageReceived(SearchTransportService.java:390) [elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.transport.RequestHandlerRegistry.processMessageReceived(RequestHandlerRegistry.java:69) [elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.transport.TransportService$7.doRun(TransportService.java:644) [elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.doRun(ThreadContext.java:638) [elasticsearch-5.5.0.jar:5.5.0]
	at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) [elasticsearch-5.5.0.jar:5.5.0]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_131]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_131]
	at java.lang.Thread.run(Thread.java:748) [?:1.8.0_131]
```

---

<div class="post-metadata">

**Author:** ![colings86](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/colings86/32/44960_2.png) [@colings86](https://discuss.elastic.co/u/colings86)\
**Post date:** [September 26, 2017, 10:43am UTC](https://discuss.elastic.co/t/failed-to-execute-fetch-phase-org-elasticsearch-transport-remotetransportexception/101829/2 "2017-09-26T10:43:22Z")

</div>

Could you paste the request that you are sending to elasticsearch that causes this error?

---

<div class="post-metadata">

**Author:** ![dedosan](https://avatars.discourse-cdn.com/v4/letter/d/e9c0ed/32.png) [@dedosan](https://discuss.elastic.co/u/dedosan)\
**Post date:** [September 26, 2017, 11:15am UTC](https://discuss.elastic.co/t/failed-to-execute-fetch-phase-org-elasticsearch-transport-remotetransportexception/101829/3 "2017-09-26T11:15:25Z")

</div>

@colings86 Thank you for the reply.

This Dashboard has more queries.  
Individually all queries (visual )are working without issue.  
But I added all visuals to DashBoard and tried to open dashboard. Then Kibana shows timeout

 ![tomeout](https://us1.discourse-cdn.com/elastic/original/3X/1/4/14b67b12174db264baff5cabcb0948d31ca299fd.JPG)

and Elastic search logs shows above error.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 24, 2017, 11:15am UTC](https://discuss.elastic.co/t/failed-to-execute-fetch-phase-org-elasticsearch-transport-remotetransportexception/101829/4 "2017-10-24T11:15:30Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
