# Failed to execute fetch phase

**URL:** <https://discuss.elastic.co/t/failed-to-execute-fetch-phase/65502>\
**Category:** Elasticsearch\
**Created:** [November 9, 2016, 2:00pm UTC](https://discuss.elastic.co/t/failed-to-execute-fetch-phase/65502 "2016-11-09T14:00:51Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![ironbeast](https://avatars.discourse-cdn.com/v4/letter/i/b5a626/32.png) [@ironbeast](https://discuss.elastic.co/u/ironbeast)\
**Post date:** [November 9, 2016, 2:00pm UTC](https://discuss.elastic.co/t/failed-to-execute-fetch-phase/65502/1 "2016-11-09T14:00:51Z")

</div>

I've got following lines constantly in my logs for elasticsearch 5:

[2016-11-09T14:58:45,189][DEBUG][o.e.a.s.TransportSearchAction] [elasticsearch01dev] [6702157] Failed to execute fetch phase  
org.elasticsearch.transport.RemoteTransportException: [elasticsearch03dev][10.206.13.145:9300][indices:data/read/search[phase/fetch/id]]  
Caused by: java.lang.IllegalArgumentException: features that prevent cachability are disabled on this context  
at org.elasticsearch.index.query.QueryShardContext.failIfFrozen(QueryShardContext.java:396) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.index.query.QueryShardContext.nowInMillis(QueryShardContext.java:278) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.index.mapper.TTLFieldMapper$TTLFieldType.valueForSearch(TTLFieldMapper.java:146) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.index.fieldvisitor.FieldsVisitor.postProcess(FieldsVisitor.java:93) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.search.fetch.FetchPhase.createSearchHit(FetchPhase.java:187) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.search.fetch.FetchPhase.execute(FetchPhase.java:152) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.search.SearchService.executeFetchPhase(SearchService.java:474) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.action.search.SearchTransportService.lambda$registerRequestHandler$13(SearchTransportService.java:311) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.action.search.SearchTransportService$$Lambda$1037/998004967.messageReceived(Unknown Source) ~[?:?]  
at org.elasticsearch.transport.TransportRequestHandler.messageReceived(TransportRequestHandler.java:33) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.transport.RequestHandlerRegistry.processMessageReceived(RequestHandlerRegistry.java:69) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.transport.TcpTransport$RequestHandler.doRun(TcpTransport.java:1348) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.doRun(ThreadContext.java:504) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) ~[elasticsearch-5.0.0.jar:5.0.0]  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) ~[?:1.8.0\_25]  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) ~[?:1.8.0\_25]  
at java.lang.Thread.run(Thread.java:745) [?:1.8.0\_25]

Anyone has any ideas?

---

<div class="post-metadata">

**Author:** ![ywelsch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ywelsch/32/7751_2.png) [@ywelsch](https://discuss.elastic.co/u/ywelsch)\
**Post date:** [November 9, 2016, 3:03pm UTC](https://discuss.elastic.co/t/failed-to-execute-fetch-phase/65502/2 "2016-11-09T15:03:41Z")

</div>

This might be an issue that we've fixed for 5.0.1:

> <https://github.com/elastic/elasticsearch/pull/21303>

I'll ping one of the engineers that worked on it @colings86 to confirm

---

<div class="post-metadata">

**Author:** ![colings86](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/colings86/32/44960_2.png) [@colings86](https://discuss.elastic.co/u/colings86)\
**Post date:** [November 9, 2016, 3:04pm UTC](https://discuss.elastic.co/t/failed-to-execute-fetch-phase/65502/3 "2016-11-09T15:04:24Z")

</div>

@ironbeast could you post the search request that produces this exception?

---

<div class="post-metadata">

**Author:** ![ironbeast](https://avatars.discourse-cdn.com/v4/letter/i/b5a626/32.png) [@ironbeast](https://discuss.elastic.co/u/ironbeast)\
**Post date:** [November 10, 2016, 6:02am UTC](https://discuss.elastic.co/t/failed-to-execute-fetch-phase/65502/4 "2016-11-10T06:02:49Z")

</div>

No search request yet... Just booting up the ES cluster

---

<div class="post-metadata">

**Author:** ![Clinton\_Gormley](https://avatars.discourse-cdn.com/v4/letter/c/50afbb/32.png) [@Clinton\_Gormley](https://discuss.elastic.co/u/Clinton_Gormley)\
**Post date:** [November 10, 2016, 8:47am UTC](https://discuss.elastic.co/t/failed-to-execute-fetch-phase/65502/5 "2016-11-10T08:47:40Z")

</div>

This still fails in 5.0.1. I've opened an issue: [https://github.com/elastic/elasticsearch/issues/21457](https://github.com/elastic/elasticsearch/issues/21457)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 8, 2016, 8:47am UTC](https://discuss.elastic.co/t/failed-to-execute-fetch-phase/65502/6 "2016-12-08T08:47:59Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
