# Failed to execute logstash.javapipeline \] Pipeline aborted due to error {:pipeline\_id=\>"main", :exception=\>#\<ArgumentError: The "sincedb\_path" argument must point to a file, received a directory: "C:/dev/null"\>

**URL:** https://discuss.elastic.co/t/failed-to-execute-logstash-javapipeline-pipeline-aborted-due-to-error-pipeline-id-main-exception-argumenterror-the-sincedb-path-argument-must-point-to-a-file-received-a-directory-c-dev-null/193272
**Category:** Logstash
**Created:** [August 1, 2019, 8:08am UTC](https://discuss.elastic.co/t/failed-to-execute-logstash-javapipeline-pipeline-aborted-due-to-error-pipeline-id-main-exception-argumenterror-the-sincedb-path-argument-must-point-to-a-file-received-a-directory-c-dev-null/193272 "2019-08-01T08:08:34Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![vikrant031](https://avatars.discourse-cdn.com/v4/letter/v/839c29/32.png) [@vikrant031](https://discuss.elastic.co/u/vikrant031)
#### Post date: [August 1, 2019, 8:08am UTC](https://discuss.elastic.co/t/failed-to-execute-logstash-javapipeline-pipeline-aborted-due-to-error-pipeline-id-main-exception-argumenterror-the-sincedb-path-argument-must-point-to-a-file-received-a-directory-c-dev-null/193272/1 "2019-08-01T08:08:34Z")

</div>

Config File:

input{  
file{  
path =\>"C:\logstash-7.2.0\config\cars.csv"  
start\_position =\> "beginning"  
sincedb\_path =\> "C:/dev/null"  
}  
}  
filter{  
csv{  
separator=\>","  
columns=\> ["maker", "model", "mileage", "manufacture\_year", "engine\_displacement", "engine\_power", "body\_type", "color\_slug", "stk\_year", "transmission", "door\_count", "seat\_count", "fuel\_type", "date\_created", "date\_last\_seen", "price\_eur"]  
}  
mutate{convert =\> ["mileage", "integer"]}  
mutate{convert =\> ["price\_eur", "float"]}  
mutate{convert =\> ["engine\_power", "integer"]}  
mutate{convert =\> ["door\_count", "integer"]}  
mutate{convert =\> ["seat\_count", "integer"]}  
}  
output {  
elasticsearch{  
hosts =\> ["localhost:9200"]  
index =\> ["cars"]  
document\_type =\> "sold\_cars"  
}  
stdout {}  
}

Error in Windows CMD:

C:\logstash-7.2.0\bin\>logstash.bat -f C:\Users\VikrantMittal\Desktop\Data\Logstash\_cars.config  
Thread.exclusive is deprecated, use Thread::Mutex  
Sending Logstash logs to C:/logstash-7.2.0/logs which is now configured via log4j2.properties  
[2019-08-01T13:21:23,859][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2019-08-01T13:21:23,884][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.2.0"}  
[2019-08-01T13:21:31,461][WARN][logstash.outputs.elasticsearch] You are using a deprecated config setting "document\_type" set in elasticsearch. Deprecated settings will continue to work, but are scheduled for removal from logstash in the future. Document types are being deprecated in Elasticsearch 6.0, and removed entirely in 7.0. You should avoid this feature If you have any questions about this, please visit the #logstash channel on freenode irc. {:name=\>"document\_type", :plugin=\>\<LogStash::Outputs::ElasticSearch index=\>"cars", id=\>"5925a7b6c4d4848492b1e1022f0f6e414241546eb04128795fc22767b3eea416", hosts=\>[[//localhost:9200](https://localhost:9200)], document\_type=\>"sold\_cars", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_54963c73-b2a1-4e33-859c-3a5bd3d5d9ac", enable\_metric=\>true, charset=\>"UTF-8"\>, workers=\>1, manage\_template=\>true, template\_name=\>"logstash", template\_overwrite=\>false, doc\_as\_upsert=\>false, script\_type=\>"inline", script\_lang=\>"painless", script\_var\_name=\>"event", scripted\_upsert=\>false, retry\_initial\_interval=\>2, retry\_max\_interval=\>64, retry\_on\_conflict=\>1, ilm\_enabled=\>"auto", ilm\_rollover\_alias=\>"logstash", ilm\_pattern=\>"{now/d}-000001", ilm\_policy=\>"logstash-policy", action=\>"index", ssl\_certificate\_verification=\>true, sniffing=\>false, sniffing\_delay=\>5, timeout=\>60, pool\_max=\>1000, pool\_max\_per\_route=\>100, resurrect\_delay=\>5, validate\_after\_inactivity=\>10000, http\_compression=\>false\>}  
[2019-08-01T13:21:32,359][INFO][logstash.outputs.elasticsearch] Elasticsearch pool URLs updated {:changes=\>{:removed=\>, :added=\>[[http://localhost:9200/](http://localhost:9200/)]}}  
[2019-08-01T13:21:32,682][WARN][logstash.outputs.elasticsearch] Restored connection to ES instance {:url=\>"[http://localhost:9200/](http://localhost:9200/)"}  
[2019-08-01T13:21:32,741][INFO][logstash.outputs.elasticsearch] ES Output version determined {:es\_version=\>7}  
[2019-08-01T13:21:32,744][WARN][logstash.outputs.elasticsearch] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document \_type {:es\_version=\>7}  
[2019-08-01T13:21:32,768][INFO][logstash.outputs.elasticsearch] New Elasticsearch output {:class=\>"LogStash::Outputs::ElasticSearch", :hosts=\>["[//localhost:9200](https://localhost:9200)"]}  
[2019-08-01T13:21:32,869][INFO][logstash.outputs.elasticsearch] Using default mapping template  
[2019-08-01T13:21:32,938][WARN][org.logstash.instrument.metrics.gauge.LazyDelegatingGauge] A gauge metric of an unknown type (org.jruby.specialized.RubyArrayOneObject) has been create for key: cluster\_uuids. This may result in invalid serialization. It is recommended to log an issue to the responsible developer/development team.  
[2019-08-01T13:21:32,943][INFO][logstash.javapipeline] Starting pipeline {:pipeline\_id=\>"main", "pipeline.workers"=\>4, "pipeline.batch.size"=\>125, "pipeline.batch.delay"=\>50, "pipeline.max\_inflight"=\>500, :thread=\>"#\<Thread:0x42c11 run\>"}  
[2019-08-01T13:21:32,945][INFO][logstash.outputs.elasticsearch] Attempting to install template {:manage\_template=\>{"index\_patterns"=\>"logstash-_", "version"=\>60001, "settings"=\>{"index.refresh\_interval"=\>"5s", "number\_of\_shards"=\>1}, "mappings"=\>{"dynamic\_templates"=\>[{"message\_field"=\>{"path\_match"=\>"message", "match\_mapping\_type"=\>"string", "mapping"=\>{"type"=\>"text", "norms"=\>false}}}, {"string\_fields"=\>{"match"=\>"_", "match\_mapping\_type"=\>"string", "mapping"=\>{"type"=\>"text", "norms"=\>false, "fields"=\>{"keyword"=\>{"type"=\>"keyword", "ignore\_above"=\>256}}}}}], "properties"=\>{"@timestamp"=\>{"type"=\>"date"}, "@version"=\>{"type"=\>"keyword"}, "geoip"=\>{"dynamic"=\>true, "properties"=\>{"ip"=\>{"type"=\>"ip"}, "location"=\>{"type"=\>"geo\_point"}, "latitude"=\>{"type"=\>"half\_float"}, "longitude"=\>{"type"=\>"half\_float"}}}}}}}  
[2019-08-01T13:21:35,828][ERROR][logstash.javapipeline] Pipeline aborted due to error {:pipeline\_id=\>"main", :exception=\>#\<ArgumentError: The "sincedb\_path" argument must point to a file, received a directory: "C:/dev/null"\>, :backtrace=\>["C:/logstash-7.2.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.10/lib/logstash/inputs/file.rb:280:in `register'", "C:/logstash-7.2.0/logstash-core/lib/logstash/java_pipeline.rb:192:in`block in register\_plugins'", "org/jruby/RubyArray.java:1792:in `each'", "C:/logstash-7.2.0/logstash-core/lib/logstash/java_pipeline.rb:191:in`register\_plugins'", "C:/logstash-7.2.0/logstash-core/lib/logstash/java\_pipeline.rb:292:in `start_inputs'", "C:/logstash-7.2.0/logstash-core/lib/logstash/java_pipeline.rb:248:in`start\_workers'", "C:/logstash-7.2.0/logstash-core/lib/logstash/java\_pipeline.rb:146:in `run'", "C:/logstash-7.2.0/logstash-core/lib/logstash/java_pipeline.rb:105:in`block in start'"], :thread=\>"#\<Thread:0x42c11 run\>"}  
[2019-08-01T13:21:35,881][ERROR][logstash.agent] Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not execute action: PipelineAction::Create, action\_result: false", :backtrace=\>nil}  
[2019-08-01T13:21:36,238][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2019-08-01T13:21:41,194][INFO][logstash.runner] Logstash shut down.

---

<div class="post-metadata">

### Author: ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)
#### Post date: [August 1, 2019, 10:57am UTC](https://discuss.elastic.co/t/failed-to-execute-logstash-javapipeline-pipeline-aborted-due-to-error-pipeline-id-main-exception-argumenterror-the-sincedb-path-argument-must-point-to-a-file-received-a-directory-c-dev-null/193272/2 "2019-08-01T10:57:13Z")

</div>

On Windows, if you do not want logstash to persists the in-memory sincedb to disk then set

```
 sincedb_path => "NUL"

```

Also, do not use backslash in path option of a file input, use forward slash.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 29, 2019, 10:57am UTC](https://discuss.elastic.co/t/failed-to-execute-logstash-javapipeline-pipeline-aborted-due-to-error-pipeline-id-main-exception-argumenterror-the-sincedb-path-argument-must-point-to-a-file-received-a-directory-c-dev-null/193272/3 "2019-08-29T10:57:17Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
