# Failed to execute on node Caused by: org.apache.lucene.store.AlreadyClosedException: this IndexReader is closed

**URL:** <https://discuss.elastic.co/t/failed-to-execute-on-node-caused-by-org-apache-lucene-store-alreadyclosedexception-this-indexreader-is-closed/114818>\
**Category:** Elasticsearch\
**Created:** [January 10, 2018, 9:01am UTC](https://discuss.elastic.co/t/failed-to-execute-on-node-caused-by-org-apache-lucene-store-alreadyclosedexception-this-indexreader-is-closed/114818 "2018-01-10T09:01:50Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![xlc](https://avatars.discourse-cdn.com/v4/letter/x/13edae/32.png) [@xlc](https://discuss.elastic.co/u/xlc)\
**Post date:** [January 10, 2018, 9:01am UTC](https://discuss.elastic.co/t/failed-to-execute-on-node-caused-by-org-apache-lucene-store-alreadyclosedexception-this-indexreader-is-closed/114818/1 "2018-01-10T09:01:50Z")

</div>

It seems to be an internal error in elsticsearch.I'm using 2.3.2 and one shard can not recover from the restart.Cluster yellow all the day.The log says  
RemoteTransportException[[10.10.3.16][10.10.3.16:9300][cluster:monitor/nodes/stats[n]]]; nested: AlreadyClosedException[this IndexReader is closed];  
Caused by: org.apache.lucene.store.AlreadyClosedException: this IndexReader is closed  
at org.apache.lucene.index.IndexReader.ensureOpen(IndexReader.java:274)  
at org.apache.lucene.index.CompositeReader.getContext(CompositeReader.java:101)  
at org.apache.lucene.index.CompositeReader.getContext(CompositeReader.java:55)  
at org.apache.lucene.index.IndexReader.leaves(IndexReader.java:438)  
at org.elasticsearch.search.suggest.completion.Completion090PostingsFormat.completionStats(Completion090PostingsFormat.java:330)  
at org.elasticsearch.index.shard.IndexShard.completionStats(IndexShard.java:765)  
at org.elasticsearch.action.admin.indices.stats.CommonStats.(CommonStats.java:164)  
at org.elasticsearch.indices.IndicesService.stats(IndicesService.java:253)  
at org.elasticsearch.node.service.NodeService.stats(NodeService.java:158)  
at org.elasticsearch.action.admin.cluster.node.stats.TransportNodesStatsAction.nodeOperation(TransportNodesStatsAction.java:82)  
at org.elasticsearch.action.admin.cluster.node.stats.TransportNodesStatsAction.nodeOperation(TransportNodesStatsAction.java:44)  
at org.elasticsearch.action.support.nodes.TransportNodesAction.nodeOperation(TransportNodesAction.java:92)  
at org.elasticsearch.action.support.nodes.TransportNodesAction$NodeTransportHandler.messageReceived(TransportNodesAction.java:230)  
at org.elasticsearch.action.support.nodes.TransportNodesAction$NodeTransportHandler.messageReceived(TransportNodesAction.java:226)  
at org.elasticsearch.transport.RequestHandlerRegistry.processMessageReceived(RequestHandlerRegistry.java:75)  
at org.elasticsearch.transport.netty.MessageChannelHandler$RequestHandler.doRun(MessageChannelHandler.java:300)  
at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)  
at java.lang.Thread.run(Thread.java:745)

Is there some way to make my cluster green again?

---

<div class="post-metadata">

**Author:** ![Fram\_Souza](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fram_souza/32/24833_2.png) [@Fram\_Souza](https://discuss.elastic.co/u/Fram_Souza)\
**Post date:** [January 10, 2018, 8:00pm UTC](https://discuss.elastic.co/t/failed-to-execute-on-node-caused-by-org-apache-lucene-store-alreadyclosedexception-this-indexreader-is-closed/114818/2 "2018-01-10T20:00:06Z")

</div>

See:

> [@RemoteTransportException - AlreadyClosedException\[this IndexReader is closed\]](https://discuss.elastic.co/t/remotetransportexception-alreadyclosedexception-this-indexreader-is-closed/49577/2):
>
> Yep, unfortunately this was a bug introduced in 2.3.0. It was just fixed in 2.3.2 (unreleased as of writing) so should be available soonish: [https://github.com/elastic/elasticsearch/pull/18094](https://github.com/elastic/elasticsearch/pull/18094) It's unclear to me if this is actually related to the problems you're having, it may just be coincidental. Can you describe your problem a bit more? Also, are you checking that A) there are no bulk rejections and B) if there are rejections, you're retrying the rejected documents? A rejection isn't re…

😉

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 7, 2018, 8:00pm UTC](https://discuss.elastic.co/t/failed-to-execute-on-node-caused-by-org-apache-lucene-store-alreadyclosedexception-this-indexreader-is-closed/114818/3 "2018-02-07T20:00:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
