# Failed to execute on node Caused by: org.apache.lucene.store.AlreadyClosedException: this IndexReader is closed

**URL:** <https://discuss.elastic.co/t/failed-to-execute-on-node-caused-by-org-apache-lucene-store-alreadyclosedexception-this-indexreader-is-closed/114818>\
**Category:** Elasticsearch\
**Created:** [January 10, 2018, 9:01am UTC](https://discuss.elastic.co/t/failed-to-execute-on-node-caused-by-org-apache-lucene-store-alreadyclosedexception-this-indexreader-is-closed/114818 "2018-01-10T09:01:50Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![Fram\_Souza](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fram_souza/32/24833_2.png) [@Fram\_Souza](https://discuss.elastic.co/u/Fram_Souza)\
**Post date:** [January 10, 2018, 8:00pm UTC](https://discuss.elastic.co/t/failed-to-execute-on-node-caused-by-org-apache-lucene-store-alreadyclosedexception-this-indexreader-is-closed/114818/2 "2018-01-10T20:00:06Z")

</div>

See:

> [@RemoteTransportException - AlreadyClosedException\[this IndexReader is closed\]](https://discuss.elastic.co/t/remotetransportexception-alreadyclosedexception-this-indexreader-is-closed/49577/2):
>
> Yep, unfortunately this was a bug introduced in 2.3.0. It was just fixed in 2.3.2 (unreleased as of writing) so should be available soonish: [https://github.com/elastic/elasticsearch/pull/18094](https://github.com/elastic/elasticsearch/pull/18094) It's unclear to me if this is actually related to the problems you're having, it may just be coincidental. Can you describe your problem a bit more? Also, are you checking that A) there are no bulk rejections and B) if there are rejections, you're retrying the rejected documents? A rejection isn't re…

😉

---

_[View the full topic](https://discuss.elastic.co/t/failed-to-execute-on-node-caused-by-org-apache-lucene-store-alreadyclosedexception-this-indexreader-is-closed/114818)._
