# Failed to find a X509ExtendedTrustManager in the trust manager factory for \[PKIX\] and truststore \[null\]

**URL:** <https://discuss.elastic.co/t/failed-to-find-a-x509extendedtrustmanager-in-the-trust-manager-factory-for-pkix-and-truststore-null/309547>\
**Category:** Elasticsearch\
**Created:** [July 13, 2022, 3:14pm UTC](https://discuss.elastic.co/t/failed-to-find-a-x509extendedtrustmanager-in-the-trust-manager-factory-for-pkix-and-truststore-null/309547 "2022-07-13T15:14:38Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![blaked](https://avatars.discourse-cdn.com/v4/letter/b/65b543/32.png) [@blaked](https://discuss.elastic.co/u/blaked)\
**Post date:** [July 13, 2022, 3:14pm UTC](https://discuss.elastic.co/t/failed-to-find-a-x509extendedtrustmanager-in-the-trust-manager-factory-for-pkix-and-truststore-null/309547/1 "2022-07-13T15:14:38Z")

</div>

I'm using Sonarqube Development Edition on Windows 2019 (I've previously posted this to the SQ forums but only gotten light feedback). Things have worked fine for years with the current config - but when I upgraded to SQ 9.5 I get this on service start

```auto
Exception
org.elasticsearch.common.ssl.SslConfigException: failed to find a X509ExtendedTrustManager in the trust manager factory for [PKIX] and truststore [null]

```

It would seem to indicate an issue with a certificate store. Since this is Windows, I regularly use:

```auto
setx _JAVA_OPTIONS "-Djavax.net.ssl.trustStoreType=WINDOWS-ROOT

```

to allow Java to leverage the native Windows certificate store (the JVM can use the OS cert store for all the corporate CAs instead of having to muck with java-specific cert files). This has worked on this system (and continues to work on a number of other non-Sonarqube servers I manage. If I remove the \_JAVA\_OPTIONS environment variable - the error disappears and the service will start (but as I discovered today, obviously I can't grok the corporate CA certs, so LDAP integration doesn't work - among other things).

Since I'm stuck on the Sonarqube side - I was hoping someone on the Elastic side might have some insight on any changes why this would suddenly stop working.

I'm running Azul Zulu JRE 11.56.19 FWIW.

Thanks much  
B

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 10, 2022, 3:15pm UTC](https://discuss.elastic.co/t/failed-to-find-a-x509extendedtrustmanager-in-the-trust-manager-factory-for-pkix-and-truststore-null/309547/2 "2022-08-10T15:15:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
