# Failed to find geo\_point field \[destination.geo.location\]

**URL:** <https://discuss.elastic.co/t/failed-to-find-geo-point-field-destination-geo-location/256966>\
**Category:** Elasticsearch\
**Created:** [November 28, 2020, 10:43pm UTC](https://discuss.elastic.co/t/failed-to-find-geo-point-field-destination-geo-location/256966 "2020-11-28T22:43:00Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![secopsgeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/secopsgeek/32/83957_2.png) [@secopsgeek](https://discuss.elastic.co/u/secopsgeek)\
**Post date:** [November 28, 2020, 10:43pm UTC](https://discuss.elastic.co/t/failed-to-find-geo-point-field-destination-geo-location/256966/1 "2020-11-28T22:43:00Z")

</div>

Hello everyone,

I am having some problems with geo.location showing up on that maps with errors.

This is my errors"

```auto
query_shard_exception at `shard` 0 `index` .ds-logs-windows.security-default-000001 `node` stUuKb8ZR424_ZwqrouRMg

Type

query_shard_exception

Reason

failed to find geo_point field [destination.geo.location]

Index uuid

cIg33sTNQ96U3C3f0YUoNw

Index

.ds-logs-windows.security-default-000001

```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 2, 2020, 1:10am UTC](https://discuss.elastic.co/t/failed-to-find-geo-point-field-destination-geo-location/256966/2 "2020-12-02T01:10:43Z")

</div>

Welcome to our community! 😃

Is this in Kibana? What is the mapping of that `.ds-logs-windows.security-default-000001` index?

---

<div class="post-metadata">

**Author:** ![ManuelF](https://avatars.discourse-cdn.com/v4/letter/m/e99b99/32.png) [@ManuelF](https://discuss.elastic.co/u/ManuelF)\
**Post date:** [December 3, 2020, 7:39pm UTC](https://discuss.elastic.co/t/failed-to-find-geo-point-field-destination-geo-location/256966/3 "2020-12-03T19:39:20Z")

</div>

Hi,

I'm experiencing the same issue on a fresh ELK 7.10 installation. I just deployed the _Elastic-Agent_ with the only integration _Endpoint_ , not even _system_ . Is there a solution or workaround available or this is still under research?

[![geolocation1](https://us1.discourse-cdn.com/elastic/original/3X/6/c/6c2773597b619e9455a31a980193d8609dc247ed.png)](https://user-images.githubusercontent.com/63368223/101078928-d02caf80-3574-11eb-87be-d49a98956ba0.PNG)  
[![geolocation2](https://us1.discourse-cdn.com/elastic/original/3X/5/a/5a69aa52ff38d160425b247aa8894fc917db70eb.png)](https://user-images.githubusercontent.com/63368223/101078935-d28f0980-3574-11eb-8238-fc7f77161a7f.PNG)  
[![geolocation3](https://us1.discourse-cdn.com/elastic/original/3X/6/c/6c2f09803d8f301c5380bd776fbeb3571d89c23e.png)](https://user-images.githubusercontent.com/63368223/101078948-d4f16380-3574-11eb-9600-5f43ab1429e3.PNG)

Thank you

---

<div class="post-metadata">

**Author:** ![ManuelF](https://avatars.discourse-cdn.com/v4/letter/m/e99b99/32.png) [@ManuelF](https://discuss.elastic.co/u/ManuelF)\
**Post date:** [December 8, 2020, 3:56pm UTC](https://discuss.elastic.co/t/failed-to-find-geo-point-field-destination-geo-location/256966/4 "2020-12-08T15:56:44Z")

</div>

Hi,

Any update on this?

Thanks

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 8, 2020, 8:14pm UTC](https://discuss.elastic.co/t/failed-to-find-geo-point-field-destination-geo-location/256966/5 "2020-12-08T20:14:43Z")

</div>

> [@warkolm](#):
>
> What is the mapping of that `.ds-logs-windows.security-default-000001` index?

Answering this will help us help you 🙂

---

<div class="post-metadata">

**Author:** ![ManuelF](https://avatars.discourse-cdn.com/v4/letter/m/e99b99/32.png) [@ManuelF](https://discuss.elastic.co/u/ManuelF)\
**Post date:** [December 9, 2020, 2:05pm UTC](https://discuss.elastic.co/t/failed-to-find-geo-point-field-destination-geo-location/256966/6 "2020-12-09T14:05:48Z")

</div>

> [@warkolm](#):
>
> .ds-logs-windows.security-default-000001

Hi,

I have no index `.ds-logs-windows.security-default-000001` on my ES. Instead the issue is related to the following indexes (I have included the mappings):

- `.ds-logs-elastic_agent.metricbeat-default-000001`  
[Mapping](https://pastebin.com/frFnMy44)
- `.ds-logs-elastic_agent.filebeat-default-000001`  
[Mapping](https://pastebin.com/zy7T0YbB)
- `.ds-logs-elastic_agent-default-000001`  
[Mapping](https://pastebin.com/rxjte25N)

Thank you

---

<div class="post-metadata">

**Author:** ![ManuelF](https://avatars.discourse-cdn.com/v4/letter/m/e99b99/32.png) [@ManuelF](https://discuss.elastic.co/u/ManuelF)\
**Post date:** [December 14, 2020, 1:56pm UTC](https://discuss.elastic.co/t/failed-to-find-geo-point-field-destination-geo-location/256966/7 "2020-12-14T13:56:14Z")

</div>

Hi,

Any update on this report?

Thank you

---

<div class="post-metadata">

**Author:** ![secopsgeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/secopsgeek/32/83957_2.png) [@secopsgeek](https://discuss.elastic.co/u/secopsgeek)\
**Post date:** [December 14, 2020, 5:01pm UTC](https://discuss.elastic.co/t/failed-to-find-geo-point-field-destination-geo-location/256966/8 "2020-12-14T17:01:49Z")

</div>

Sorry It took so long I fixed it by adding geoinfo to my packetbeat file on the server. Once I've done that I added the geo pipline script from the website, and data showed up. Once I executed that PUT query in the dev tools I was good.

---

<div class="post-metadata">

**Author:** ![ManuelF](https://avatars.discourse-cdn.com/v4/letter/m/e99b99/32.png) [@ManuelF](https://discuss.elastic.co/u/ManuelF)\
**Post date:** [December 14, 2020, 5:17pm UTC](https://discuss.elastic.co/t/failed-to-find-geo-point-field-destination-geo-location/256966/9 "2020-12-14T17:17:02Z")

</div>

Hi @secopsgeek,

Thank you for the feedback. So, I was not sure if I had to configure all the [pipeline stuff](https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-geoip.html) for the geoIP, like I did on previous ELK versions. I thought it was already included by default in ELK 7.10, but it looks I was wrong. I'll start working on that next.

Thank you

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 11, 2021, 5:17pm UTC](https://discuss.elastic.co/t/failed-to-find-geo-point-field-destination-geo-location/256966/10 "2021-01-11T17:17:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
