# Failed to import dashboard 7.2.0

**URL:** <https://discuss.elastic.co/t/failed-to-import-dashboard-7-2-0/187804>\
**Category:** Kibana\
**Created:** [June 27, 2019, 10:18am UTC](https://discuss.elastic.co/t/failed-to-import-dashboard-7-2-0/187804 "2019-06-27T10:18:29Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![alerta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alerta/32/46227_2.png) [@alerta](https://discuss.elastic.co/u/alerta)\
**Post date:** [June 27, 2019, 10:18am UTC](https://discuss.elastic.co/t/failed-to-import-dashboard-7-2-0/187804/1 "2019-06-27T10:18:29Z")

</div>

ES version: 7.2.0 (with xpack.security.enabled: true)  
Kibana version: 7.2.0  
Filebeat version: 7.2.0

Hello guys!  
I tried add data to Kibana with filebeat. And when i run command "filebeat setup" i see some errors in output logs. Whats wrong?

Index setup finished.  
Loading dashboards (Kibana must be running and reachable)  
Exiting: Failed to import dashboard: Failed to load directory /usr/share/filebeat/kibana/7/dashboard:  
error loading /usr/share/filebeat/kibana/7/dashboard/Coredns-Overview-Dashboard.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-Cisco-ASA.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-Envoyproxy-Overview.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-Iptables-Overview.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-Iptables-Ubiquiti-Firewall-Overview.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-Kafka-overview.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-Mongodb-overview.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-Postgresql-overview.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-Postgresql-slowlogs.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-Suricata-Alert-Overview.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-Suricata-Overview.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-Zeek-Overview.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-apache.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-auditd.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-auth-sudo-commands.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-haproxy-overview.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-icinga-debug-log.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-icinga-main-log.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-icinga-startup-errors.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-iis.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-logstash-log.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-logstash-slowlog.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-mysql.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,search,visualization"}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-nats-overview.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Unable to bulk\_create dashboard,visualization"}  
} and etc......

---

<div class="post-metadata">

**Author:** ![willemdh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/willemdh/32/16922_2.png) [@willemdh](https://discuss.elastic.co/u/willemdh)\
**Post date:** [June 27, 2019, 11:38am UTC](https://discuss.elastic.co/t/failed-to-import-dashboard-7-2-0/187804/2 "2019-06-27T11:38:47Z")

</div>

Hello,

We are experiencing the same issue.

Grtz

Willem

---

<div class="post-metadata">

**Author:** ![icefish-creativ](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/icefish-creativ/32/35699_2.png) [@icefish-creativ](https://discuss.elastic.co/u/icefish-creativ)\
**Post date:** [June 28, 2019, 8:36am UTC](https://discuss.elastic.co/t/failed-to-import-dashboard-7-2-0/187804/3 "2019-06-28T08:36:18Z")

</div>

hi

the same error with auditbeat & metricbeat too ☹

---

<div class="post-metadata">

**Author:** ![alerta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alerta/32/46227_2.png) [@alerta](https://discuss.elastic.co/u/alerta)\
**Post date:** [July 2, 2019, 4:19pm UTC](https://discuss.elastic.co/t/failed-to-import-dashboard-7-2-0/187804/4 "2019-07-02T16:19:38Z")

</div>

@sqren Can you help us?

---

<div class="post-metadata">

**Author:** ![bigdamhero](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bigdamhero/32/34478_2.png) [@bigdamhero](https://discuss.elastic.co/u/bigdamhero)\
**Post date:** [July 9, 2019, 8:10pm UTC](https://discuss.elastic.co/t/failed-to-import-dashboard-7-2-0/187804/5 "2019-07-09T20:10:11Z")

</div>

We are having the same issue here. Have removed some templates. Tried enabling the compatibility mode \<migration.6\_to\_7.enabled: true\> . Anyone have a fix?

---

<div class="post-metadata">

**Author:** ![cwurm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cwurm/32/34882_2.png) [@cwurm](https://discuss.elastic.co/u/cwurm)\
**Post date:** [July 10, 2019, 8:15am UTC](https://discuss.elastic.co/t/failed-to-import-dashboard-7-2-0/187804/6 "2019-07-10T08:15:55Z")

</div>

I saw a case recently where this error was hiding a permission issue. Do people on this thread have Kibana security enabled? If yes, please double check that the Beats user has the required privileges (esp. `kibana_user`).

---

<div class="post-metadata">

**Author:** ![cwurm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cwurm/32/34882_2.png) [@cwurm](https://discuss.elastic.co/u/cwurm)\
**Post date:** [July 10, 2019, 8:33am UTC](https://discuss.elastic.co/t/failed-to-import-dashboard-7-2-0/187804/7 "2019-07-10T08:33:55Z")

</div>

Fyi, I've been able to reproduce it and have opened a bug report at [https://github.com/elastic/kibana/issues/40714](https://github.com/elastic/kibana/issues/40714)

---

<div class="post-metadata">

**Author:** ![golaso](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/golaso/32/49967_2.png) [@golaso](https://discuss.elastic.co/u/golaso)\
**Post date:** [July 11, 2019, 3:24pm UTC](https://discuss.elastic.co/t/failed-to-import-dashboard-7-2-0/187804/8 "2019-07-11T15:24:32Z")

</div>

Where is the permission lists for kibana user and beat user to check?

---

<div class="post-metadata">

**Author:** ![cwurm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cwurm/32/34882_2.png) [@cwurm](https://discuss.elastic.co/u/cwurm)\
**Post date:** [July 11, 2019, 4:00pm UTC](https://discuss.elastic.co/t/failed-to-import-dashboard-7-2-0/187804/9 "2019-07-11T16:00:29Z")

</div>

@golaso `kibana_user` is the only role your Kibana user should need to import dashboards.

The `filebeat setup` command also sets up things in Elasticsearch and so needs `beats_system` and `ingest_admin` as well I think. Not all of these privileges are necessary after running setup.

---

<div class="post-metadata">

**Author:** ![golaso](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/golaso/32/49967_2.png) [@golaso](https://discuss.elastic.co/u/golaso)\
**Post date:** [July 12, 2019, 8:00am UTC](https://discuss.elastic.co/t/failed-to-import-dashboard-7-2-0/187804/11 "2019-07-12T08:00:28Z")

</div>

> [@cwurm](#):
>
> The `filebeat setup` command also sets up things in Elasticsearch and so needs `beats_system` and `ingest_admin` as well I think. Not all of these privileges are necessary after running setup.

Well, now i have this error with `beats_system` and `ingest_admin` permissions for beat user:  
`action [indices:admin/create] is unauthorized for user [metricbeat_internal]`  
What index (or index pattern) requires this permission?  
I already have `create` , `create_index` , `write` , `manage_ilm` permissions on `metricbeat-*` index pattern.

---

<div class="post-metadata">

**Author:** ![cwurm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cwurm/32/34882_2.png) [@cwurm](https://discuss.elastic.co/u/cwurm)\
**Post date:** [July 12, 2019, 3:10pm UTC](https://discuss.elastic.co/t/failed-to-import-dashboard-7-2-0/187804/12 "2019-07-12T15:10:02Z")

</div>

@golaso Sorry, my bad. I've done some testing, here's what privileges should be required. You can create roles that have these and then assign them to the user(s).

**Setup**

1. monitor
2. manage\_ilm
3. manage\_index\_templates
4. manage (on `metricbeat-*`)
5. manage\_pipeline
6. + kibana\_user (separate role to load Kibana dashboards)

**Run**

1. monitor
2. read\_ilm
3. manage\_index\_templates
4. view\_index\_metadata (on `metricbeat-*`)
5. index (on `metricbeat-*`)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 9, 2019, 3:10pm UTC](https://discuss.elastic.co/t/failed-to-import-dashboard-7-2-0/187804/13 "2019-08-09T15:10:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
