# Failed to install kibana 7.17.2 on Amazon Linux 2

**URL:** <https://discuss.elastic.co/t/failed-to-install-kibana-7-17-2-on-amazon-linux-2/302945>\
**Category:** Kibana\
**Created:** [April 21, 2022, 4:00pm UTC](https://discuss.elastic.co/t/failed-to-install-kibana-7-17-2-on-amazon-linux-2/302945 "2022-04-21T16:00:57Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![chrisbra](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chrisbra/32/104662_2.png) [@chrisbra](https://discuss.elastic.co/u/chrisbra)\
**Post date:** [April 21, 2022, 4:00pm UTC](https://discuss.elastic.co/t/failed-to-install-kibana-7-17-2-on-amazon-linux-2/302945/1 "2022-04-21T16:00:57Z")

</div>

I I downloaded kibana 7.17.2 as rpm package.

Unfortunately, when trying to run it, it fails with those errors:

```auto
~ $ sudo /usr/share/kibana/bin/kibana
/usr/share/kibana/bin/../node/bin/node: /lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/share/kibana/bin/../node/bin/node)
/usr/share/kibana/bin/../node/bin/node: /lib/libstdc++.so.6: version `GLIBCXX_3.4.18' not found (required by /usr/share/kibana/bin/../node/bin/node)
/usr/share/kibana/bin/../node/bin/node: /lib/libstdc++.so.6: version `CXXABI_1.3.5' not found (required by /usr/share/kibana/bin/../node/bin/node)
/usr/share/kibana/bin/../node/bin/node: /lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/share/kibana/bin/../node/bin/node)

```

This is the system where it fails:

```auto
~ $ lsb_release -a
LSB Version: :core-4.1-amd64:core-4.1-noarch
Distributor ID: Amazon
Description: Amazon Linux release 2 (Karoo)
Release: 2
Codename: Karoo
~ $ uname -a
Linux cal0661ca036 4.14.248-189.473.amzn2.x86_64 #1 SMP Mon Sep 27 05:52:26 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
~ $ cat /etc/os-release
	NAME="Amazon Linux"
	VERSION="2"
	ID="amzn"
	ID_LIKE="centos rhel fedora"
	VERSION_ID="2"
	PRETTY_NAME="Amazon Linux 2"
	ANSI_COLOR="0;33"
	CPE_NAME="cpe:2.3:o:amazon:amazon_linux:2"
	HOME_URL="https://amazonlinux.com/"

```

According to my research Amazon Linux 2 should be based on CentOS7 and that one should be still supported according to the product matrix: [Unterstützungsmatrix | Elastic](https://www.elastic.co/de/support/matrix)

So what to do?

Thanks,  
Chris

---

<div class="post-metadata">

**Author:** ![tiagocosta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tiagocosta/32/40045_2.png) [@tiagocosta](https://discuss.elastic.co/u/tiagocosta)\
**Post date:** [April 21, 2022, 4:58pm UTC](https://discuss.elastic.co/t/failed-to-install-kibana-7-17-2-on-amazon-linux-2/302945/2 "2022-04-21T16:58:20Z")

</div>

Hi @chrisbra ,

Could you confirm which `glibc` version you have currently installed? I believe you need `2.28+` to use the version of node shipped there.

Meanwhile I've created a Github issue to proper investigate and track this: [Kibana 7.17.2 rpm install fails on Amazon Linux 2 · Issue #130813 · elastic/kibana · GitHub](https://github.com/elastic/kibana/issues/130813)

Cheers

---

<div class="post-metadata">

**Author:** ![chrisbra](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chrisbra/32/104662_2.png) [@chrisbra](https://discuss.elastic.co/u/chrisbra)\
**Post date:** [April 21, 2022, 7:21pm UTC](https://discuss.elastic.co/t/failed-to-install-kibana-7-17-2-on-amazon-linux-2/302945/3 "2022-04-21T19:21:09Z")

</div>

Thanks, I'll check the referenced issue as well.

Here is the information regarding glibc which I can provide:

```auto
[root@cal0661ca036 prometheus]# ldd --version
ldd (GNU libc) 2.26
Copyright (C) 2017 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Roland McGrath and Ulrich Drepper.
[root@cal0661ca036 prometheus]# rpm -q glibc
glibc-2.26-54.amzn2.x86_64
glibc-2.26-54.amzn2.i686

```

Interestingly, I just spin up another AWS instance and cannot reproduce it there with same kernel and glibc version, but I do not really know what kind of an AMI image the customer has been using.

Thanks,  
Chris

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 19, 2022, 7:21pm UTC](https://discuss.elastic.co/t/failed-to-install-kibana-7-17-2-on-amazon-linux-2/302945/4 "2022-05-19T19:21:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
