# Failed to install template

**URL:** <https://discuss.elastic.co/t/failed-to-install-template/91918>\
**Category:** Logstash\
**Created:** [July 5, 2017, 2:07pm UTC](https://discuss.elastic.co/t/failed-to-install-template/91918 "2017-07-05T14:07:25Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![erion](https://avatars.discourse-cdn.com/v4/letter/e/779978/32.png) [@erion](https://discuss.elastic.co/u/erion)\
**Post date:** [July 5, 2017, 2:07pm UTC](https://discuss.elastic.co/t/failed-to-install-template/91918/1 "2017-07-05T14:07:25Z")

</div>

Hi,  
I use two different machine: one with filebeat and other with logstash. Elasticsearch is on web service.  
I configure filebeat.yml like this:

> filebeat.prospectors:  
> -input\_type: log  
> path:  
> - /mnt/analisilog/www.access\_log  
> output.logstash:  
> hosts: ["52.20.987.249:5044"]

the hosts is the IP of logstash machine.  
logstash.conf:

> input {  
> beats {  
> port =\> 5044 }  
> }  
> output {  
> stdout {  
> codec =\> dots {}  
> }

> elasticsearch {  
> hosts =\> ["https://search-analisilog-  
> [kmymdimynogbrfy.eu-west-1.es.amazonaws.com](http://kmymdimynogbrfy.eu-west-1.es.amazonaws.com)"]  
> index =\> "%{[@metadata][beat]}-%{+YYYY.MM.dd}"  
> document\_type =\> "%{[@metadata][type]}"  
> }  
> }

i follow the guide to upload manually filebeat.template.json.  
Now for comunicating of two machines i have to start logstash and filebeat but when i start logstash send me error:

> [2017-07-05T16:00:41,147][ERROR][logstash.outputs.elasticsearch] Failed to install template. {:message=\>"Got response code '403' contacting Elasticsearch at URL...

On Logstash machine i've installed logstash-input-beats on logstash directory.  
My logstash doesn't start.  
Thanks for replay

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [July 7, 2017, 9:33am UTC](https://discuss.elastic.co/t/failed-to-install-template/91918/2 "2017-07-07T09:33:48Z")

</div>

A 403 response means "forbidden" so you probably don't have permissions to post index template updates, at least not without authenticating first.

---

<div class="post-metadata">

**Author:** ![erion](https://avatars.discourse-cdn.com/v4/letter/e/779978/32.png) [@erion](https://discuss.elastic.co/u/erion)\
**Post date:** [July 7, 2017, 10:06am UTC](https://discuss.elastic.co/t/failed-to-install-template/91918/3 "2017-07-07T10:06:57Z")

</div>

Thank you very much

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 4, 2017, 10:07am UTC](https://discuss.elastic.co/t/failed-to-install-template/91918/4 "2017-08-04T10:07:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
