# Failed to load plugin class \[org.elasticsearch.xpack.XPackPlugin\] ELASTICSEARCH

**URL:** https://discuss.elastic.co/t/failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin-elasticsearch/110381
**Category:** Elasticsearch
**Created:** [December 5, 2017, 3:05pm UTC](https://discuss.elastic.co/t/failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin-elasticsearch/110381 "2017-12-05T15:05:23Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![yakiza](https://avatars.discourse-cdn.com/v4/letter/y/d07c76/32.png) [@yakiza](https://discuss.elastic.co/u/yakiza)
#### Post date: [December 5, 2017, 3:05pm UTC](https://discuss.elastic.co/t/failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin-elasticsearch/110381/1 "2017-12-05T15:05:24Z")

</div>

HEllo i have just installed x-pack on elasticsearch ,kibana, logstash and once i start elasticsearch i get this, any clues?

thanks in advance

> Blockquote[2017-12-05T15:00:29,194][INFO][o.e.n.Node] initializing ...  
> [2017-12-05T15:00:29,337][INFO][o.e.e.NodeEnvironment] [DAg1kKg] using [1] data paths, mounts [[/home (/dev/sda8)]], net usable\_space [391.6gb], net total\_space [419.6gb], spins? [possibly], types [ext4]  
> [2017-12-05T15:00:29,337][INFO][o.e.e.NodeEnvironment] [DAg1kKg] heap size [1.9gb], compressed ordinary object pointers [true]  
> [2017-12-05T15:00:29,449][INFO][o.e.n.Node] node name [DAg1kKg] derived from node ID [DAg1kKgvTeSdN\_15z1aL-w]; set [node.name] to override  
> [2017-12-05T15:00:29,449][INFO][o.e.n.Node] version[5.6.4], pid[4229], build[8bbedf5/2017-10-31T18:55:38.105Z], OS[Linux/4.12.0-kali1-amd64/amd64], JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/1.8.0\_144/25.144-b01]  
> [2017-12-05T15:00:29,449][INFO][o.e.n.Node] JVM arguments [-Xms2g, -Xmx2g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -Djdk.io.permissionsUseCanonicalPath=true, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Dlog4j.skipJansi=true, -XX:+HeapDumpOnOutOfMemoryError, -Des.path.home=/home/secis/Documents/ELK/elasticsearch-5.6.4]  
> [2017-12-05T15:00:30,625][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] uncaught exception in thread [main]  
> org.elasticsearch.bootstrap.StartupException: ElasticsearchException[Failed to load plugin class [org.elasticsearch.xpack.XPackPlugin]]; nested: InvocationTargetException; nested: IllegalArgumentException[the [action.auto\_create\_index] setting value [.security,.monitoring\*,.watches,.triggered\_watches,.watcher-history\*,.ml\*] is too restrictive. disable [action.auto\_create\_index] or set it to [.security,.security-6]];  
> at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:123) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:70) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:134) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) ~[elasticsearch-5.6.4.jar:5.6.4]  
> Caused by: org.elasticsearch.ElasticsearchException: Failed to load plugin class [org.elasticsearch.xpack.XPackPlugin]  
> at org.elasticsearch.plugins.PluginsService.loadPlugin(PluginsService.java:438) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:391) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.plugins.PluginsService.(PluginsService.java:141) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.node.Node.(Node.java:313) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.node.Node.(Node.java:245) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:233) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:233) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:342) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:132) ~[elasticsearch-5.6.4.jar:5.6.4]  
> ... 6 more  
> Caused by: java.lang.reflect.InvocationTargetException  
> at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:?]  
> at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:?]  
> at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:?]  
> at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:1.8.0\_144]  
> at org.elasticsearch.plugins.PluginsService.loadPlugin(PluginsService.java:427) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:391) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.plugins.PluginsService.(PluginsService.java:141) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.node.Node.(Node.java:313) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.node.Node.(Node.java:245) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:233) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:233) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:342) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:132) ~[elasticsearch-5.6.4.jar:5.6.4]  
> ... 6 more  
> Caused by: java.lang.IllegalArgumentException: the [action.auto\_create\_index] setting value [.security,.monitoring\*,.watches,.triggered\_watches,.watcher-history\*,.ml\*] is too restrictive. disable [action.auto\_create\_index] or set it to [.security,.security-6]  
> at org.elasticsearch.xpack.security.Security.validateAutoCreateIndex(Security.java:812) ~[?:?]  
> at org.elasticsearch.xpack.security.Security.(Security.java:252) ~[?:?]  
> at org.elasticsearch.xpack.XPackPlugin.(XPackPlugin.java:219) ~[?:?]  
> at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:?]  
> at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:?]  
> at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:?]  
> at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:1.8.0\_144]  
> at org.elasticsearch.plugins.PluginsService.loadPlugin(PluginsService.java:427) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:391) ~[elasticsearch-5.6.4.jar:5.6.4]  
> at org.elasticsearch.plugins.PluginsService.(PluginsService.java:141) ~[elasticsearch-

---

<div class="post-metadata">

### Author: ![dakrone](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dakrone/32/23351_2.png) [@dakrone](https://discuss.elastic.co/u/dakrone)
#### Post date: [December 5, 2017, 4:00pm UTC](https://discuss.elastic.co/t/failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin-elasticsearch/110381/2 "2017-12-05T16:00:42Z")

</div>

The error is contained in the message, it was unable to start because it needs to be able to create a certain index (for the security index), see:

> [@yakiza](#):
>
> ```
> org.elasticsearch.bootstrap.StartupException: ElasticsearchException[Failed to load plugin class [org.elasticsearch.xpack.XPackPlugin]]; nested: InvocationTargetException; nested: IllegalArgumentException[the [action.auto_create_index] setting value [.security,.monitoring*,.watches,.triggered_watches,.watcher-history*,.ml*] is too restrictive. disable [action.auto_create_index] or set it to [.security,.security-6]];
> 
> ```

Specifically:

```
the [action.auto_create_index] setting value [.security,.monitoring*,.watches,.triggered_watches,.watcher-history*,.ml*] is too restrictive. disable [action.auto_create_index] or set it to [.security,.security-6]

```

You'll need to update the `action.auto_create_index` settingand restart ES.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 2, 2018, 4:01pm UTC](https://discuss.elastic.co/t/failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin-elasticsearch/110381/3 "2018-01-02T16:01:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
