# Failed to load plugin class \[org.elasticsearch.xpack.XPackPlugin\]

**URL:** <https://discuss.elastic.co/t/failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/71030>\
**Category:** Elasticsearch\
**Created:** [January 10, 2017, 7:32am UTC](https://discuss.elastic.co/t/failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/71030 "2017-01-10T07:32:08Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![shaonbean](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaonbean/32/14416_2.png) [@shaonbean](https://discuss.elastic.co/u/shaonbean)\
**Post date:** [January 10, 2017, 7:32am UTC](https://discuss.elastic.co/t/failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/71030/1 "2017-01-10T07:32:08Z")

</div>

I use yum install elasticsearch 5.1.1 (three nodes), before install x-pack, the elasticsearch clluster correct,  
but then install x-pack restrat elasticsearch all nodes failed...

[2017-01-10T15:32:40,128][INFO][o.e.x.m.e.Exporters] [elastic-2] skipping exporter [default\_local] as it isn't ready yet  
[2017-01-10T15:32:40,134][ERROR][o.e.x.m.AgentService] [elastic-2] exception when exporting documents  
org.elasticsearch.xpack.monitoring.exporter.ExportException: exporters are either not ready or faulty  
at org.elasticsearch.xpack.monitoring.exporter.Exporters.export(Exporters.java:188) ~[x-pack-5.1.1.jar:5.1.1]  
at org.elasticsearch.xpack.monitoring.AgentService$ExportingWorker.run(AgentService.java:208) [x-pack-5.1.1.jar:5.1.1]  
at java.lang.Thread.run(Thread.java:745) [?:1.8.0\_111]

---

<div class="post-metadata">

**Author:** ![bohyun](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bohyun/32/10087_2.png) [@bohyun](https://discuss.elastic.co/u/bohyun)\
**Post date:** [January 10, 2017, 7:33am UTC](https://discuss.elastic.co/t/failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/71030/2 "2017-01-10T07:33:20Z")

</div>

Hi @shaonbean

Did you install X-Pack on all of your nodes?

Thanks,  
Bohyun

---

<div class="post-metadata">

**Author:** ![shaonbean](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaonbean/32/14416_2.png) [@shaonbean](https://discuss.elastic.co/u/shaonbean)\
**Post date:** [January 10, 2017, 7:39am UTC](https://discuss.elastic.co/t/failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/71030/3 "2017-01-10T07:39:35Z")

</div>

yes ,I install x-apck on all nodes

---

<div class="post-metadata">

**Author:** ![shaonbean](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaonbean/32/14416_2.png) [@shaonbean](https://discuss.elastic.co/u/shaonbean)\
**Post date:** [January 10, 2017, 7:48am UTC](https://discuss.elastic.co/t/failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/71030/4 "2017-01-10T07:48:23Z")

</div>

If I remove x-pack on all nodes. then restart elasticsearch correct...

So help me..

---

<div class="post-metadata">

**Author:** ![bohyun](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bohyun/32/10087_2.png) [@bohyun](https://discuss.elastic.co/u/bohyun)\
**Post date:** [January 10, 2017, 8:03am UTC](https://discuss.elastic.co/t/failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/71030/5 "2017-01-10T08:03:30Z")

</div>

Hi @shaonbean

Could you please shut down all nodes, and re-install x-pack on all nodes? Then please re-start the nodes.

It could be that you didn't start up the elected master node before other ones. The elected master node is the one that adds the templates to the cluster, which the rest of the local exporters wait to see before running (default\_local).

Thanks,  
Bohyun

---

<div class="post-metadata">

**Author:** ![shaonbean](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaonbean/32/14416_2.png) [@shaonbean](https://discuss.elastic.co/u/shaonbean)\
**Post date:** [January 10, 2017, 9:12am UTC](https://discuss.elastic.co/t/failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/71030/6 "2017-01-10T09:12:33Z")

</div>

Hi Bohuyun

i have tried your method, but still not work...Now,I give up install x-apck. Still want to thank you....

---

<div class="post-metadata">

**Author:** ![nanshan](https://avatars.discourse-cdn.com/v4/letter/n/858c86/32.png) [@nanshan](https://discuss.elastic.co/u/nanshan)\
**Post date:** [January 14, 2017, 5:22am UTC](https://discuss.elastic.co/t/failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/71030/7 "2017-01-14T05:22:17Z")

</div>

I am having the same error:

if I set up like this with the private ips of 3 master node:  
discovery.zen.ping.unicast.hosts: ["10.0.12.242", "10.0.20.216", "10.0.19.11"]

but if I use the elb: elasticmaster-master  
discovery.zen.ping.unicast.hosts: ]"elasticsearch-master.dev-ore.vsco.plumbing"]

Then i got the error:  
org.elasticsearch.xpack.monitoring.exporter.ExportException: exporters are either not ready or faulty

---

<div class="post-metadata">

**Author:** ![nanshan](https://avatars.discourse-cdn.com/v4/letter/n/858c86/32.png) [@nanshan](https://discuss.elastic.co/u/nanshan)\
**Post date:** [January 18, 2017, 2:38am UTC](https://discuss.elastic.co/t/failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/71030/8 "2017-01-18T02:38:40Z")

</div>

what do you mean shut down all the nodes, stop the elasticsearch on the node?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 15, 2017, 2:38am UTC](https://discuss.elastic.co/t/failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/71030/9 "2017-02-15T02:38:44Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
