# Failed to load process information for PID 32338: readlink /proc/32338/exe: permission denied

**URL:** https://discuss.elastic.co/t/failed-to-load-process-information-for-pid-32338-readlink-proc-32338-exe-permission-denied/309420
**Category:** Beats
**Tags:** auditbeat
**Created:** [July 12, 2022, 12:47pm UTC](https://discuss.elastic.co/t/failed-to-load-process-information-for-pid-32338-readlink-proc-32338-exe-permission-denied/309420 "2022-07-12T12:47:52Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Maksym\_Postument](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/maksym_postument/32/106661_2.png) [@Maksym\_Postument](https://discuss.elastic.co/u/Maksym_Postument)
#### Post date: [July 12, 2022, 12:47pm UTC](https://discuss.elastic.co/t/failed-to-load-process-information-for-pid-32338-readlink-proc-32338-exe-permission-denied/309420/1 "2022-07-12T12:47:52Z")

</div>

Hello, i have auditbeat version 8.3.2 running in kubernetes and i am getting this kind of error all of the time

```auto
failed to load process information for PID 32338: readlink /proc/32338/exe: permission denied

```

I am using config similar to this one [beats/auditbeat-configmap.yaml at main · elastic/beats · GitHub](https://github.com/elastic/beats/blob/main/deploy/kubernetes/auditbeat/auditbeat-configmap.yaml)

Any ideas why i am getting this error?

I

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 9, 2022, 2:48pm UTC](https://discuss.elastic.co/t/failed-to-load-process-information-for-pid-32338-readlink-proc-32338-exe-permission-denied/309420/2 "2022-08-09T14:48:37Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
