# Failed to load resource: the server responded with a status of 405 (Method Not Allowed)

**URL:** https://discuss.elastic.co/t/failed-to-load-resource-the-server-responded-with-a-status-of-405-method-not-allowed/183955
**Category:** Kibana
**Created:** [June 3, 2019, 12:07pm UTC](https://discuss.elastic.co/t/failed-to-load-resource-the-server-responded-with-a-status-of-405-method-not-allowed/183955 "2019-06-03T12:07:43Z")
**Posts on this page:** 1
**Showing post:** 5

<div class="post-metadata">

### Author: ![vipulnewaskar7](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vipulnewaskar7/32/47332_2.png) [@vipulnewaskar7](https://discuss.elastic.co/u/vipulnewaskar7)
#### Post date: [June 4, 2019, 7:41am UTC](https://discuss.elastic.co/t/failed-to-load-resource-the-server-responded-with-a-status-of-405-method-not-allowed/183955/5 "2019-06-04T07:41:46Z")

</div>

Hi Nick,  
One more thing,  
I am running elasticsearch and kibana in Kubernetes Cluster and, Kibana is exposed outside using nginx ingress controller.  
So when I remove nginx and try to connect Kibana directly,  
It's successful.  
So is there any specific configuration to be done to run KIbana behind nginx?

Probably my question is similar to this

[https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964)

Only difference is I am using nginx.  
So what should

---

_[View the full topic](https://discuss.elastic.co/t/failed-to-load-resource-the-server-responded-with-a-status-of-405-method-not-allowed/183955)._
