# Failed to load temp

**URL:** <https://discuss.elastic.co/t/failed-to-load-temp/63517>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [October 20, 2016, 2:08pm UTC](https://discuss.elastic.co/t/failed-to-load-temp/63517 "2016-10-20T14:08:23Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Idan](https://avatars.discourse-cdn.com/v4/letter/i/91b2a8/32.png) [@Idan](https://discuss.elastic.co/u/Idan)\
**Post date:** [October 20, 2016, 2:08pm UTC](https://discuss.elastic.co/t/failed-to-load-temp/63517/1 "2016-10-20T14:08:23Z")

</div>

I'm attempting to load the template for the Metricbeat to the kibana  
And I'm getting this error:  
{"error":{"root\_cause":[{"type":"mapper\_parsing\_exception","reason":"No handler for type [keyword] declared on field [hostname]"}],"type":"mapper\_parsing\_exception","reason":"Failed to parse mapping [_default_]: No handler for type [keyword] declared on field [hostname]","caused\_by":{"type":"mapper\_parsing\_exception","reason":"No handler for type [keyword] declared on field [hostname]"}},"status":400}

I have installed the metricbeat on a client, and just want to set up the template on the server to read the packets...  
what I'm doing wrong?

Thanks for the help

---

<div class="post-metadata">

**Author:** ![tudor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tudor/32/3753_2.png) [@tudor](https://discuss.elastic.co/u/tudor)\
**Post date:** [October 21, 2016, 11:08am UTC](https://discuss.elastic.co/t/failed-to-load-temp/63517/2 "2016-10-21T11:08:55Z")

</div>

What elasticsearch version do you have? The errors seems to indicate that you might be trying the 5.x template on a 2.x server?

---

<div class="post-metadata">

**Author:** ![Idan](https://avatars.discourse-cdn.com/v4/letter/i/91b2a8/32.png) [@Idan](https://discuss.elastic.co/u/Idan)\
**Post date:** [October 21, 2016, 2:42pm UTC](https://discuss.elastic.co/t/failed-to-load-temp/63517/3 "2016-10-21T14:42:42Z")

</div>

Yes, I am -  
the packets name are:  
elasticsearch-2.4.1.deb  
metricbeat-5.0.0-rc1-amd64.deb

What I'm doing wrong?  
I download the most up-to-date packets

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 10, 2016, 2:09pm UTC](https://discuss.elastic.co/t/failed-to-load-temp/63517/4 "2016-11-10T14:09:05Z")

</div>

This topic was automatically closed after 21 days. New replies are no longer allowed.
