# Failed to load uid from index in 0.19.6

**URL:** <https://discuss.elastic.co/t/failed-to-load-uid-from-index-in-0-19-6/8220>\
**Category:** Elasticsearch\
**Created:** [June 25, 2012, 9:46pm UTC](https://discuss.elastic.co/t/failed-to-load-uid-from-index-in-0-19-6/8220 "2012-06-25T21:46:34Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Matthew\_A\_Brown](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/matthew_a_brown/32/2699_2.png) [@Matthew\_A\_Brown](https://discuss.elastic.co/u/Matthew_A_Brown)\
**Post date:** [June 25, 2012, 9:46pm UTC](https://discuss.elastic.co/t/failed-to-load-uid-from-index-in-0-19-6/8220/1 "2012-06-25T21:46:34Z")

</div>

Hi all,

Recently updated to 0.19.6 and we saw this error:

FetchPhaseExecutionException  
Error  
[[brew\_staging-0][0]:  
query[filtered(ConstantScore(NotDeleted(+cache(owner\_id:[1 TO 1])  
+cache(friend\_score:[2.0 TO \*])  
+NotFilter(\_uid:contact\_document#1:1))))-\>cache(\_type:contact\_document)],from[0],size[300],sort[\<custom:"score":  
org.elasticsearch.index.field.data.floats.FloatFieldDataType$1@11e3853f\>!,\<custom:"created\_at":  
org.elasticsearch.index.field.data.longs.LongFieldDataType$1@7040f445\>!]:  
Fetch Failed [Failed to load uid from the index, missing internal \_uid  
field, current fields in the doc [[\_source]]]]; }]

Rolled back to 19.4 and ran the same operation with no trouble. We're  
not doing anything fancy here with the mappings. Has anyone else run  
across this in 19.6?

Thanks,  
Mat

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 3:22am UTC](https://discuss.elastic.co/t/failed-to-load-uid-from-index-in-0-19-6/8220/2 "2017-07-06T03:22:34Z")

</div>


