# Failed to load uid from the index in match\_all query

**URL:** <https://discuss.elastic.co/t/failed-to-load-uid-from-the-index-in-match-all-query/4814>\
**Category:** Elasticsearch\
**Created:** [July 7, 2011, 9:10pm UTC](https://discuss.elastic.co/t/failed-to-load-uid-from-the-index-in-match-all-query/4814 "2011-07-07T21:10:43Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Lar\_Mader](https://avatars.discourse-cdn.com/v4/letter/l/a6a055/32.png) [@Lar\_Mader](https://discuss.elastic.co/u/Lar_Mader)\
**Post date:** [July 7, 2011, 9:10pm UTC](https://discuss.elastic.co/t/failed-to-load-uid-from-the-index-in-match-all-query/4814/1 "2011-07-07T21:10:43Z")

</div>

We are getting an error when executing the following query:

{"query":{"match\_all":{}}}

Error in search:[shard [[n0KvEaZoQh2jEaB1xUoHHg][ssga-dev\_ssga-dev]  
[0]], reason [RemoteTransportException[[Cannonball][inet[/  
10.205.24.63:9300]][search/phase/fetch/id]]; nested:  
FetchPhaseExecutionException[[ssga-dev\_ssga-dev][0]:  
query[ConstantScore(_:_)],from[0],size[10]: Fetch Failed [Failed to  
load uid from the index]]; ]]

We are also having trouble with some "ids" queries failing, some  
working.

What could cause this?

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [July 8, 2011, 12:58am UTC](https://discuss.elastic.co/t/failed-to-load-uid-from-the-index-in-match-all-query/4814/2 "2011-07-08T00:58:09Z")

</div>

It seems like its missing the internal \_uid field that is stored in each document from the document fetched. Is it something reproducible? (I improved the failure message to include the loaded fields).

On Friday, July 8, 2011 at 12:10 AM, lmader wrote:

> Failed to  
> load uid from the index

---

<div class="post-metadata">

**Author:** ![Matt\_Smalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/matt_smalley/32/3173_2.png) [@Matt\_Smalley](https://discuss.elastic.co/u/Matt_Smalley)\
**Post date:** [July 13, 2011, 2:10am UTC](https://discuss.elastic.co/t/failed-to-load-uid-from-the-index-in-match-all-query/4814/3 "2011-07-13T02:10:24Z")

</div>

Hi, I work with the OP and have been digging into this. I don't have a  
hard example to send you just yet, but have uncovered some important  
details. We use a parent/child mapping to index attachments separate  
from our metadata and it appears to only occur when doing a  
"match\_all" against both the parent (content) and child type  
(contentFiles), eg:

curl -XGET [http://localhost:9200/temp/\_search](http://localhost:9200/temp/_search) -d '{"query":  
{"match\_all":{}}}'  
curl -XGET [http://localhost:9200/temp/content,contentFiles/\_search](http://localhost:9200/temp/content,contentFiles/_search) -d  
'{"query":{"match\_all":{}}}'

both fail, but:

curl -XGET [http://localhost:9200/temp/content/\_search](http://localhost:9200/temp/content/_search) -d '{"query":  
{"match\_all":{}}}'  
curl -XGET [http://localhost:9200/temp/contentFiles/\_search](http://localhost:9200/temp/contentFiles/_search) -d  
'{"query":{"match\_all":{}}}'

do not. Here is log snippet, showing the index being dropped, created,  
and several mapping updates before the exception trace:

[2011-07-12 18:57:14,692][INFO][cluster.metadata] [Nital,  
Adri] [temp] deleting index  
[2011-07-12 18:57:16,879][INFO][cluster.metadata] [Nital,  
Adri] [temp] creating index, cause [auto(index api)], shards [5]/[1],  
mappings [content, contentFiles]  
[2011-07-12 18:57:16,927][INFO][cluster.metadata] [Nital,  
Adri] [temp] update\_mapping [content] (dynamic)  
[2011-07-12 18:57:17,122][INFO][cluster.metadata] [Nital,  
Adri] [temp] update\_mapping [content] (dynamic)  
[2011-07-12 18:57:17,244][INFO][cluster.metadata] [Nital,  
Adri] [temp] update\_mapping [content] (dynamic)  
[2011-07-12 18:57:17,372][INFO][cluster.metadata] [Nital,  
Adri] [temp] update\_mapping [content] (dynamic)  
[2011-07-12 18:57:17,700][INFO][cluster.metadata] [Nital,  
Adri] [temp] update\_mapping [content] (dynamic)  
[2011-07-12 18:57:18,122][DEBUG][action.search.type] [Nital,  
Adri] [257386] Failed to execute fetch phase  
org.elasticsearch.search.fetch.FetchPhaseExecutionException: [temp]  
[0]: query[ConstantScore(_:_)],from[0],size[10]: Fetch Failed [Failed  
to load uid from the index]  
at  
org.elasticsearch.search.fetch.FetchPhase.extractUid(FetchPhase.java:  
167)  
at org.elasticsearch.search.fetch.FetchPhase.execute(FetchPhase.java:  
80)  
at  
org.elasticsearch.search.SearchService.executeFetchPhase(SearchService.java:  
352)  
at  
org.elasticsearch.search.action.SearchServiceTransportAction.sendExecuteFetch(SearchServiceTransportAction.java:  
314)  
at  
org.elasticsearch.action.search.type.TransportSearchQueryThenFetchAction  
$AsyncAction.executeFetch(TransportSearchQueryThenFetchAction.java:  
140)  
at  
org.elasticsearch.action.search.type.TransportSearchQueryThenFetchAction  
$AsyncAction.access$200(TransportSearchQueryThenFetchAction.java:59)  
at  
org.elasticsearch.action.search.type.TransportSearchQueryThenFetchAction  
$AsyncAction$1.run(TransportSearchQueryThenFetchAction.java:113)  
at java.util.concurrent.ThreadPoolExecutor  
$Worker.runTask(ThreadPoolExecutor.java:886)  
at java.util.concurrent.ThreadPoolExecutor  
$Worker.run(ThreadPoolExecutor.java:908)  
at java.lang.Thread.run(Thread.java:662)

Our documents are rather complex so I'm not exactly sure what about  
that particular document (if anything) triggered the issue. Other  
child documents were inserted by my test script but did not cause any  
shard failures for the match\_all query. Unfortunately I can't post the  
data so I will try to whittle it down to something simple you will be  
able to reproduce on your end.

On Jul 7, 5:58 pm, Shay Banon [shay.ba...@elasticsearch.com](mailto:shay.ba...@elasticsearch.com) wrote:

> It seems like its missing the internal \_uid field that is stored in each document from the document fetched. Is it something reproducible? (I improved the failure message to include the loaded fields).
> 
> On Friday, July 8, 2011 at 12:10 AM, lmader wrote:
> 
> > Failed to  
> > load uid from the index

---

<div class="post-metadata">

**Author:** ![Lar\_Mader](https://avatars.discourse-cdn.com/v4/letter/l/a6a055/32.png) [@Lar\_Mader](https://discuss.elastic.co/u/Lar_Mader)\
**Post date:** [July 20, 2011, 11:14pm UTC](https://discuss.elastic.co/t/failed-to-load-uid-from-the-index-in-match-all-query/4814/4 "2011-07-20T23:14:53Z")

</div>

I've created a program that repros the problem:

> <https://gist.github.com/lmader/1096154>

This is essentially a problem with parent/child documents.

Please note that the \_source for the child document must be disabled  
for this problem to show up. The program puts the mapping and thus  
sets this.

Keep me posted on whether this program works for you to repro the  
problem.

Thanks,  
Lar

On Jul 12, 7:10 pm, Matt Smalley [matt.smal...@gmail.com](mailto:matt.smal...@gmail.com) wrote:

> Hi, I work with the OP and have been digging into this. I don't have a  
> hard example to send you just yet, but have uncovered some important  
> details. We use a parent/child mapping to index attachments separate  
> from our metadata and it appears to only occur when doing a  
> "match\_all" against both the parent (content) and child type  
> (contentFiles), eg:
> 
> curl -XGEThttp://localhost:9200/temp/\_search-d '{"query":  
> {"match\_all":{}}}'  
> curl -XGEThttp://localhost:9200/temp/content,contentFiles/\_search-d  
> '{"query":{"match\_all":{}}}'
> 
> both fail, but:
> 
> curl -XGEThttp://localhost:9200/temp/content/\_search-d '{"query":  
> {"match\_all":{}}}'  
> curl -XGEThttp://localhost:9200/temp/contentFiles/\_search-d  
> '{"query":{"match\_all":{}}}'
> 
> do not. Here is log snippet, showing the index being dropped, created,  
> and several mapping updates before the exception trace:
> 
> [2011-07-12 18:57:14,692][INFO][cluster.metadata] [Nital,  
> Adri] [temp] deleting index  
> [2011-07-12 18:57:16,879][INFO][cluster.metadata] [Nital,  
> Adri] [temp] creating index, cause [auto(index api)], shards [5]/[1],  
> mappings [content, contentFiles]  
> [2011-07-12 18:57:16,927][INFO][cluster.metadata] [Nital,  
> Adri] [temp] update\_mapping [content] (dynamic)  
> [2011-07-12 18:57:17,122][INFO][cluster.metadata] [Nital,  
> Adri] [temp] update\_mapping [content] (dynamic)  
> [2011-07-12 18:57:17,244][INFO][cluster.metadata] [Nital,  
> Adri] [temp] update\_mapping [content] (dynamic)  
> [2011-07-12 18:57:17,372][INFO][cluster.metadata] [Nital,  
> Adri] [temp] update\_mapping [content] (dynamic)  
> [2011-07-12 18:57:17,700][INFO][cluster.metadata] [Nital,  
> Adri] [temp] update\_mapping [content] (dynamic)  
> [2011-07-12 18:57:18,122][DEBUG][action.search.type] [Nital,  
> Adri] [257386] Failed to execute fetch phase  
> org.elasticsearch.search.fetch.FetchPhaseExecutionException: [temp]  
> [0]: query[ConstantScore(_:_)],from[0],size[10]: Fetch Failed [Failed  
> to loaduidfrom the index]  
> at  
> org.elasticsearch.search.fetch.FetchPhase.extractUid(FetchPhase.java:  
> 167)  
> at org.elasticsearch.search.fetch.FetchPhase.execute(FetchPhase.java:  
> 80)  
> at  
> org.elasticsearch.search.SearchService.executeFetchPhase(SearchService.java :  
> 352)  
> at  
> org.elasticsearch.search.action.SearchServiceTransportAction.sendExecuteFet ch(SearchServiceTransportAction.java:  
> 314)  
> at  
> org.elasticsearch.action.search.type.TransportSearchQueryThenFetchAction  
> $AsyncAction.executeFetch(TransportSearchQueryThenFetchAction.java:  
> 140)  
> at  
> org.elasticsearch.action.search.type.TransportSearchQueryThenFetchAction  
> $AsyncAction.access$200(TransportSearchQueryThenFetchAction.java:59)  
> at  
> org.elasticsearch.action.search.type.TransportSearchQueryThenFetchAction  
> $AsyncAction$1.run(TransportSearchQueryThenFetchAction.java:113)  
> at java.util.concurrent.ThreadPoolExecutor  
> $Worker.runTask(ThreadPoolExecutor.java:886)  
> at java.util.concurrent.ThreadPoolExecutor  
> $Worker.run(ThreadPoolExecutor.java:908)  
> at java.lang.Thread.run(Thread.java:662)
> 
> Our documents are rather complex so I'm not exactly sure what about  
> that particular document (if anything) triggered the issue. Other  
> child documents were inserted by my test script but did not cause any  
> shard failures for thematch\_allquery. Unfortunately I can't post the  
> data so I will try to whittle it down to something simple you will be  
> able to reproduce on your end.
> 
> On Jul 7, 5:58 pm, Shay Banon [shay.ba...@elasticsearch.com](mailto:shay.ba...@elasticsearch.com) wrote:
> 
> > It seems like its missing the internal \_uid field that is stored in each document from the document fetched. Is it something reproducible? (I improved the failure message to include the loaded fields).
> 
> > On Friday, July 8, 2011 at 12:10 AM, lmader wrote:
> > 
> > > Failed to  
> > > loaduidfrom the index

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [July 22, 2011, 12:56am UTC](https://discuss.elastic.co/t/failed-to-load-uid-from-the-index-in-match-all-query/4814/5 "2011-07-22T00:56:23Z")

</div>

Heya, thanks for the repro!. Just so we won't forget it, can you open an  
issue for it?

On Thu, Jul 21, 2011 at 2:14 AM, lmader [lmaderintrepid@gmail.com](mailto:lmaderintrepid@gmail.com) wrote:

> I've created a program that repros the problem:
> 
> [Demonstrates a problem with the uid not getting stored in the index. · GitHub](https://gist.github.com/1096154)
> 
> This is essentially a problem with parent/child documents.
> 
> Please note that the \_source for the child document must be disabled  
> for this problem to show up. The program puts the mapping and thus  
> sets this.
> 
> Keep me posted on whether this program works for you to repro the  
> problem.
> 
> Thanks,  
> Lar
> 
> On Jul 12, 7:10 pm, Matt Smalley [matt.smal...@gmail.com](mailto:matt.smal...@gmail.com) wrote:
> 
> > Hi, I work with the OP and have been digging into this. I don't have a  
> > hard example to send you just yet, but have uncovered some important  
> > details. We use a parent/child mapping to index attachments separate  
> > from our metadata and it appears to only occur when doing a  
> > "match\_all" against both the parent (content) and child type  
> > (contentFiles), eg:
> > 
> > curl -XGEThttp://localhost:9200/temp/\_search-d '{"query":  
> > {"match\_all":{}}}'  
> > curl -XGEThttp://localhost:9200/temp/content,contentFiles/\_search-d  
> > '{"query":{"match\_all":{}}}'
> > 
> > both fail, but:
> > 
> > curl -XGEThttp://localhost:9200/temp/content/\_search-d '{"query":  
> > {"match\_all":{}}}'  
> > curl -XGEThttp://localhost:9200/temp/contentFiles/\_search-d  
> > '{"query":{"match\_all":{}}}'
> > 
> > do not. Here is log snippet, showing the index being dropped, created,  
> > and several mapping updates before the exception trace:
> > 
> > [2011-07-12 18:57:14,692][INFO][cluster.metadata] [Nital,  
> > Adri] [temp] deleting index  
> > [2011-07-12 18:57:16,879][INFO][cluster.metadata] [Nital,  
> > Adri] [temp] creating index, cause [auto(index api)], shards [5]/[1],  
> > mappings [content, contentFiles]  
> > [2011-07-12 18:57:16,927][INFO][cluster.metadata] [Nital,  
> > Adri] [temp] update\_mapping [content] (dynamic)  
> > [2011-07-12 18:57:17,122][INFO][cluster.metadata] [Nital,  
> > Adri] [temp] update\_mapping [content] (dynamic)  
> > [2011-07-12 18:57:17,244][INFO][cluster.metadata] [Nital,  
> > Adri] [temp] update\_mapping [content] (dynamic)  
> > [2011-07-12 18:57:17,372][INFO][cluster.metadata] [Nital,  
> > Adri] [temp] update\_mapping [content] (dynamic)  
> > [2011-07-12 18:57:17,700][INFO][cluster.metadata] [Nital,  
> > Adri] [temp] update\_mapping [content] (dynamic)  
> > [2011-07-12 18:57:18,122][DEBUG][action.search.type] [Nital,  
> > Adri] [257386] Failed to execute fetch phase  
> > org.elasticsearch.search.fetch.FetchPhaseExecutionException: [temp]  
> > [0]: query[ConstantScore(_:_)],from[0],size[10]: Fetch Failed [Failed  
> > to loaduidfrom the index]  
> > at  
> > org.elasticsearch.search.fetch.FetchPhase.extractUid(FetchPhase.java:  
> > 167)  
> > at  
> > org.elasticsearch.search.fetch.FetchPhase.execute(FetchPhase.java:  
> > 80)  
> > at
> 
> org.elasticsearch.search.SearchService.executeFetchPhase(SearchService.java  
> :
> 
> > 1. at
> 
> org.elasticsearch.search.action.SearchServiceTransportAction.sendExecuteFet  
> ch(SearchServiceTransportAction.java:
> 
> > 1. at  
> > org.elasticsearch.action.search.type.TransportSearchQueryThenFetchAction  
> > $AsyncAction.executeFetch(TransportSearchQueryThenFetchAction.java:
> > 2. at  
> > org.elasticsearch.action.search.type.TransportSearchQueryThenFetchAction  
> > $AsyncAction.access$200(TransportSearchQueryThenFetchAction.java:59)  
> > at  
> > org.elasticsearch.action.search.type.TransportSearchQueryThenFetchAction  
> > $AsyncAction$1.run(TransportSearchQueryThenFetchAction.java:113)  
> > at java.util.concurrent.ThreadPoolExecutor  
> > $Worker.runTask(ThreadPoolExecutor.java:886)  
> > at java.util.concurrent.ThreadPoolExecutor  
> > $Worker.run(ThreadPoolExecutor.java:908)  
> > at java.lang.Thread.run(Thread.java:662)
> > 
> > Our documents are rather complex so I'm not exactly sure what about  
> > that particular document (if anything) triggered the issue. Other  
> > child documents were inserted by my test script but did not cause any  
> > shard failures for thematch\_allquery. Unfortunately I can't post the  
> > data so I will try to whittle it down to something simple you will be  
> > able to reproduce on your end.
> > 
> > On Jul 7, 5:58 pm, Shay Banon [shay.ba...@elasticsearch.com](mailto:shay.ba...@elasticsearch.com) wrote:
> > 
> > > It seems like its missing the internal \_uid field that is stored in  
> > > each document from the document fetched. Is it something reproducible? (I  
> > > improved the failure message to include the loaded fields).
> > 
> > > On Friday, July 8, 2011 at 12:10 AM, lmader wrote:
> > > 
> > > > Failed to  
> > > > loaduidfrom the index

---

<div class="post-metadata">

**Author:** ![Lar\_Mader](https://avatars.discourse-cdn.com/v4/letter/l/a6a055/32.png) [@Lar\_Mader](https://discuss.elastic.co/u/Lar_Mader)\
**Post date:** [July 22, 2011, 5:09pm UTC](https://discuss.elastic.co/t/failed-to-load-uid-from-the-index-in-match-all-query/4814/6 "2011-07-22T17:09:43Z")

</div>

Issue #1149, Failed to load uid from the index in match\_all query  
with parent/child and \_source disabled

Has been created.

Thanks!  
Lar

On Jul 21, 5:56 pm, Shay Banon [shay.ba...@elasticsearch.com](mailto:shay.ba...@elasticsearch.com) wrote:

> Heya, thanks for the repro!. Just so we won't forget it, can you open an  
> issue for it?
> 
> On Thu, Jul 21, 2011 at 2:14 AM, lmader [lmaderintre...@gmail.com](mailto:lmaderintre...@gmail.com) wrote:
> 
> > I've created a program that repros the problem:
> 
> > [Demonstrates a problem with the uid not getting stored in the index. · GitHub](https://gist.github.com/1096154)
> 
> > This is essentially a problem with parent/child documents.
> 
> > Please note that the \_source for the child document must be disabled  
> > for this problem to show up. The program puts the mapping and thus  
> > sets this.
> 
> > Keep me posted on whether this program works for you to repro the  
> > problem.
> 
> > Thanks,  
> > Lar
> 
> > On Jul 12, 7:10 pm, Matt Smalley [matt.smal...@gmail.com](mailto:matt.smal...@gmail.com) wrote:
> > 
> > > Hi, I work with the OP and have been digging into this. I don't have a  
> > > hard example to send you just yet, but have uncovered some important  
> > > details. We use a parent/child mapping to index attachments separate  
> > > from our metadata and it appears to only occur when doing a  
> > > "match\_all" against both the parent (content) and child type  
> > > (contentFiles), eg:
> 
> > > curl -XGEThttp://localhost:9200/temp/\_search-d'{"query":  
> > > {"match\_all":{}}}'  
> > > curl -XGEThttp://localhost:9200/temp/content,contentFiles/\_search-d  
> > > '{"query":{"match\_all":{}}}'
> 
> > > both fail, but:
> 
> > > curl -XGEThttp://localhost:9200/temp/content/\_search-d'{"query":  
> > > {"match\_all":{}}}'  
> > > curl -XGEThttp://localhost:9200/temp/contentFiles/\_search-d  
> > > '{"query":{"match\_all":{}}}'
> 
> > > do not. Here is log snippet, showing the index being dropped, created,  
> > > and several mapping updates before the exception trace:
> 
> > > [2011-07-12 18:57:14,692][INFO][cluster.metadata] [Nital,  
> > > Adri] [temp] deleting index  
> > > [2011-07-12 18:57:16,879][INFO][cluster.metadata] [Nital,  
> > > Adri] [temp] creating index, cause [auto(index api)], shards [5]/[1],  
> > > mappings [content, contentFiles]  
> > > [2011-07-12 18:57:16,927][INFO][cluster.metadata] [Nital,  
> > > Adri] [temp] update\_mapping [content] (dynamic)  
> > > [2011-07-12 18:57:17,122][INFO][cluster.metadata] [Nital,  
> > > Adri] [temp] update\_mapping [content] (dynamic)  
> > > [2011-07-12 18:57:17,244][INFO][cluster.metadata] [Nital,  
> > > Adri] [temp] update\_mapping [content] (dynamic)  
> > > [2011-07-12 18:57:17,372][INFO][cluster.metadata] [Nital,  
> > > Adri] [temp] update\_mapping [content] (dynamic)  
> > > [2011-07-12 18:57:17,700][INFO][cluster.metadata] [Nital,  
> > > Adri] [temp] update\_mapping [content] (dynamic)  
> > > [2011-07-12 18:57:18,122][DEBUG][action.search.type] [Nital,  
> > > Adri] [257386] Failed to execute fetch phase  
> > > org.elasticsearch.search.fetch.FetchPhaseExecutionException: [temp]  
> > > [0]: query[ConstantScore(_:_)],from[0],size[10]: Fetch Failed [Failed  
> > > to loaduidfrom the index]  
> > > at  
> > > org.elasticsearch.search.fetch.FetchPhase.extractUid(FetchPhase.java:  
> > > 167)  
> > > at  
> > > org.elasticsearch.search.fetch.FetchPhase.execute(FetchPhase.java:  
> > > 80)  
> > > at
> 
> > org.elasticsearch.search.SearchService.executeFetchPhase(SearchService.java  
> > :
> > 
> > > 1. at
> 
> > org.elasticsearch.search.action.SearchServiceTransportAction.sendExecuteFet  
> > ch(SearchServiceTransportAction.java:
> > 
> > > 1. at  
> > > org.elasticsearch.action.search.type.TransportSearchQueryThenFetchAction  
> > > $AsyncAction.executeFetch(TransportSearchQueryThenFetchAction.java:
> > > 2. at  
> > > org.elasticsearch.action.search.type.TransportSearchQueryThenFetchAction  
> > > $AsyncAction.access$200(TransportSearchQueryThenFetchAction.java:59)  
> > > at  
> > > org.elasticsearch.action.search.type.TransportSearchQueryThenFetchAction  
> > > $AsyncAction$1.run(TransportSearchQueryThenFetchAction.java:113)  
> > > at java.util.concurrent.ThreadPoolExecutor  
> > > $Worker.runTask(ThreadPoolExecutor.java:886)  
> > > at java.util.concurrent.ThreadPoolExecutor  
> > > $Worker.run(ThreadPoolExecutor.java:908)  
> > > at java.lang.Thread.run(Thread.java:662)
> 
> > > Our documents are rather complex so I'm not exactly sure what about  
> > > that particular document (if anything) triggered the issue. Other  
> > > child documents were inserted by my test script but did not cause any  
> > > shard failures for thematch\_allquery. Unfortunately I can't post the  
> > > data so I will try to whittle it down to something simple you will be  
> > > able to reproduce on your end.
> 
> > > On Jul 7, 5:58 pm, Shay Banon [shay.ba...@elasticsearch.com](mailto:shay.ba...@elasticsearch.com) wrote:
> 
> > > > It seems like its missing the internal \_uid field that is stored in  
> > > > each document from the document fetched. Is it something reproducible? (I  
> > > > improved the failure message to include the loaded fields).
> 
> > > > On Friday, July 8, 2011 at 12:10 AM, lmader wrote:
> > > > 
> > > > > Failed to  
> > > > > loaduidfrom the index

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 3:59am UTC](https://discuss.elastic.co/t/failed-to-load-uid-from-the-index-in-match-all-query/4814/7 "2017-07-06T03:59:48Z")

</div>


