# Failed to obtain node locks

**URL:** <https://discuss.elastic.co/t/failed-to-obtain-node-locks/229902>\
**Category:** Elasticsearch\
**Created:** [April 27, 2020, 5:53am UTC](https://discuss.elastic.co/t/failed-to-obtain-node-locks/229902 "2020-04-27T05:53:46Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rajeev\_Bhat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rajeev_bhat/32/66529_2.png) [@Rajeev\_Bhat](https://discuss.elastic.co/u/Rajeev_Bhat)\
**Post date:** [April 27, 2020, 5:53am UTC](https://discuss.elastic.co/t/failed-to-obtain-node-locks/229902/1 "2020-04-27T05:53:46Z")

</div>

I have a single node ElasticSearch Cluster in local. I am unable to start elasticsearch service getting this error:

```auto
[bhatr@BLRVCESVM27547]~/elasticsearch-6.8.8/bin% elasticsearch 5:30AM
[2020-04-27T05:30:14,280][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [unknown] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: failed to obtain node locks, tried [[/remote/users/bhatr/elasticsearch-6.8.8/data]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes] (was [1])?
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:163) ~[elasticsearch-6.8.8.jar:6.8.8]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) ~[elasticsearch-6.8.8.jar:6.8.8]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-6.8.8.jar:6.8.8]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-6.8.8.jar:6.8.8]
        at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-6.8.8.jar:6.8.8]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:116) ~[elasticsearch-6.8.8.jar:6.8.8]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93) ~[elasticsearch-6.8.8.jar:6.8.8]
Caused by: java.lang.IllegalStateException: failed to obtain node locks, tried [[/remote/users/bhatr/elasticsearch-6.8.8/data]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes] (was [1])?
        at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:300) ~[elasticsearch-6.8.8.jar:6.8.8]
        at org.elasticsearch.node.Node.<init>(Node.java:296) ~[elasticsearch-6.8.8.jar:6.8.8]
        at org.elasticsearch.node.Node.<init>(Node.java:266) ~[elasticsearch-6.8.8.jar:6.8.8]
        at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:212) ~[elasticsearch-6.8.8.jar:6.8.8]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:212) ~[elasticsearch-6.8.8.jar:6.8.8]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:333) ~[elasticsearch-6.8.8.jar:6.8.8]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-6.8.8.jar:6.8.8]
        ... 6 more

```

All directories in elasticsearch have rwx permission.  
What is the solution for this?  
Unix flavour : Red Hat 4.8.5

**Edit** :  
RedHat Version : 7.5

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [April 27, 2020, 9:30am UTC](https://discuss.elastic.co/t/failed-to-obtain-node-locks/229902/3 "2020-04-27T09:30:15Z")

</div>

I am hoping you got the version of RedHat Linux wrong as that looks very old and [not supported](https://www.elastic.co/support/matrix). What kind of storage are you using? Some kind of networked storage?

---

<div class="post-metadata">

**Author:** ![Rajeev\_Bhat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rajeev_bhat/32/66529_2.png) [@Rajeev\_Bhat](https://discuss.elastic.co/u/Rajeev_Bhat)\
**Post date:** [April 27, 2020, 9:33am UTC](https://discuss.elastic.co/t/failed-to-obtain-node-locks/229902/4 "2020-04-27T09:33:38Z")

</div>

OS: Red Hat 4.8.5-28  
I am using HDD.

---

<div class="post-metadata">

**Author:** ![Rajeev\_Bhat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rajeev_bhat/32/66529_2.png) [@Rajeev\_Bhat](https://discuss.elastic.co/u/Rajeev_Bhat)\
**Post date:** [April 27, 2020, 9:35am UTC](https://discuss.elastic.co/t/failed-to-obtain-node-locks/229902/5 "2020-04-27T09:35:08Z")

</div>

Yes , I am using a remote VM

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [April 27, 2020, 9:35am UTC](https://discuss.elastic.co/t/failed-to-obtain-node-locks/229902/6 "2020-04-27T09:35:46Z")

</div>

That is not a supported OS so I have no idea what effects that could have. I would recommend upgrading to a supported one to eliminate this being the cause.

---

<div class="post-metadata">

**Author:** ![Rajeev\_Bhat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rajeev_bhat/32/66529_2.png) [@Rajeev\_Bhat](https://discuss.elastic.co/u/Rajeev_Bhat)\
**Post date:** [April 27, 2020, 9:36am UTC](https://discuss.elastic.co/t/failed-to-obtain-node-locks/229902/7 "2020-04-27T09:36:06Z")

</div>

Okay. Thank you, I'll do that.

---

<div class="post-metadata">

**Author:** ![Rajeev\_Bhat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rajeev_bhat/32/66529_2.png) [@Rajeev\_Bhat](https://discuss.elastic.co/u/Rajeev_Bhat)\
**Post date:** [April 27, 2020, 9:44am UTC](https://discuss.elastic.co/t/failed-to-obtain-node-locks/229902/8 "2020-04-27T09:44:11Z")

</div>

@Christian_Dahlqvist. Sorry I got it wrong. RedHat Version is :7.5  
All files in elasticsearch folder have rwx permission. And there is no orphan java process. what else could be the issue?

---

<div class="post-metadata">

**Author:** ![Rajeev\_Bhat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rajeev_bhat/32/66529_2.png) [@Rajeev\_Bhat](https://discuss.elastic.co/u/Rajeev_Bhat)\
**Post date:** [April 28, 2020, 5:06am UTC](https://discuss.elastic.co/t/failed-to-obtain-node-locks/229902/9 "2020-04-28T05:06:21Z")

</div>

Deleted data folder and rebooted VM. Now it is working

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 26, 2020, 5:13am UTC](https://discuss.elastic.co/t/failed-to-obtain-node-locks/229902/10 "2020-05-26T05:13:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
