# Failed to publish events caused by: read tcp

**URL:** <https://discuss.elastic.co/t/failed-to-publish-events-caused-by-read-tcp/217410>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [January 31, 2020, 3:13pm UTC](https://discuss.elastic.co/t/failed-to-publish-events-caused-by-read-tcp/217410 "2020-01-31T15:13:08Z")\
**Posts on this page:** 1\
**Showing post:** 12

<div class="post-metadata">

**Author:** ![runtman](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/runtman/32/18136_2.png) [@runtman](https://discuss.elastic.co/u/runtman)\
**Post date:** [February 7, 2020, 2:16pm UTC](https://discuss.elastic.co/t/failed-to-publish-events-caused-by-read-tcp/217410/12 "2020-02-07T14:16:37Z")

</div>

> [@Intermittent timeouts (Doesn't appear to stop service)](https://discuss.elastic.co/t/intermittent-timeouts-doesnt-appear-to-stop-service/218132):
>
> Hello, so we are starting a project where we are moving to ELK 7, with the Elasticsearch and Kibana being offered by [elastic.co](http://elastic.co) rather than self hosted. In our ELK6 install, I had a Nginx loadbalancer balancing our logstash nodes, this time round i've opted to use a AWS Network load balancer. Despite logs reaching Logstash absolutely fine, in the Filebeat logs I do see this, usually every minute. |2020-02-06T09:31:25.235Z|ERROR|logstash/async.go:256|Failed to publish events caused by: read tc…

Here you go, i'll mention this thread now.

---

_[View the full topic](https://discuss.elastic.co/t/failed-to-publish-events-caused-by-read-tcp/217410)._
