# Failed to put mappings on indices \[\[\[account\_address\_01112020/M\_Yx-7TTTOeBgtJ-ckrHbw\]\]\], type \[\_doc\] java.lang.IllegalArgumentException: mapper \[quater\] of different type, current\_type \[keyword\], merged\_type \[text\]

**URL:** <https://discuss.elastic.co/t/failed-to-put-mappings-on-indices-account-address-01112020-m-yx-7tttoebgtj-ckrhbw-type-doc-java-lang-illegalargumentexception-mapper-quater-of-different-type-current-type-keyword-merged-type-text/284116>\
**Category:** Elasticsearch\
**Created:** [September 13, 2021, 7:04pm UTC](https://discuss.elastic.co/t/failed-to-put-mappings-on-indices-account-address-01112020-m-yx-7tttoebgtj-ckrhbw-type-doc-java-lang-illegalargumentexception-mapper-quater-of-different-type-current-type-keyword-merged-type-text/284116 "2021-09-13T19:04:49Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mesut\_Yilmaz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mesut_yilmaz/32/87598_2.png) [@Mesut\_Yilmaz](https://discuss.elastic.co/u/Mesut_Yilmaz)\
**Post date:** [September 13, 2021, 7:04pm UTC](https://discuss.elastic.co/t/failed-to-put-mappings-on-indices-account-address-01112020-m-yx-7tttoebgtj-ckrhbw-type-doc-java-lang-illegalargumentexception-mapper-quater-of-different-type-current-type-keyword-merged-type-text/284116/1 "2021-09-13T19:04:49Z")

</div>

Hi,

I am having a problem as below. What could be the reason of this specific problem which was occured only two hours during the day first time and do not know how to repeat the same problem. It occured and does not repeat currectly.

```auto
[2021-09-13T20:05:50,711][DEBUG][o.e.a.a.i.m.p.TransportPutMappingAction] [172.31.211.142] failed to put mappings on indices [[[account_address_01112020/M_Yx-7TTTOeBgtJ-ckrHbw]]], type [_doc]
java.lang.IllegalArgumentException: mapper [quater] of different type, current_type [keyword], merged_type [text]
        at org.elasticsearch.index.mapper.FieldMapper.doMerge(FieldMapper.java:352) ~[elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.index.mapper.KeywordFieldMapper.doMerge(KeywordFieldMapper.java:393) ~[elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.index.mapper.FieldMapper.merge(FieldMapper.java:339) ~[elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.index.mapper.FieldMapper.merge(FieldMapper.java:55) ~[elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.index.mapper.ObjectMapper.doMerge(ObjectMapper.java:472) ~[elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.index.mapper.RootObjectMapper.doMerge(RootObjectMapper.java:276) ~[elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.index.mapper.ObjectMapper.merge(ObjectMapper.java:443) ~[elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.index.mapper.RootObjectMapper.merge(RootObjectMapper.java:271) ~[elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.index.mapper.Mapping.merge(Mapping.java:91) ~[elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.index.mapper.DocumentMapper.merge(DocumentMapper.java:321) ~[elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.cluster.metadata.MetaDataMappingService$PutMappingExecutor.applyRequest(MetaDataMappingService.java:282) ~[elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.cluster.metadata.MetaDataMappingService$PutMappingExecutor.execute(MetaDataMappingService.java:238) ~[elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.cluster.service.MasterService.executeTasks(MasterService.java:702) ~[elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.cluster.service.MasterService.calculateTaskOutputs(MasterService.java:324) ~[elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.cluster.service.MasterService.runTasks(MasterService.java:219) [elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.cluster.service.MasterService.access$000(MasterService.java:73) [elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.cluster.service.MasterService$Batcher.run(MasterService.java:151) [elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.cluster.service.TaskBatcher.runIfNotProcessed(TaskBatcher.java:150) [elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.cluster.service.TaskBatcher$BatchedTask.run(TaskBatcher.java:188) [elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:703) [elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.runAndClean(PrioritizedEsThreadPoolExecutor.java:252) [elasticsearch-7.5.2.jar:7.5.2]
        at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:215) [elasticsearch-7.5.2.jar:7.5.2]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]
        at java.lang.Thread.run(Thread.java:830) [?:?]

```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 13, 2021, 11:45pm UTC](https://discuss.elastic.co/t/failed-to-put-mappings-on-indices-account-address-01112020-m-yx-7tttoebgtj-ckrhbw-type-doc-java-lang-illegalargumentexception-mapper-quater-of-different-type-current-type-keyword-merged-type-text/284116/2 "2021-09-13T23:45:30Z")

</div>

Where do you see this error?

---

<div class="post-metadata">

**Author:** ![Mesut\_Yilmaz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mesut_yilmaz/32/87598_2.png) [@Mesut\_Yilmaz](https://discuss.elastic.co/u/Mesut_Yilmaz)\
**Post date:** [September 14, 2021, 7:48am UTC](https://discuss.elastic.co/t/failed-to-put-mappings-on-indices-account-address-01112020-m-yx-7tttoebgtj-ckrhbw-type-doc-java-lang-illegalargumentexception-mapper-quater-of-different-type-current-type-keyword-merged-type-text/284116/3 "2021-09-14T07:48:26Z")

</div>

3 nodes ELK cluster, logs are in the first node of cluster under /var/log/elasticsearch/\*.log file.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 14, 2021, 7:49am UTC](https://discuss.elastic.co/t/failed-to-put-mappings-on-indices-account-address-01112020-m-yx-7tttoebgtj-ckrhbw-type-doc-java-lang-illegalargumentexception-mapper-quater-of-different-type-current-type-keyword-merged-type-text/284116/4 "2021-09-14T07:49:33Z")

</div>

Ok, you just posted this in the Kibana category is all.

That means that you have something that is wanting to put a mapping that clashes with the existing one for the index.

---

<div class="post-metadata">

**Author:** ![Mesut\_Yilmaz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mesut_yilmaz/32/87598_2.png) [@Mesut\_Yilmaz](https://discuss.elastic.co/u/Mesut_Yilmaz)\
**Post date:** [September 14, 2021, 8:37am UTC](https://discuss.elastic.co/t/failed-to-put-mappings-on-indices-account-address-01112020-m-yx-7tttoebgtj-ckrhbw-type-doc-java-lang-illegalargumentexception-mapper-quater-of-different-type-current-type-keyword-merged-type-text/284116/5 "2021-09-14T08:37:54Z")

</div>

application is running on kubernetes, the issue is gone after kubernetes starting a new elasticsearch API pod itself automatically. What could be the root cause for the clashing if any insights?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 12, 2021, 8:38am UTC](https://discuss.elastic.co/t/failed-to-put-mappings-on-indices-account-address-01112020-m-yx-7tttoebgtj-ckrhbw-type-doc-java-lang-illegalargumentexception-mapper-quater-of-different-type-current-type-keyword-merged-type-text/284116/6 "2021-10-12T08:38:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
