# Failed to recover from translog

**URL:** https://discuss.elastic.co/t/failed-to-recover-from-translog/57484
**Category:** Elasticsearch
**Created:** [August 8, 2016, 2:10pm UTC](https://discuss.elastic.co/t/failed-to-recover-from-translog/57484 "2016-08-08T14:10:29Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![dmugyr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dmugyr/32/6267_2.png) [@dmugyr](https://discuss.elastic.co/u/dmugyr)
#### Post date: [August 8, 2016, 2:10pm UTC](https://discuss.elastic.co/t/failed-to-recover-from-translog/57484/1 "2016-08-08T14:10:29Z")

</div>

many shards stuck in initializing after power failure  
Here is my log:

`[gather.log][[gather.log][0]] IndexShardRecoveryException[failed to recovery from gateway]; nested: EngineCreationFailureException[failed to recover from translog]; nested: EngineException[failed to recover from translog]; nested: ElasticsearchException[unexpected exception reading from translog snapshot of /usr/local/elasticsearch/data/elasticsearch/nodes/0/indices/gather.log/0/translog/translog-382.tlog]; nested: EOFException[read past EOF. pos [3932480] length: [4] end: [3932480]]; at org.elasticsearch.index.shard.StoreRecoveryService.recoverFromStore(StoreRecoveryService.java:254) at org.elasticsearch.index.shard.StoreRecoveryService.access$100(StoreRecoveryService.java:56) at org.elasticsearch.index.shard.StoreRecoveryService$1.run(StoreRecoveryService.java:129) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) at java.lang.Thread.run(Thread.java:745) Caused by: [gather.log][[gather.log][0]] EngineCreationFailureException[failed to recover from translog]; nested: EngineException[failed to recover from translog]; nested: ElasticsearchException[unexpected exception reading from translog snapshot of /usr/local/elasticsearch/data/elasticsearch/nodes/0/indices/gather.log/0/translog/translog-382.tlog]; nested: EOFException[read past EOF. pos [3932480] length: [4] end: [3932480]]; at org.elasticsearch.index.engine.InternalEngine.<init>(InternalEngine.java:178) at org.elasticsearch.index.engine.InternalEngineFactory.newReadWriteEngine(InternalEngineFactory.java:25) at org.elasticsearch.index.shard.IndexShard.newEngine(IndexShard.java:1450) at org.elasticsearch.index.shard.IndexShard.createNewEngine(IndexShard.java:1434) at org.elasticsearch.index.shard.IndexShard.internalPerformTranslogRecovery(IndexShard.java:925) at org.elasticsearch.index.shard.IndexShard.performTranslogRecovery(IndexShard.java:897) at org.elasticsearch.index.shard.StoreRecoveryService.recoverFromStore(StoreRecoveryService.java:245) ... 5 more`

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [August 9, 2016, 3:00am UTC](https://discuss.elastic.co/t/failed-to-recover-from-translog/57484/2 "2016-08-09T03:00:30Z")

</div>

Did your disk fill up, or something else catastrophic happen?

---

<div class="post-metadata">

### Author: ![dmugyr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dmugyr/32/6267_2.png) [@dmugyr](https://discuss.elastic.co/u/dmugyr)
#### Post date: [August 9, 2016, 5:49am UTC](https://discuss.elastic.co/t/failed-to-recover-from-translog/57484/3 "2016-08-09T05:49:38Z")

</div>

No, everything was good before power cut. There was no translog-recovering files

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 10:29pm UTC](https://discuss.elastic.co/t/failed-to-recover-from-translog/57484/4 "2017-07-05T22:29:10Z")

</div>


