# failed to restore snapshot - IndexShardRestoreFailedException file not found

**URL:** https://discuss.elastic.co/t/failed-to-restore-snapshot-indexshardrestorefailedexception-file-not-found/19490
**Category:** Elasticsearch
**Created:** [August 27, 2014, 11:34am UTC](https://discuss.elastic.co/t/failed-to-restore-snapshot-indexshardrestorefailedexception-file-not-found/19490 "2014-08-27T11:34:14Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![sarohan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sarohan/32/4575_2.png) [@sarohan](https://discuss.elastic.co/u/sarohan)
#### Post date: [August 27, 2014, 11:34am UTC](https://discuss.elastic.co/t/failed-to-restore-snapshot-indexshardrestorefailedexception-file-not-found/19490/1 "2014-08-27T11:34:14Z")

</div>

Hi,  
I am using 3 node cluster setup with the elasticsearch 1.3.1, i have 17 indices each one is having min 2L documents and 14L max. now i would like to try the snapshot and restore process in my cluster. i used the following REST calls to do the same...

To create a repository:  
curl -XPUT '[http://host.name:9200/\_snapshot/es\_snapshot\_repo](http://host.name:9200/_snapshot/es_snapshot_repo)' -d '{  
"type": "fs",  
"settings": {  
"location": "/data/es\_snapshot\_bkup\_repo/es\_snapshot\_repo"  
}  
}'

Verified the repository:  
curl -XGET '[http://host.name:9200/\_snapshot/es\_snapshot\_repo?pretty](http://host.name:9200/_snapshot/es_snapshot_repo?pretty)' the response is  
{  
"es\_snapshot\_repo" : {  
"type" : "fs",  
"settings" : {  
"location" : "/data/es\_snapshot\_bkup\_repo/es\_snapshot\_repo"  
}  
}  
}

done the SNAPSHOT using  
curl -XPUT "[http://host.name:9200/\_snapshot/es\_snapshot\_repo/snap\_001](http://host.name:9200/_snapshot/es_snapshot_repo/snap_001)" -d '{"indices": "index\_01","ignore\_unavailable": "true","include\_global\_state": false,"wait\_for\_completion": true}'

the response is {"accepted":true}

then i am trying to restore the snapshot by the request  
curl -XPOST "[http://host.name:9200/\_snapshot/es\_snapshot\_repo/snap\_001/\_restore](http://host.name:9200/_snapshot/es_snapshot_repo/snap_001/_restore)" -d '{  
"indices": "index\_01",  
"ignore\_unavailable": "true",  
"include\_global\_state": false,  
"rename\_pattern": "index\_01",  
"rename\_replacement": "index\_01\_bk","include\_aliases": false}'

ISSUE:  
As i informed i have 3 nodes. the index which i am trying to take snapshot & restore is has 6 shards and 2 replicas.

Most of the shards restored properly, but 1 or 2 nodes are not restoring those are in the INITIALIZING state and i left it for more than an hour but those shards are not relocating to the exact correct node... i got the following exception in my node.

[2014-08-27 07:10:35,492][DEBUG][cluster.service] [node\_01] processing [shard-failed ([snap\_001][4], node[r4UoA7vJREmQfh6lz634NA], [P], restoring[es\_snapshot\_repo:snap\_001], s[INITIALIZING]), reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[snap\_001][4] failed recovery]; nested: IndexShardRestoreFailedException[[snap\_001][4] restore failed]; nested: IndexShardRestoreFailedException[[snap\_001][4] failed to restore snapshot [snap\_001]]; nested: IndexShardRestoreFailedException[[snap\_001][4] failed to read shard snapshot file]; nested: FileNotFoundException[/data/es\_snapshot\_bkup\_repo/es\_snapshot\_repo/indices/index\_01/4/snapshot-snap\_001 (No such file or directory)]; ]]]: done applying updated cluster\_state (version: 56391)

Could any one help me to overcome this issue.. and please correct me if i done any mistake in thease process.. .

FYI i am using master node to pass the curl request

Thanks in advance

---

<div class="post-metadata">

### Author: ![sarohan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sarohan/32/4575_2.png) [@sarohan](https://discuss.elastic.co/u/sarohan)
#### Post date: [August 28, 2014, 11:33am UTC](https://discuss.elastic.co/t/failed-to-restore-snapshot-indexshardrestorefailedexception-file-not-found/19490/2 "2014-08-28T11:33:26Z")

</div>

Issue is fixed

i made a mistake in the fileSystem location. actually we need to point a shared file system. i gave a local location of each node. Now i changed the location to an shared mount folder [which is accessible by all nodes] and this issue is fixed

Thanks

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:05am UTC](https://discuss.elastic.co/t/failed-to-restore-snapshot-indexshardrestorefailedexception-file-not-found/19490/3 "2017-07-06T01:05:49Z")

</div>


