# Failed to retrieve password hash for reserved user \[elastic\]

**URL:** https://discuss.elastic.co/t/failed-to-retrieve-password-hash-for-reserved-user-elastic/286255
**Category:** Elastic Security
**Tags:** elastic-stack-security
**Created:** [October 8, 2021, 2:45pm UTC](https://discuss.elastic.co/t/failed-to-retrieve-password-hash-for-reserved-user-elastic/286255 "2021-10-08T14:45:09Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![rachelyang](https://avatars.discourse-cdn.com/v4/letter/r/51bf81/32.png) [@rachelyang](https://discuss.elastic.co/u/rachelyang)
#### Post date: [October 8, 2021, 2:45pm UTC](https://discuss.elastic.co/t/failed-to-retrieve-password-hash-for-reserved-user-elastic/286255/1 "2021-10-08T14:45:09Z")

</div>

I have verified the password of user elastic.

```auto
 curl -k -u elastic 'https://localhost:9200/_xpack/security/_authenticate?pretty'
Enter host password for user 'elastic':
{
  "username" : "elastic",
  "roles" : [
    "superuser"
  ],
  "full_name" : null,
  "email" : null,
  "metadata" : {
    "_reserved" : true
  },
  "enabled" : true,
  "authentication_realm" : {
    "name" : "reserved",
    "type" : "reserved"
  },
  "lookup_realm" : {
    "name" : "reserved",
    "type" : "reserved"
  },
  "authentication_type" : "realm"
}

```

But after I restart Elasticsearch service, the log file has error:

```auto
failed to retrieve password hash for reserved user [elastic]
org.elasticsearch.action.UnavailableShardsException: at least one primary shard for the index [.security-7] is unavailable
Authentication of [elastic] was terminated by realm [reserved] - failed to authenticate user [elastic]

```

How do I need to check the configuration? Thanks

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [October 10, 2021, 10:43pm UTC](https://discuss.elastic.co/t/failed-to-retrieve-password-hash-for-reserved-user-elastic/286255/2 "2021-10-10T22:43:06Z")

</div>

Please don't post questions about the Security functionality of Elasticsearch in this category. There's a pretty clear set of directions that mention this when you go to post in this category;

> _Please delete this message before posting your topic 🙂_
> 
> For questions on securing the Elastic Stack via TLS/SSL or access control, please use the relevant product category - #Elasticsearch, #Kibana, #Beats and #Logstash.
> 
> This category is for questions related to the Elastic Stack Security functionality - [Security solution unifying SIEM, endpoint & cloud | Elastic](https://www.elastic.co/security) - encompassing our free and open SIEM, and Endpoint Security.
> 
> _Please delete this message before posting your topic 🙂_

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [October 10, 2021, 10:43pm UTC](https://discuss.elastic.co/t/failed-to-retrieve-password-hash-for-reserved-user-elastic/286255/3 "2021-10-10T22:43:10Z")

</div>


