# Failed to retrieve password hash for reserved user \[elastic\]

**URL:** https://discuss.elastic.co/t/failed-to-retrieve-password-hash-for-reserved-user-elastic/303475
**Category:** Elasticsearch
**Tags:** elastic-stack-security
**Created:** [April 28, 2022, 7:42am UTC](https://discuss.elastic.co/t/failed-to-retrieve-password-hash-for-reserved-user-elastic/303475 "2022-04-28T07:42:06Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Balaji\_Arumugam](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/balaji_arumugam/32/92969_2.png) [@Balaji\_Arumugam](https://discuss.elastic.co/u/Balaji_Arumugam)
#### Post date: [April 28, 2022, 7:42am UTC](https://discuss.elastic.co/t/failed-to-retrieve-password-hash-for-reserved-user-elastic/303475/1 "2022-04-28T07:42:06Z")

</div>

Hi Team,

We have facing an issue while we start the Elasticsearch master node with the following errors

[2022-04-28T07:40:11,318][INFO][o.e.x.s.a.AuthenticationService] [master] Authentication of [elastic] was terminated by realm [reserved] - failed to authenticate user [elastic]  
[2022-04-28T07:40:12,879][ERROR][o.e.x.s.a.e.ReservedRealm] [master] failed to retrieve password hash for reserved user [elastic]  
org.Elasticsearch.action.UnavailableShardsException: at least one primary shard for the index [.security-7] is unavailable  
at org.Elasticsearch.xpack.security.support.SecurityIndexManager.getUnavailableReason(SecurityIndexManager.java:148) ~[x-pack-security-7.15.0.jar:7.15.0]  
at org.Elasticsearch.xpack.security.authc.esnative.NativeUsersStore.getReservedUserInfo(NativeUsersStore.java:493) [x-pack-security-7.15.0.jar:7.15.0]  
at org.Elasticsearch.xpack.security.authc.esnative.ReservedRealm.getUserInfo(ReservedRealm.java:220) [x-pack-security-7.15.0.jar:7.15.0]  
at org.Elasticsearch.xpack.security.authc.esnative.ReservedRealm.doAuthenticate(ReservedRealm.java:96) [x-pack-security-7.15.0.jar:7.15.0]  
at org.Elasticsearch.xpack.security.authc.support.CachingUsernamePasswordRealm.authenticateWithCache(CachingUsernamePasswordRealm.java:188) [x-pack-security-7.15.0.jar:7.15.0]  
at org.Elasticsearch.xpack.security.authc.support.CachingUsernamePasswordRealm.authenticate(CachingUsernamePasswordRealm.java:105) [x-pack-security-7.15.0.jar:7.15.0]

Kindly help me to resolve the issue

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [April 28, 2022, 7:49am UTC](https://discuss.elastic.co/t/failed-to-retrieve-password-hash-for-reserved-user-elastic/303475/2 "2022-04-28T07:49:22Z")

</div>

> [@Balaji\_Arumugam](#):
>
> at least one primary shard for the index [.security-7] is unavailable

Did you have a replica for this index?

---

<div class="post-metadata">

### Author: ![Balaji\_Arumugam](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/balaji_arumugam/32/92969_2.png) [@Balaji\_Arumugam](https://discuss.elastic.co/u/Balaji_Arumugam)
#### Post date: [April 28, 2022, 7:57am UTC](https://discuss.elastic.co/t/failed-to-retrieve-password-hash-for-reserved-user-elastic/303475/3 "2022-04-28T07:57:41Z")

</div>

No, we don't have a replica. This is master node and we have 2 data nodes to sync with master node

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 26, 2022, 7:58am UTC](https://discuss.elastic.co/t/failed-to-retrieve-password-hash-for-reserved-user-elastic/303475/4 "2022-05-26T07:58:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
