# Failed to send event to Redis. IOError

**URL:** <https://discuss.elastic.co/t/failed-to-send-event-to-redis-ioerror/46349>\
**Category:** Logstash\
**Created:** [April 5, 2016, 8:28am UTC](https://discuss.elastic.co/t/failed-to-send-event-to-redis-ioerror/46349 "2016-04-05T08:28:35Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![diwertowski](https://avatars.discourse-cdn.com/v4/letter/d/ac91a4/32.png) [@diwertowski](https://discuss.elastic.co/u/diwertowski)\
**Post date:** [April 5, 2016, 8:28am UTC](https://discuss.elastic.co/t/failed-to-send-event-to-redis-ioerror/46349/1 "2016-04-05T08:28:35Z")

</div>

Hi,  
today I got an Error, that I can not fix. My Setup (everything is on one local machine, so I can easily test it):  
Its a windows server with 16GB, 64-Bit  
Logstash Version 2.2.0  
Kibana Version 4.4.1  
Elasticsearch Version 2.3.0  
Redis Version 3.0.501

3 Shipper =\> Redis =\> Logstash Indexer =\> Elasticsearch =\> Kibana

I'll get this error even if my Setup is only (without Indexer,ES,Ki):

3 Shipper =\> Redis

So it's a problem from Logstash or Redis. I start the shipper with -b 2000 -w 8.

←[33mFailed to send event to Redis {:event=\>#\<LogStash::Event:0x3e031e0d  
@accessors=#\<LogStash::Util::Accessors:0xcc469c3  
...  
:exception=\>#\<IOError: Unable to establish loopback connection\>,  
:backtrace=\>["org/jruby/RubyIO.java:3682:in `select'", "C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis/connection/ruby.rb:52:in`\_read\_from\_socket'",  
"C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis/connection/ruby.rb:49:in `_read_from_socket'", "C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis/connection/ruby.rb:41:in`gets'",  
"C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis/connection/ruby.rb:273:in `read'", "C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis/client.rb:249:in`read'",  
"C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis/client.rb:237:in `io'", "C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis/client.rb:248:in`read'",  
"C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis/client.rb:113:in `call'", "C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis/client.rb:218:in`process'",  
"C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis/client.rb:354:in `ensure_connected'", "C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis/client.rb:208:in`process'",  
"C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis/client.rb:293:in `logging'", "C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis/client.rb:207:in`process'",  
"C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis/client.rb:113:in `call'", "C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis.rb:1030:in`rpush'",  
"C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis.rb:57:in `synchronize'", "C:/Program Files/ELK/logstash-2.2.0/vendor/jruby/lib/ruby/1.9/monitor.rb:211:in`mon\_synchronize'",  
"C:/Program Files/ELK/logstash-2.2.0/vendor/jruby/lib/ruby/1.9/monitor.rb:210:in `mon_synchronize'", "C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis.rb:57:in`synchronize'",  
"C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/redis-3.2.2/lib/redis.rb:1029:in `rpush'", "C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/logstash-output-redis-2.0.2/lib/logstash/outputs/redis.rb:169:in`receive'",  
"C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.0-java/lib/logstash/outputs/base.rb:83:in `multi_receive'", "org/jruby/RubyArray.java:1613:in`each'",  
"C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.0-java/lib/logstash/outputs/base.rb:83:in `multi_receive'", "C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.0-java/lib/logstash/output_delegator.rb:119:in`worker\_multi\_receive'",  
"C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.0-java/lib/logstash/output\_delegator.rb:118:in `worker_multi_receive'", "C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.0-java/lib/logstash/output_delegator.rb:65:in`multi\_receive'",  
"C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.0-java/lib/logstash/pipeline.rb:275:in `output_batch'", "org/jruby/RubyHash.java:1342:in`each'",  
"C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.0-java/lib/logstash/pipeline.rb:275:in `output_batch'", "C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.0-java/lib/logstash/pipeline.rb:206:in`worker\_loop'",  
"C:/Program Files/ELK/logstash-2.2.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.0-java/lib/logstash/pipeline.rb:175:in `start\_workers'"]

input {  
file {  
type =\> "log4j"  
path =\> "//_/logs/_/_/_/_.log"  
start\_position =\> beginning  
sincedb\_path =\> null  
codec =\> plain { charset =\> "ISO-8859-1" }  
}  
}  
output {  
redis {  
host =\> ["_\*\*.\*\*\*.\*\*\*.\*\*\*:6379"]  
data\_type =\> "list"  
key =\> "logstash"  
codec =\> plain { charset =\> "ISO-8859-1" }  
}  
}

---

<div class="post-metadata">

**Author:** ![diwertowski](https://avatars.discourse-cdn.com/v4/letter/d/ac91a4/32.png) [@diwertowski](https://discuss.elastic.co/u/diwertowski)\
**Post date:** [April 5, 2016, 8:33am UTC](https://discuss.elastic.co/t/failed-to-send-event-to-redis-ioerror/46349/4 "2016-04-05T08:33:27Z")

</div>

IOError: Unable to establish loopback connection

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 5, 2016, 8:51am UTC](https://discuss.elastic.co/t/failed-to-send-event-to-redis-ioerror/46349/5 "2016-04-05T08:51:30Z")

</div>

Did you check redis?

---

<div class="post-metadata">

**Author:** ![diwertowski](https://avatars.discourse-cdn.com/v4/letter/d/ac91a4/32.png) [@diwertowski](https://discuss.elastic.co/u/diwertowski)\
**Post date:** [April 5, 2016, 8:53am UTC](https://discuss.elastic.co/t/failed-to-send-event-to-redis-ioerror/46349/6 "2016-04-05T08:53:36Z")

</div>

Redis works, i tried it with different Versions

---

<div class="post-metadata">

**Author:** ![diwertowski](https://avatars.discourse-cdn.com/v4/letter/d/ac91a4/32.png) [@diwertowski](https://discuss.elastic.co/u/diwertowski)\
**Post date:** [April 5, 2016, 9:28am UTC](https://discuss.elastic.co/t/failed-to-send-event-to-redis-ioerror/46349/7 "2016-04-05T09:28:51Z")

</div>

I tried it with -w 2 to start my shipper. Everythings fine. Why I can't start the shipper with -w 8 or more?!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 5:03am UTC](https://discuss.elastic.co/t/failed-to-send-event-to-redis-ioerror/46349/8 "2017-07-06T05:03:52Z")

</div>


