# Failed to send ping to \[{#zen\_unicast}\] RemoteTransportException in Tribe node setup

**URL:** <https://discuss.elastic.co/t/failed-to-send-ping-to-zen-unicast-remotetransportexception-in-tribe-node-setup/40827>\
**Category:** Elasticsearch\
**Created:** [February 3, 2016, 6:54am UTC](https://discuss.elastic.co/t/failed-to-send-ping-to-zen-unicast-remotetransportexception-in-tribe-node-setup/40827 "2016-02-03T06:54:07Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![rajkamalkool6](https://avatars.discourse-cdn.com/v4/letter/r/e9c0ed/32.png) [@rajkamalkool6](https://discuss.elastic.co/u/rajkamalkool6)\
**Post date:** [February 3, 2016, 6:54am UTC](https://discuss.elastic.co/t/failed-to-send-ping-to-zen-unicast-remotetransportexception-in-tribe-node-setup/40827/1 "2016-02-03T06:54:07Z")

</div>

Hi,

I am trying to create a tribe node setup. I am having two servers , I am trying to setup one server as tribe and another as normal data node. I am using Elasticsearch version 2.1.1

Please find my config below,

> **#Data Node Config**  
> cluster.name: my\_net\_ctx  
> path.data: /ctx/dataindex  
> path.logs: /ctx/datalogs  
> network.bind\_host:   
> transport.tcp.port: 9300  
> network.publish\_host:   
> http.port: 9200  
> http.enabled: true  
> discovery.zen.ping.unicast.hosts: [":9300"]  
> discovery.zen.ping.multicast.enabled: false

> \*\* #Tribe Node Config\*\*  
> node.data: false  
> node.master: false  
> network.bind\_host:   
> transport.tcp.port: 9200  
> network.publish\_host:   
> http.port: 9300  
> http.enabled: true  
> tribe.t1.cluster.name: my\_net\_ctx

When I tried to start my elasticsearch after including the above configuration in elasticsearch.yml on both the servers. I am facing the below error.

> java.lang.IllegalStateException: Message not fully read (request) for requestId [3], action [internal:discovery/zen/unicast], readerIndex [51] vs expected [187]; resetting  
> at org.elasticsearch.transport.netty.MessageChannelHandler.messageReceived(MessageChannelHandler.java:120)  
> at org.jboss.netty.channel.SimpleChannelUpstreamHandler.handleUpstream(SimpleChannelUpstreamHandler.java:70)  
> at org.jboss.netty.channel.DefaultChannelPipeline.sendUpstream(DefaultChannelPipeline.java:564)  
> at org.jboss.netty.channel.DefaultChannelPipeline$DefaultChannelHandlerContext.sendUpstream(DefaultChannelPipeline.java:791).....

> [WARN][discovery.zen.ping.unicast] [May Parker/t1] failed to send ping to [{#zen\_unicast\_1#}{127.0.0.1}{127.0.0.1:9300}]  
> RemoteTransportException[[May Parker][127.0.0.1:9300][internal:discovery/zen/unicast]]; nested: ActionNotFoundTransportException[No handler for action [internal:discovery/zen/unicast]];  
> Caused by: ActionNotFoundTransportException[No handler for action [internal:discovery/zen/unicast]]  
> at org.elasticsearch.transport.netty.MessageChannelHandler.handleRequest(MessageChannelHandler.java:237)  
> at org.elasticsearch.transport.netty.MessageChannelHandler.messageReceived(MessageChannelHandler.java:114)  
> at org.jboss.netty.channel.SimpleChannelUpstreamHandler.handleUpstream(SimpleChannelUpstreamHandler.java:70)  
> at org.jboss.netty.channel.DefaultChannelPipeline.sendUpstream(DefaultChannelPipeline.java:564)  
> at org.jboss.netty.channel.DefaultChannelPipeline$DefaultChannelHandlerContext.sendUpstream(DefaultChannelPipeline.java:791)  
> at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:296)  
> at org.jboss.netty.handler.codec.frame.FrameDecoder.unfoldAndFireMessageReceived(FrameDecoder.java:462)  
> at org.jboss.netty.handler.codec.frame.FrameDecoder.callDecode(FrameDecoder.java:443)  
> at org.jboss.netty.handler.codec.frame.FrameDecoder.messageReceived(FrameDecoder.java:303)  
> at org.jboss.netty.channel.SimpleChannelUpstreamHandler.handleUpstream(SimpleChannelUpstreamHandler.java:70)  
> at org.jboss.netty.channel.DefaultChannelPipeline.sendUpstream(DefaultChannelPipeline.java:564)  
> at...

I have noticed one thing in the log file, even though I have changed the IP address but still it showing 127.0.0.1 in the exception.

I don't know where I am going wrong.

Thanks in advance!!!!!

---

<div class="post-metadata">

**Author:** ![Ganesh2303](https://avatars.discourse-cdn.com/v4/letter/g/57b2e6/32.png) [@Ganesh2303](https://discuss.elastic.co/u/Ganesh2303)\
**Post date:** [February 3, 2016, 7:01am UTC](https://discuss.elastic.co/t/failed-to-send-ping-to-zen-unicast-remotetransportexception-in-tribe-node-setup/40827/2 "2016-02-03T07:01:37Z")

</div>

HI,  
i'm also facing same kind of issue while setting tribe node. Kindly help me to sort our of it.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:19pm UTC](https://discuss.elastic.co/t/failed-to-send-ping-to-zen-unicast-remotetransportexception-in-tribe-node-setup/40827/3 "2017-07-05T23:19:21Z")

</div>


