# Failed to setup multicast discovery on port \[54328\] ES can't connect to cluster

**URL:** https://discuss.elastic.co/t/failed-to-setup-multicast-discovery-on-port-54328-es-cant-connect-to-cluster/15907
**Category:** Elasticsearch
**Created:** [February 19, 2014, 6:56pm UTC](https://discuss.elastic.co/t/failed-to-setup-multicast-discovery-on-port-54328-es-cant-connect-to-cluster/15907 "2014-02-19T18:56:12Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Ogulcan\_Selcuk\_Akbul](https://avatars.discourse-cdn.com/v4/letter/o/a6a055/32.png) [@Ogulcan\_Selcuk\_Akbul](https://discuss.elastic.co/u/Ogulcan_Selcuk_Akbul)
#### Post date: [February 19, 2014, 6:56pm UTC](https://discuss.elastic.co/t/failed-to-setup-multicast-discovery-on-port-54328-es-cant-connect-to-cluster/15907/1 "2014-02-19T18:56:12Z")

</div>

> [2014-02-19 20:40:58,668][INFO][node]  
> [elastic\_inst2] {0.90.0.Beta1}[1368]: initializing ...  
> [2014-02-19 20:40:58,676][INFO][plugins]  
> [elastic\_inst2] loaded , sites   
> [2014-02-19 20:41:01,402][INFO][node]  
> [elastic\_inst2] {0.90.0.Beta1}[1368]: initialized  
> [2014-02-19 20:41:01,403][INFO][node]  
> [elastic\_inst2] {0.90.0.Beta1}[1368]: starting ...  
> [2014-02-19 20:41:01,501][INFO][transport]  
> [elastic\_inst2] bound\_address {inet[/0:0:0:0:0:0:0:0:9301]},  
> publish\_address {inet[/192.168.2.130:9301]}  
> [2014-02-19 20:41:01,521][WARN][discovery.zen.ping.multicast]  
> [elastic\_inst2] disabled, failed to setup multicast discovery on port  
> [54328], [/192.168.2.130]: Invalid argument  
> [2014-02-19 20:41:04,563][INFO][cluster.service]  
> [elastic\_inst2] new\_master  
> [elastic\_inst2][VVoWrIc4QRuiSo9-0lhd1g][inet[/192.168.2.130:9301]], reason:  
> zen-disco-join (elected\_as\_master)  
> [2014-02-19 20:41:04,595][INFO][discovery]  
> [elastic\_inst2] elasticsearch\_dc1/VVoWrIc4QRuiSo9-0lhd1g  
> [2014-02-19 20:41:05,573][INFO][http]  
> [elastic\_inst2] bound\_address {inet[/0:0:0:0:0:0:0:0:9201]},  
> publish\_address {inet[/192.168.2.130:9201]}  
> [2014-02-19 20:41:05,573][INFO][node]  
> [elastic\_inst2] {0.90.0.Beta1}[1368]: started  
> [2014-02-19 20:41:05,576][INFO][gateway]  
> [elastic\_inst2] recovered [0] indices into cluster\_state

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/507affac-fe3f-4501-ad4d-6a8c4a5672fb%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/507affac-fe3f-4501-ad4d-6a8c4a5672fb%40googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [February 24, 2014, 12:59pm UTC](https://discuss.elastic.co/t/failed-to-setup-multicast-discovery-on-port-54328-es-cant-connect-to-cluster/15907/2 "2014-02-24T12:59:13Z")

</div>

Hey,

first, you should really upgrade elasticsearch, this is quite an old beta  
version.  
Second, if you are using something like amazon ec2, multicast is disabled.  
You might want to test with unicast in that case, see

> **[Elasticsearch Platform — Find real-time answers at scale](https://www.elastic.co)**
>
> Power insights and outcomes with the Elasticsearch Platform and AI. See into your data and find answers that matter with enterprise solutions designed to help you build, observe, and protect. Try Elasticsearch free today.

--Alex

On Wed, Feb 19, 2014 at 7:56 PM, Oğulcan Selcuk Akbulut [gaplan@gmail.com](mailto:gaplan@gmail.com)wrote:

> [2014-02-19 20:40:58,668][INFO][node]
> 
> > [elastic\_inst2] {0.90.0.Beta1}[1368]: initializing ...  
> > [2014-02-19 20:40:58,676][INFO][plugins]  
> > [elastic\_inst2] loaded , sites   
> > [2014-02-19 20:41:01,402][INFO][node]  
> > [elastic\_inst2] {0.90.0.Beta1}[1368]: initialized  
> > [2014-02-19 20:41:01,403][INFO][node]  
> > [elastic\_inst2] {0.90.0.Beta1}[1368]: starting ...  
> > [2014-02-19 20:41:01,501][INFO][transport]  
> > [elastic\_inst2] bound\_address {inet[/0:0:0:0:0:0:0:0:9301]},  
> > publish\_address {inet[/192.168.2.130:9301]}  
> > [2014-02-19 20:41:01,521][WARN][discovery.zen.ping.multicast]  
> > [elastic\_inst2] disabled, failed to setup multicast discovery on port  
> > [54328], [/192.168.2.130]: Invalid argument  
> > [2014-02-19 20:41:04,563][INFO][cluster.service]  
> > [elastic\_inst2] new\_master  
> > [elastic\_inst2][VVoWrIc4QRuiSo9-0lhd1g][inet[/192.168.2.130:9301]],  
> > reason: zen-disco-join (elected\_as\_master)  
> > [2014-02-19 20:41:04,595][INFO][discovery]  
> > [elastic\_inst2] elasticsearch\_dc1/VVoWrIc4QRuiSo9-0lhd1g  
> > [2014-02-19 20:41:05,573][INFO][http]  
> > [elastic\_inst2] bound\_address {inet[/0:0:0:0:0:0:0:0:9201]},  
> > publish\_address {inet[/192.168.2.130:9201]}  
> > [2014-02-19 20:41:05,573][INFO][node]  
> > [elastic\_inst2] {0.90.0.Beta1}[1368]: started  
> > [2014-02-19 20:41:05,576][INFO][gateway]  
> > [elastic\_inst2] recovered [0] indices into cluster\_state
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/507affac-fe3f-4501-ad4d-6a8c4a5672fb%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/507affac-fe3f-4501-ad4d-6a8c4a5672fb%40googlegroups.com)  
> .  
> For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CAGCwEM8t%3DPTOV%3DGLGyPnvX-zbN910NmR\_GW6FmVb%3DBy9ZOVMjA%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAGCwEM8t%3DPTOV%3DGLGyPnvX-zbN910NmR_GW6FmVb%3DBy9ZOVMjA%40mail.gmail.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:47am UTC](https://discuss.elastic.co/t/failed-to-setup-multicast-discovery-on-port-54328-es-cant-connect-to-cluster/15907/3 "2017-07-06T01:47:50Z")

</div>


