# Failed to start Beats services, including filebeat, topbeat

**URL:** https://discuss.elastic.co/t/failed-to-start-beats-services-including-filebeat-topbeat/45925
**Category:** Beats
**Tags:** filebeat
**Created:** [March 31, 2016, 11:21am UTC](https://discuss.elastic.co/t/failed-to-start-beats-services-including-filebeat-topbeat/45925 "2016-03-31T11:21:54Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![usahitya](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/usahitya/32/6180_2.png) [@usahitya](https://discuss.elastic.co/u/usahitya)
#### Post date: [March 31, 2016, 11:21am UTC](https://discuss.elastic.co/t/failed-to-start-beats-services-including-filebeat-topbeat/45925/1 "2016-03-31T11:21:54Z")

</div>

HI Team,

I am working on Beats especially with Topbeat and Filebeat. when I am installing services running successfully, but if I modify in configuration file and restart it, then giving the below error.

```
[root@Vineet47 log]# service filebeat stauts
Usage: /etc/init.d/filebeat {start|stop|status|restart|condrestart}
[root@Vineet47 log]# service filebeat status
filebeat.service - filebeat
   Loaded: loaded (/usr/lib/systemd/system/filebeat.service; enabled)
   Active: failed (Result: start-limit) since Thu 2016-03-31 17:55:12 IST; 1min 12s ago
     Docs: https://www.elastic.co/guide/en/beats/filebeat/current/index.html
 Main PID: 14090 (code=exited, status=1/FAILURE)

Mar 31 17:55:12 Vineet47 systemd[1]: filebeat.service: main process exited, code=exited, status=1/FAILURE
Mar 31 17:55:12 Vineet47 systemd[1]: Unit filebeat.service entered failed state.
Mar 31 17:55:12 Vineet47 systemd[1]: filebeat.service holdoff time over, scheduling restart.
Mar 31 17:55:12 Vineet47 systemd[1]: Stopping filebeat...
Mar 31 17:55:12 Vineet47 systemd[1]: Starting filebeat...
Mar 31 17:55:12 Vineet47 systemd[1]: filebeat.service start request repeated too quickly, refusing to start.
Mar 31 17:55:12 Vineet47 systemd[1]: Failed to start filebeat.
Mar 31 17:55:12 Vineet47 systemd[1]: Unit filebeat.service entered failed state.

```

Can I should restart the service filebeat or topbeat after changes in configurations? or they take changes automatically?

regards,  
sahitya

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [March 31, 2016, 11:30am UTC](https://discuss.elastic.co/t/failed-to-start-beats-services-including-filebeat-topbeat/45925/2 "2016-03-31T11:30:49Z")

</div>

Are there any clues in the Filebeat log?

---

<div class="post-metadata">

### Author: ![usahitya](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/usahitya/32/6180_2.png) [@usahitya](https://discuss.elastic.co/u/usahitya)
#### Post date: [March 31, 2016, 12:25pm UTC](https://discuss.elastic.co/t/failed-to-start-beats-services-including-filebeat-topbeat/45925/3 "2016-03-31T12:25:11Z")

</div>

which clue? what is that?

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [March 31, 2016, 12:27pm UTC](https://discuss.elastic.co/t/failed-to-start-beats-services-including-filebeat-topbeat/45925/4 "2016-03-31T12:27:10Z")

</div>

Something, for example an error message, that would indicate why Filebeat refuses to start.

---

<div class="post-metadata">

### Author: ![usahitya](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/usahitya/32/6180_2.png) [@usahitya](https://discuss.elastic.co/u/usahitya)
#### Post date: [April 1, 2016, 7:02am UTC](https://discuss.elastic.co/t/failed-to-start-beats-services-including-filebeat-topbeat/45925/5 "2016-04-01T07:02:41Z")

</div>

When I am starting the Filebeats , getting the below error

```
 service topbeat start
Starting topbeat (via systemctl): [OK]
[root@vineet45 topbeat]# service topbeat status
topbeat.service - topbeat
   Loaded: loaded (/usr/lib/systemd/system/topbeat.service; enabled)
   Active: failed (Result: start-limit) since Fri 2016-04-01 04:06:09 EDT; 11s ago
     Docs: https://www.elastic.co/guide/en/beats/topbeat/current/index.html
  Process: 38488 ExecStart=/usr/bin/topbeat -c /etc/topbeat/topbeat.yml (code=exited, status=1/FAILURE)
 Main PID: 38488 (code=exited, status=1/FAILURE)

Apr 01 04:06:09 vineet45 systemd[1]: topbeat.service: main process exited, code=exited, status=1/FAILURE
Apr 01 04:06:09 vineet45 systemd[1]: Unit topbeat.service entered failed state.
Apr 01 04:06:09 vineet45 systemd[1]: topbeat.service holdoff time over, scheduling restart.
Apr 01 04:06:09 vineet45 systemd[1]: Stopping topbeat...
Apr 01 04:06:09 vineet45 systemd[1]: Starting topbeat...
Apr 01 04:06:09 vineet45 systemd[1]: topbeat.service start request repeated too quickly, refusing to start.
Apr 01 04:06:09 vineet45 systemd[1]: Failed to start topbeat.
Apr 01 04:06:09 vineet45 systemd[1]: Unit topbeat.service entered failed state.

```

and

when I installed it, its working fine!

changed the config file for Logstash as output and restarted it then it giving the above error.

I suspected my self and keep the # in front of all changes what i done. But this error still persists. could you please help me with above error lines.

interestingly, same problem with Topbeat also.

Cheers!  
sahitya

---

<div class="post-metadata">

### Author: ![steffens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/steffens/32/79630_2.png) [@steffens](https://discuss.elastic.co/u/steffens)
#### Post date: [April 1, 2016, 11:16am UTC](https://discuss.elastic.co/t/failed-to-start-beats-services-including-filebeat-topbeat/45925/6 "2016-04-01T11:16:16Z")

</div>

can you please post the log files written by topbeat/filebeat?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 9:53pm UTC](https://discuss.elastic.co/t/failed-to-start-beats-services-including-filebeat-topbeat/45925/7 "2017-07-05T21:53:57Z")

</div>


