# Failed to start crawler: starting input failed: error while initializing input: No paths were defined for input accessing

**URL:** <https://discuss.elastic.co/t/failed-to-start-crawler-starting-input-failed-error-while-initializing-input-no-paths-were-defined-for-input-accessing/345085>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [October 16, 2023, 9:29am UTC](https://discuss.elastic.co/t/failed-to-start-crawler-starting-input-failed-error-while-initializing-input-no-paths-were-defined-for-input-accessing/345085 "2023-10-16T09:29:27Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Manula\_Manjitha](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/manula_manjitha/32/126017_2.png) [@Manula\_Manjitha](https://discuss.elastic.co/u/Manula_Manjitha)\
**Post date:** [October 16, 2023, 9:29am UTC](https://discuss.elastic.co/t/failed-to-start-crawler-starting-input-failed-error-while-initializing-input-no-paths-were-defined-for-input-accessing/345085/1 "2023-10-16T09:29:27Z")

</div>

I have configured two filebeat inputs which the type of them is **log**.

```auto
filebeat.inputs:
- type: log
  id: gateway-elk
  enabled: true
  paths:
    - /home/ggg/app/ntp_gateway/gateway-elk.log

  fields: {log_type: gatewaylog_analyzed}

- type: log
  id: auralog_analyzed
  enabled: true
  paths:
    - /home/ggg/app/ntp_bos/logs/elk.log

  fields: {log_type: auralog_analyzed}
  
  bulk_max_size: 4096

- add_id: ~

logging.level: info
logging.to_files: true
logging.files:
  path: /var/log/filebeat
  name: filebeat
  keepfiles: 7
  permissions: 0644

```

But when I start the service, though the service get started, in the server journal, following error message shows up.

```auto
Oct 16 14:47:38 ANBC-NTP-HA-SVR01 systemd[1]: Started Filebeat sends log files to Logstash or directly to Elasticsearch..
Oct 16 14:47:42 ANBC-NTP-HA-SVR01 filebeat[1353431]: Exiting: Failed to start crawler: starting input failed: error while initializing input: No paths were defined for input accessing 'filebeat.inputs.2' (source:'/etc/filebeat/filebeat.yml')
Oct 16 14:47:42 ANBC-NTP-HA-SVR01 systemd[1]: filebeat.service: Main process exited, code=exited, status=1/FAILURE
Oct 16 14:47:42 ANBC-NTP-HA-SVR01 systemd[1]: filebeat.service: Failed with result 'exit-code'.
Oct 16 14:47:42 ANBC-NTP-HA-SVR01 systemd[1]: filebeat.service: Service RestartSec=100ms expired, scheduling restart.
Oct 16 14:47:42 ANBC-NTP-HA-SVR01 systemd[1]: filebeat.service: Scheduled restart job, restart counter is at 194.
Oct 16 14:47:42 ANBC-NTP-HA-SVR01 systemd[1]: Stopped Filebeat sends log files to Logstash or directly to Elasticsearch..

```

Files that I have mentioned as inputs exist and logs are printed on them continuously as well. And also, those files have read permission for user, group and organization.

Can anyone please give me support on this?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 13, 2023, 11:29am UTC](https://discuss.elastic.co/t/failed-to-start-crawler-starting-input-failed-error-while-initializing-input-no-paths-were-defined-for-input-accessing/345085/2 "2023-11-13T11:29:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
