# Failed to start Elasticcluster after adding trial license

**URL:** https://discuss.elastic.co/t/failed-to-start-elasticcluster-after-adding-trial-license/150780
**Category:** Elasticsearch
**Created:** [October 3, 2018, 12:21am UTC](https://discuss.elastic.co/t/failed-to-start-elasticcluster-after-adding-trial-license/150780 "2018-10-03T00:21:15Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![rmadoori](https://avatars.discourse-cdn.com/v4/letter/r/47e85d/32.png) [@rmadoori](https://discuss.elastic.co/u/rmadoori)
#### Post date: [October 3, 2018, 12:21am UTC](https://discuss.elastic.co/t/failed-to-start-elasticcluster-after-adding-trial-license/150780/1 "2018-10-03T00:21:15Z")

</div>

Elastic serach container fails after adding trial license key.. logs doesnt show any specific error.  
Created elasticsearch keystore in /usr/share/elasticsearch/config  
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
[2018-10-02T23:47:23,656][INFO][o.e.n.Node] [es] initializing ...  
[2018-10-02T23:47:23,753][INFO][o.e.e.NodeEnvironment] [es] using [1] data paths, mounts [[/usr/share/elasticsearch/data (/dev/scinic)]], net usable\_space [79.9gb], net total\_space [79.9gb], types [xfs]  
[2018-10-02T23:47:23,754][INFO][o.e.e.NodeEnvironment] [es] heap size [1007.3mb], compressed ordinary object pointers [true]  
[2018-10-02T23:47:23,755][INFO][o.e.n.Node] [es] node name [es], node ID [ZzEsvHGNQfmnOsVd4yJwMA]  
[2018-10-02T23:47:23,755][INFO][o.e.n.Node] [es] version[6.3.0], pid[1], build[default/tar/424e937/2018-06-11T23:38:03.357887Z], OS[Linux/4.17.11-1.el7.elrepo.x86\_64/amd64], JVM["Oracle Corporation"/OpenJDK 64-Bit Server VM/10.0.2/10.0.2+13]  
[2018-10-02T23:47:23,756][INFO][o.e.n.Node] [es] JVM arguments [-Xms1g, -Xmx1g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -XX:-OmitStackTraceInFastThrow, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Djava.io.tmpdir=/tmp/elasticsearch.pSx3v0dd, -XX:+HeapDumpOnOutOfMemoryError, -XX:HeapDumpPath=data, -XX:ErrorFile=logs/hs\_err\_pid%p.log, -Xlog:gc\*,gc+age=trace,safepoint:file=logs/gc.log:utctime,pid,tags:filecount=32,filesize=64m, -Djava.locale.providers=COMPAT, -Des.cgroups.hierarchy.override=/, -Xms1024m, -Xmx1024m, -Des.path.home=/usr/share/elasticsearch, -Des.path.conf=/usr/share/elasticsearch/config, -Des.distribution.flavor=default, -Des.distribution.type=tar]  
[INFO][o.e.p.PluginsService] [es] loaded module [aggs-matrix-stats]  
[INFO][o.e.p.PluginsService] [es] loaded module [analysis-common]  
[INFO][o.e.p.PluginsService] [es] loaded module [ingest-common]  
[o.e.p.PluginsService] [es] loaded module [lang-expression]  
[INFO][o.e.p.PluginsService] [es] loaded module [lang-mustache]  
[INFO][o.e.p.PluginsService] [es] loaded module [lang-painless]  
[INFO][o.e.p.PluginsService] [es] loaded module [mapper-extras]  
-10-02T23:47:25,690][INFO][o.e.p.PluginsService] [es] loaded module [parent-join]  
-02T23:47:25,690][INFO][o.e.p.PluginsService] [es] loaded module [percolator]  
T23:47:25,690][INFO][o.e.p.PluginsService] [es] loaded module [rank-eval]  
2T23:47:25,691][INFO][o.e.p.PluginsService] [es] loaded module [reindex]  
0-02T23:47:25,691][INFO][o.e.p.PluginsService] [es] loaded module [repository-url]  
47:25,691][INFO][o.e.p.PluginsService] [es] loaded module [transport-netty4]  
INFO ][o.e.p.PluginsService] [es] loaded module [tribe]  
[INFO][o.e.p.PluginsService] [es] loaded module [x-pack-core]  
[INFO][o.e.p.PluginsService] [es] loaded module [x-pack-deprecation]  
[INFO][o.e.p.PluginsService] [es] loaded module [x-pack-graph]  
[INFO][o.e.p.PluginsService] [es] loaded module [x-pack-logstash]  
[INFO][o.e.p.PluginsService] [es] loaded module [x-pack-ml]  
[INFO][o.e.p.PluginsService] [es] loaded module [x-pack-monitoring]  
[INFO][o.e.p.PluginsService] [es] loaded module [x-pack-rollup]  
[INFO][o.e.p.PluginsService] [es] loaded module [x-pack-security]  
[INFO][o.e.p.PluginsService] [es] loaded module [x-pack-sql]  
[INFO][o.e.p.PluginsService] [es] loaded module [x-pack-upgrade]  
[INFO][o.e.p.PluginsService] [es] loaded module [x-pack-watcher]  
INFO ][o.e.p.PluginsService] [es] no plugins loaded

---

<div class="post-metadata">

### Author: ![rmadoori](https://avatars.discourse-cdn.com/v4/letter/r/47e85d/32.png) [@rmadoori](https://discuss.elastic.co/u/rmadoori)
#### Post date: [October 3, 2018, 12:21am UTC](https://discuss.elastic.co/t/failed-to-start-elasticcluster-after-adding-trial-license/150780/2 "2018-10-03T00:21:44Z")

</div>

18-10-02T23:47:29,002][INFO][o.e.x.s.a.s.FileRolesStore] [es] parsed [0] roles from file [/usr/share/elasticsearch/config/roles.yml]  
018-10-02T23:47:29,797][INFO][o.e.d.DiscoveryModule] [es] using discovery type [zen]  
T23:47:30,315][INFO][o.e.n.Node] [es] initialized  
2018-10-02T23:47:30,315][INFO][o.e.n.Node] [es] starting ...  
[2018-10-02T23:47:30,471][INFO][o.e.t.TransportService] [es] publish\_address {172.16.xx.xx:9300}, bound\_addresses {[::]:9300}  
[2018-10-02T23:47:30,489][INFO][o.e.b.BootstrapChecks] [es] bound or publishing to a non-loopback address, enforcing bootstrap checks  
[2018-10-02T23:47:33,530][INFO][o.e.c.s.MasterService] [es] zen-disco-elected-as-master ([0] nodes joined)[,], reason: new\_master {es}{ZzEsvHGNQfmnOsVd4yJwMA}{XDlxOFRaRJmFVmOtrtZp7g}{172.16.xx.xx}{172.16.xx.xx:9300}{xpack.installed=true}  
[2018-10-02T23:47:33,535][INFO][o.e.c.s.ClusterApplierService] [es] new\_master {es}{ZzEsvHGNQfmnOsVd4yJwMA}{XDlxOFRaRJmFVmOtrtZp7g}{172.16.xx.xx}{172.16.xx.xx:9300}{xpack.installed=true}, reason: apply cluster state (from master [master {es}{ZzEsvHGNQfmnOsVd4yJwMA}{XDlxOFRaRJmFVmOtrtZp7g}{172.16.xx.xx}{172.16.xx.xx:9300}{xpack.installed=true} committed version [1] source [zen-disco-elected-as-master ([0] nodes joined)[,]]])  
[2018-10-02T23:47:33,556][INFO][o.e.x.s.t.n.SecurityNetty4HttpServerTransport] [es] publish\_address {172.16.xx.xx:9200}, bound\_addresses {[::]:9200}  
[2018-10-02T23:47:33,556][INFO][o.e.n.Node] [es] started  
[INFO][o.e.g.GatewayService] [es] recovered [0] indices into cluster\_state  
[INFO][o.e.c.m.MetaDataIndexTemplateService] [es] adding template [.triggered\_watches] for index patterns [.triggered\_watches\*]  
[INFO][o.e.c.m.MetaDataIndexTemplateService] [es] adding template [.watches] for index patterns [.watches\*]  
[INFO][o.e.c.m.MetaDataIndexTemplateService] [es] adding template [.watch-history-7] for index patterns [.watcher-history-7\*]  
[INFO][o.e.c.m.MetaDataIndexTemplateService] [es] adding template [.monitoring-logstash] for index patterns [.monitoring-logstash-6-_]  
[INFO][o.e.c.m.MetaDataIndexTemplateService] [es] adding template [.monitoring-es] for index patterns [.monitoring-es-6-_]  
[INFO][o.e.c.m.MetaDataIndexTemplateService] [es] adding template [.monitoring-alerts] for index patterns [.monitoring-alerts-6]  
[INFO][o.e.c.m.MetaDataIndexTemplateService] [es] adding template [.monitoring-beats] for index patterns [.monitoring-beats-6-_]  
[INFO][o.e.c.m.MetaDataIndexTemplateService] [es] adding template [.monitoring-kibana] for index patterns [.monitoring-kibana-6-_]  
[INFO][o.e.l.LicenseService] [es] license [11472ae9-d6ff-425a-b11f-7e31eaf31f9a] mode [basic] - valid  
[INFO][o.e.c.s.MasterService] [es] zen-disco-node-join, reason: added {{es-data}{nH2d7RGUSoSJZG-b9gElsw}{l83Nhg2TQ7-sZ-KnVPTvLA}{172.16.xx.xx}{172.16.xx.xx:9300}{ml.machine\_memory=3145728000, ml.max\_open\_jobs=20, xpack.installed=true, ml.enabled=true},}  
[INFO][o.e.c.s.ClusterApplierService] [es] added {{es-data}{nH2d7RGUSoSJZG-b9gElsw}{l83Nhg2TQ7-sZ-KnVPTvLA}{172.16.xx.xx}{172.16.xx.xx:9300}{ml.machine\_memory=3145728000, ml.max\_open\_jobs=20, xpack.installed=true, ml.enabled=true},}, reason: apply cluster state (from master [master {es}{ZzEsvHGNQfmnOsVd4yJwMA}{XDlxOFRaRJmFVmOtrtZp7g}{172.16.xx.xx}{172.16.xx.xx:9300}{xpack.installed=true} committed version [15] source [zen-disco-node-join]])  
[INFO][o.e.c.s.MasterService] [es] zen-disco-node-join, reason: added {{es-data}{JLL7GVfNQrK1N29RKB-R9A}{WRZDV4i0TkGu2TSNvhHzCw}{172.16.xx.xx}{172.16.xx.xx:9300}{ml.machine\_memory=3145728000, ml.max\_open\_jobs=20, xpack.installed=true, ml.enabled=true},}  
[INFO][o.e.c.s.ClusterApplierService] [es] added {{es-data}{JLL7GVfNQrK1N29RKB-R9A}{WRZDV4i0TkGu2TSNvhHzCw}{172.16.xx.xx}{172.16.xx.xx:9300}{ml.machine\_memory=3145728000, ml.max\_open\_jobs=20, xpack.installed=true, ml.enabled=true},}, reason: apply cluster state (from master [master {es}{ZzEsvHGNQfmnOsVd4yJwMA}{XDlxOFRaRJmFVmOtrtZp7g}{172.16.xx.xx}{172.16.xx.xx:9300}{xpack.installed=true} committed version [16] source [zen-disco-node-join]])  
[INFO][o.e.l.LicenseService] [es] license [86604741-f8f0-4874-8cf0-ee2f46ecd408] mode [trial] - valid  
[o.e.n.Node] [es] stopping ...  
[INFO][o.e.x.w.WatcherService] [es] stopping watch service, reason [shutdown initiated]  
[INFO][o.e.n.Node] [es] stopped  
[INFO][o.e.n.Node] [es] closing ...  
[INFO][o.e.n.Node] [es] closed

---

<div class="post-metadata">

### Author: ![rmadoori](https://avatars.discourse-cdn.com/v4/letter/r/47e85d/32.png) [@rmadoori](https://discuss.elastic.co/u/rmadoori)
#### Post date: [October 3, 2018, 12:23am UTC](https://discuss.elastic.co/t/failed-to-start-elasticcluster-after-adding-trial-license/150780/3 "2018-10-03T00:23:27Z")

</div>

Command i used to add the trial license:

curl -XPUT '[http://es-master:9200/\_xpack/license](http://es-master:9200/_xpack/license)' -H "Content-Type: application/json" -d @license.json

i Only added tial license to my master node and once i add the trial license it exits i am running in elastic search cluster with master and data nodes is there a documentation on how to setup elastic cluster with xpack trial license

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [October 3, 2018, 10:16am UTC](https://discuss.elastic.co/t/failed-to-start-elasticcluster-after-adding-trial-license/150780/4 "2018-10-03T10:16:44Z")

</div>

Please use the code button `</>` to format data like logs, it makes it much easier to read.

You don't need to apply a trial license from 6.3.0 onwards, it comes with a basic license enabled.

> [@rmadoori](#):
>
> [o.e.n.Node] [es] stopping ...  
> [INFO][o.e.x.w.WatcherService] [es] stopping watch service, reason [shutdown initiated]

That suggests that something is asking Elasticsearch to stop, Elasticsearch cannot just stop itself.

---

<div class="post-metadata">

### Author: ![rmadoori](https://avatars.discourse-cdn.com/v4/letter/r/47e85d/32.png) [@rmadoori](https://discuss.elastic.co/u/rmadoori)
#### Post date: [October 3, 2018, 4:15pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticcluster-after-adding-trial-license/150780/5 "2018-10-03T16:15:49Z")

</div>

Hi,

Thanks For the response.  
Whats the difference between basic license and trial license??

Thanks

---

<div class="post-metadata">

### Author: ![rmadoori](https://avatars.discourse-cdn.com/v4/letter/r/47e85d/32.png) [@rmadoori](https://discuss.elastic.co/u/rmadoori)
#### Post date: [October 3, 2018, 4:17pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticcluster-after-adding-trial-license/150780/6 "2018-10-03T16:17:05Z")

</div>

I set the log level to debug and i see this error `org.elasticsearch.ElasticsearchSecurityException: missing authentication token for REST request [/] at org.elasticsearch.xpack.core.security.support.Exceptions.authenticationError(Exceptions.java:24) ~[x-pack-core-6.3.0.jar:6.3.0] at org.elasticsearch.xpack.core.security.authc.DefaultAuthenticationFailureHandler.missingToken(DefaultAuthenticationFailureHandler.java:57) ~[x-pack-core-6.3.0.jar:6.3.0] at org.elasticsearch.xpack.security.authc.AuthenticationService$AuditableRestRequest.anonymousAccessDenied(AuthenticationService.java:586) ~[x-pack-security-6.3.0.jar:6.3.0]`

---

<div class="post-metadata">

### Author: ![rmadoori](https://avatars.discourse-cdn.com/v4/letter/r/47e85d/32.png) [@rmadoori](https://discuss.elastic.co/u/rmadoori)
#### Post date: [October 3, 2018, 6:11pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticcluster-after-adding-trial-license/150780/7 "2018-10-03T18:11:51Z")

</div>

I wanted to use trial license instead of basic license since security futures are not available in basic license

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [October 3, 2018, 10:32pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticcluster-after-adding-trial-license/150780/8 "2018-10-03T22:32:52Z")

</div>

You can see the differences here [https://www.elastic.co/subscriptions](https://www.elastic.co/subscriptions)

---

<div class="post-metadata">

### Author: ![rmadoori](https://avatars.discourse-cdn.com/v4/letter/r/47e85d/32.png) [@rmadoori](https://discuss.elastic.co/u/rmadoori)
#### Post date: [October 3, 2018, 10:46pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticcluster-after-adding-trial-license/150780/9 "2018-10-03T22:46:47Z")

</div>

I was able to get around it but i having new issue now

`Path: /_xpack/security/_authenticate, params: {pretty=, index=_xpack, id=_authenticate, type=security} org.elasticsearch.index.IndexNotFoundException: no such index`

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 31, 2018, 10:46pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticcluster-after-adding-trial-license/150780/10 "2018-10-31T22:46:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
