# Failed to start Elasticsearch 8.2 on CentOSs

**URL:** <https://discuss.elastic.co/t/failed-to-start-elasticsearch-8-2-on-centoss/305072>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [May 18, 2022, 12:54pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-8-2-on-centoss/305072 "2022-05-18T12:54:17Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Bhanu\_1212](https://avatars.discourse-cdn.com/v4/letter/b/da6949/32.png) [@Bhanu\_1212](https://discuss.elastic.co/u/Bhanu_1212)\
**Post date:** [May 18, 2022, 12:54pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-8-2-on-centoss/305072/1 "2022-05-18T12:54:17Z")

</div>

```auto
[2022-05-18T12:41:58,264][INFO][o.e.e.NodeEnvironment] [elastic-centos] heap size [7.7gb], compressed ordinary object pointers [true]
[2022-05-18T12:41:58,351][INFO][o.e.n.Node] [elastic-centos] node name [elastic-centos], node ID [ucAJuc9PS7uH5Dp-kPAj5w], cluster name [elasticsearch], roles [ingest, data_frozen, ml, data_hot, transform, data_content, data_warm, master, remote_cluster_client, data, data_cold]
[2022-05-18T12:42:04,901][ERROR][o.e.b.Bootstrap] [elastic-centos] Exception
org.elasticsearch.ElasticsearchSecurityException: invalid configuration for xpack.security.transport.ssl - [xpack.security.transport.ssl.enabled] is not set, but the following settings have been configured in elasticsearch.yml : [xpack.security.transport.ssl.keystore.secure_password,xpack.security.transport.ssl.truststore.secure_password]

```

It's strange that this error occurs, none of these are present in the yml file.

Steps to replicate this issue: [Install Elasticsearch with RPM | Elasticsearch Guide [8.2] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/rpm.html)

1. Repo creation-\> `elasticsearch.repo` in the `/etc/yum.repos.d/` directory
2. rpm import -\> rpm --import [https://artifacts.elastic.co/GPG-KEY-elasticsearch](https://artifacts.elastic.co/GPG-KEY-elasticsearch)
3. sudo yum install --enablerepo=Elasticsearch Elasticsearch
4. no change in default elasticsesrch.yml file
5. sudo systemctl start Elasticsearch

content of Elasticsearch-keystore

```auto
[azureuser@elastic-centos ~]$ sudo /usr/share/elasticsearch/bin/elasticsearch-keystore list
autoconfiguration.password_hash
keystore.seed
xpack.security.http.ssl.keystore.secure_password
xpack.security.transport.ssl.keystore.secure_password
xpack.security.transport.ssl.truststore.secure_password

```

---

<div class="post-metadata">

**Author:** ![ibra\_013](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ibra_013/32/104827_2.png) [@ibra\_013](https://discuss.elastic.co/u/ibra_013)\
**Post date:** [May 18, 2022, 1:42pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-8-2-on-centoss/305072/2 "2022-05-18T13:42:38Z")

</div>

Hi,

have you done the below step,

```auto

echo "keystore_password" > /path/to/my_pwd_file.tmp
chmod 600 /path/to/my_pwd_file.tmp
sudo systemctl set-environment ES_KEYSTORE_PASSPHRASE_FILE=/path/to/my_pwd_file.tmp
sudo systemctl start elasticsearch.service

```

> **[Starting Elasticsearch | Elasticsearch Guide \[8.2\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/starting-elasticsearch.html#start-es-rpm-systemd)**

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 19, 2022, 4:24am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-8-2-on-centoss/305072/3 "2022-05-19T04:24:31Z")

</div>

Welcome to our community! 😃

Please don't post pictures of text, logs or code. They are difficult to read, impossible to search and replicate (if it's code), and some people may not be even able to see them 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 16, 2022, 4:25am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-8-2-on-centoss/305072/4 "2022-06-16T04:25:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
